Jump to content

Sign in to follow this  
NBouc

ASX: C++ runtime error when executing XEngine.exe

Recommended Posts

Hi, I installed ASX but I can't even start the program. When the program is launched, it immediatly generate the following error:Microsoft Visual C++ Runtime LibraryRuntime error !Program D:HiFiXEngineXEngine.exeAbnormal program terminationI have .NET Framework 2.0 and Visual C++ 2005 SP1 installed, on Windows XP and FSX SP1. What could be the problem ?Installing ASX in the default path (C:Program Files...) gives the same result. Any idea ??


 

Normand Boucher

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Samsung 970 EVO M.2 SSD 500GB (OS) + Samsung 850 EVO SSD 1TB  (P3D) / Prepar3D V4.5 / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Hi,We've not heard of this error before.ASX does not use the C++ Runtime Library but SimConnect does, so I suspect something is wrong with this setup.Have you tried uninstalling SP1 and reinstalling? This may cure it.Sorry we don't have more help on this yet, but we will be actively investigating and providing more info as we learn more.Best,


Damian Clark
HiFi  Simulation Technologies

Share this post


Link to post
Share on other sites

Thank you for the advice regarding SimConnect. I have uninstalled FSX SP1, then re-installed FSX SP1: NO GO, still having the C++ error.I then updated the SDK (SP1A) and installed the SimConect client from the .MSI in the SDK: NO GO, still having the C++ error.I have no idea what to try next.


 

Normand Boucher

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Samsung 970 EVO M.2 SSD 500GB (OS) + Samsung 850 EVO SSD 1TB  (P3D) / Prepar3D V4.5 / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Hi again,Ok.. after some research here are some recommendations:- Make sure you have the latest windows updates- If running McAfee or Norton AV make sure you have updated your software to the latest versions, have latest definitions, and run a full system scan- If you have google toolbar installed in IE, disable it (toolbar options) as it is no longer compatible in some circumstances (ASX uses IE-based internet components which could potentially cause this)Please let us know. FWIW this is the only report of this, so it is very obscure and system-specific. Best,


Damian Clark
HiFi  Simulation Technologies

Share this post


Link to post
Share on other sites

Thank you Damian for the recommandations. I have the latest Windows XP updates, and I don't have McAfee, Norton AV nor the Google Toolbar installed. The problem is very obscure to me too, may be it's time for a "Format C:" ;-)I wish I can fix this soon.Best regards,


 

Normand Boucher

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Samsung 970 EVO M.2 SSD 500GB (OS) + Samsung 850 EVO SSD 1TB  (P3D) / Prepar3D V4.5 / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Damian,My problem is solved. Thank's to Thomy (Ubootwolf) who found the solution on june 7th.Matrox PowerDesk SE for the DualHead2Go and TripleHead2Go boxes. After turning off the PowerDesk SE utility, ASX works like a charm.Thank you to all HiFi team for such a neat software.


 

Normand Boucher

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Samsung 970 EVO M.2 SSD 500GB (OS) + Samsung 850 EVO SSD 1TB  (P3D) / Prepar3D V4.5 / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...