Jump to content

Sign in to follow this  
Guest triangle

ASX SimConnect has broken my TrackIR?

Recommended Posts

Guest triangle

Since successfully setting up ASX on a client PC using SimConnect, my TrackIR no longer recognises FSX.I have blown away the two SimConnect folders in the C:WindowsWinSxS folder, uninstalled SP1, run a repair and reinstalled SP1 to no avail.Any advice?ThanksAndrew

Share this post


Link to post
Share on other sites
Guest triangle

Sorry, Jim, which link? I was relying on my previous experience with a TrackIR problem (the NaturalPoint forums advised to do as I did and last time it worked but not this time).ThanksAndrew

Share this post


Link to post
Share on other sites
Guest triangle

I think, Jim, you are referring to a post i made about deleting the SimConnect folders, running a repair and reinstalling SP1. Yes I have done this several times with no success. It is very odd ...Andrew

Share this post


Link to post
Share on other sites
Guest triangle

Ok - found the source of the problem but don't know how to fix it.I read up on TrackIR and found that it needs to connect to the localhost on 127.0.0.1. I realised that, possibly, the SimConnect XML file (which contains an IP destination for my server of 192.168.0.200) might be causing the problem so I removed the file from the folder, ran FSX and TrackIR works fine.Problem, of course, is that I can't use the SimConnect client without that file in its folder ... any ideas on how to resolve this apparent conflict? In the menatime, i'll just run ASX locally ...ThanksAndrew

Share this post


Link to post
Share on other sites

Hi Andrew,Ok... what you need are two comm sections in the .xml file, one for local (with 127.0.0.1), one for global scope (192.168.0.200). Should be fairly straight forward... Let me know if you have any trouble.Best,


Damian Clark
HiFi  Simulation Technologies

Share this post


Link to post
Share on other sites
Guest triangle

Bang on Damian - that fixed it!!!Like I said in an earlier thread, your support (and your products!) are absolutely first class. Absolutely loving ASX and it's extraordinary to have a problem fixed by support on the same day it arises.Might want to add this issue to the FAQ ....Again, thanks heaps!!Andrew

Share this post


Link to post
Share on other sites

I am having te same problem with Track IR4 I'll give that a shot also. I assume I just copy and paste the line and edit it to local ( as it was originally I believe). Jim/Damian ... if that's the case maybe the doc's should readt to add a comm line and edit it to add in the global settng. That way this won't be an ongoing support question or issueThanks for being the "BEST" Support in the Universe. As a customer I hope I speak for everyone when I say I always feel like I am valued customer each and every time I have a question or problem ( which is very infrequent)Hank ADam

Share this post


Link to post
Share on other sites
Guest triangle

Here is how SimConnect.xml should look (the 192.168.0.200 should obviously be your machine's LAN address):<?xml version="1.0" encoding="Windows-1252"?>SimConnectSimConnect.xmlFalseFalseIPv4global

192.168.0.200
645004096FalseFalseIPv4local
127.0.0.1
645004096FalseAndrew

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...