Sign in to follow this  
Joe L

IndexOutOfRangeException

Recommended Posts

Finished my first complete flight. At the very end, after deplaning was complete I received an "Index Out of Range" error, with the option to continue or quit. I tried continue but the error just kept coming back.Also, I see in another thread the mentions of "XPAX.cfg" file - I did a system search and found no such file on either my main FS computer or the client I'm running XPax from (FS9).Thanks.Joe Lorencerror details:See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.************** Exception Text **************System.IndexOutOfRangeException: Index was outside the bounds of the array. at XPax.Main_Control.Timer1_Tick(Object sender, EventArgs e) at System.Windows.Forms.Timer.OnTick(EventArgs e) at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)************** Loaded Assemblies **************mscorlib Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll----------------------------------------XPax_Engine Assembly Version: 1.0.0.14 Win32 Version: 1.0.0.14 CodeBase: file:///D:/Program%20Files/HiFi/XPax/XPax_Engine.exe----------------------------------------Microsoft.VisualBasic Assembly Version: 8.0.0.0 Win32 Version: 8.0.50727.42 (RTM.050727-4200) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll----------------------------------------System Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll----------------------------------------System.Windows.Forms Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll----------------------------------------System.Drawing Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll----------------------------------------System.Runtime.Remoting Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll----------------------------------------XPax Assembly Version: 1.0.0.312 Win32 Version: 1.0.0.312 CodeBase: file:///D:/Program%20Files/HiFi/XPax/XPax.DLL----------------------------------------Interop.Scripting Assembly Version: 1.0.0.0 Win32 Version: 1.0.0.0 CodeBase: file:///D:/Program%20Files/HiFi/XPax/Interop.Scripting.DLL----------------------------------------HiFiSimControls Assembly Version: 1.1.0.1 Win32 Version: 1.1.0.1 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiSimControls.DLL----------------------------------------AxInterop.WMPLib Assembly Version: 1.0.0.0 Win32 Version: 1.0.0.0 CodeBase: file:///D:/Program%20Files/HiFi/XPax/AxInterop.WMPLib.DLL----------------------------------------Interop.WMPLib Assembly Version: 1.0.0.0 Win32 Version: 1.0.0.0 CodeBase: file:///D:/Program%20Files/HiFi/XPax/Interop.WMPLib.DLL----------------------------------------HiFiUtil Assembly Version: 1.0.0.4 Win32 Version: 1.0.0.4 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiUtil.DLL----------------------------------------HiFiLic Assembly Version: 1.0.0.4 Win32 Version: 1.0.0.4 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiLic.DLL----------------------------------------System.DirectoryServices Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.42 (RTM.050727-4200) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.DirectoryServices/2.0.0.0__b03f5f7f11d50a3a/System.DirectoryServices.dll----------------------------------------HiFiSimInterface Assembly Version: 1.0.0.4 Win32 Version: 1.0.0.4 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiSimInterface.DLL----------------------------------------HiFiAircraft Assembly Version: 1.0.0.6 Win32 Version: 1.0.0.6 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiAircraft.DLL----------------------------------------HiFiSimConnect Assembly Version: 1.0.0.5 Win32 Version: 1.0.0.5 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiSimConnect.DLL----------------------------------------HiFiFSUIPC Assembly Version: 1.0.0.7 Win32 Version: 1.0.0.7 CodeBase: file:///D:/Program%20Files/HiFi/XPax/HiFiFSUIPC.DLL----------------------------------------Microsoft.FlightSimulator.SimConnect Assembly Version: 10.0.61242.0 Win32 Version: 10.0.61355.0 (fsx-sp1.20070510-2038) CodeBase: file:///C:/WINDOWS/assembly/GAC_32/Microsoft.FlightSimulator.SimConnect/10.0.61242.0__31bf3856ad364e35/Microsoft.FlightSimulator.SimConnect.dll----------------------------------------************** JIT Debugging **************To enable just-in-time (JIT) debugging, the .config file for thisapplication or computer (machine.config) must have thejitDebugging value set in the system.windows.forms section.The application must also be compiled with debuggingenabled.For example:When JIT debugging is enabled, any unhandled exceptionwill be sent to the JIT debugger registered on the computerrather than be handled by this dialog box.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jim,FS9 across a WideFS set up (connects fine)Wilco / feelthere 737-30093 PaxI'll see if it happens again - not sure if I will fly again tonight - if not tomorrow.Still don't find any XPAX.cfg file on the host or client.Thanks.Joe Lorenc

Share this post


Link to post
Share on other sites

>Hi Joe,>>Sorry for the problem. Can you post some basic information?>>FS version>Plane used>number of passengers>If you can get this to happen again.>>Happy Holidays,>Jim>>http://www.hifisim.com/banners/hifi-community-sigbanner.jpg>http://www.hifisim.com/I had the same error at the end. B737-800 with 6 passengers and 6 crew members left on board.All the flight data registered. 1 flight completed 113 pax delivered 84 average and 95 points, no injuries.KFLL - KPBG FL 3303.9 hoursFSX SP1WINXP SP2

Share this post


Link to post
Share on other sites

>Hi Joe,>>Sorry for the problem. Can you post some basic information?>>FS version>Plane used>number of passengers>If you can get this to happen again.>>Happy Holidays,>Jim>>http://www.hifisim.com/banners/hifi-community-sigbanner.jpg>http://www.hifisim.com/Yea I'll try a short commuter hop as soon as I get some coffee in me. I had copied the info last night at 4 am and it fell off the clipboard before I could paste it somewhere.

Share this post


Link to post
Share on other sites

Make sure when you search you are telling it to search in hidden files and folders. In my case that was why I wasn't finding it earlier.Joe Lorenc

Share this post


Link to post
Share on other sites

Hi thereIm cannot get this XPAX to work, im constantly getting a microsoft.net framework error. similar to what is mentioned previously by others. Info asked for below :-FS version - FSX Deluxe on Vista 32bitPlane used - any, same error no matter which aircraft i use.number of passengers - any amountIf you can get this to happen again - happens everytime i run XPAX. Whether i run FSX 1st or not. Get error immediately, cannot even get to click Aircraft tab. Tried to edit the XPAX.cfg file as mentioned on another thread, but cant find XPAX.cfg anywhere on my drives ( I have used search entire computer, still didnt find the file. )Please help, looking forward to checking this great looking piece of software.All the bestRob Engvikson

Share this post


Link to post
Share on other sites

Hi Rob,The problem is due to a modified FSX path in your registry which does not contain a trailing backslash.The immediate fix is the add the backslash in the FSXPath value in XPax.cfg.The XPax.cfg is located in C:UsersyourusernameAppDataRoamingHiFiXPax (for vista).We are testing a hotfix now to solve this internally (and a few other issues reported).Best,

Share this post


Link to post
Share on other sites

Thx Damien Got it working now.My XPAX.cfg was among hidden / system files, and i couldnt figure out how to show them in explorer on Vista. But i twiddled about and found them in the end.All working fine now so far :)All the bestRob

Share this post


Link to post
Share on other sites

OK, second flight - same aircraft - no problem this time - except for the "two for one" flight issue mentioned elsewhere.Even though I do not have doors set to auto open I notice on deplaning they open at once on parking brake - hope that changes.Thx,Joe Lorenc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this