Sign in to follow this  
irocx

Please help with AI aircraft and missing effects files

Recommended Posts

Hi, I finally decided to add some AI traffic, so I installed packages from WOAI and then PAI. I have since run into some problems with missing effects files, which are killing my FR's and didnt exist before the installs. First, I find with filemon that there's a call for fx_strobex.fx., which doesn't exist in default FS9. Upon the advice posted here:http://forums.avsim.net/dcboard.php?az=show_mesg&forum=263&topic_id=2420&mesg_id=2917&page=2, I first created a strobex.fx file from another strobeh.fx and that seemed to satisfy the call and solve the problem. But then, I then found the offending AI aircraft making the call for the file in the aircraft's.cfg file and edited the call to an existing stobeh.fx file, but left the created stobex.fx just in case. I thought I solved the problem, but tonight I find that filemon is again reporting two files being repeatedly NOT FOUND: the fx_stobex.fx and the fs9/EFFECTS.CAB file. Does anyone know short of removing all the added AI how to solve this? Also, what is the best way to disable or uninstall PAI's AI aircraft? I don't see anything on their site or forum about it and it's not within their installer? While I'm here :-lol - Last night I also noticed bad FR's and that filemon is repeatedly reporting FS9Lear_45.GAU and FS9Aircraftlear45panelLear45.GAU and FS9AircraftLear45panel.CAB not being found. This never occured before the packages and I've never altered the default Lear in anyway. Why is this occuring? I don't have any UltimateGA installed only two CRJ's for regional packages, which I'm sure are causing the issues. Is it because they're aliasing the Lear45 panel? Many thanks for assisting this noob :-hmmm to AI.Best Regards,KendallDell 8400 3.2 GHZ H.T.800 FSB/2MB L22 GB 533 DDR2X800XT 256MB/Catalyst driver - 6.9's6x Adaptive AA/16x HQ A/FIntegrated SoundDual Monitor: Dell 2405/1905CH Yoke/Pedals

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Kendall,More knowledgeable than we say Filemon can at times be misleading - that said:Fs9 is hardcoded to look for .CAB files as a second resort - ignore those. Re the strobe, are you sure your 'dummy' stobex still exists and is perfectly named? - cannot see why it cannot be found if it's in your effects folder.PAI - you have to delete them manually as far as I know.Re the lear - if you think the CRJs are causing it just delete the panel.cfg or even the panel folders - not required for fs to see and use an aircraft, AI or otherwise.Hope this helps - wasted cpu cycles are a FR sucking pain.regards,Mark

Share this post


Link to post
Share on other sites

Kendall,I'm fairly certain I had this issue after installing the FSP 777v3 AI model, which depending on which WoAI packages you are using, may have been installed.Check your AI 777's, look through the effects section of each respective aircraft.cfg. If you find "fx_strobex.fx" listed, replace it with fx_strobeh, and try filemon again.

Share this post


Link to post
Share on other sites

Re the strobe, are you sure your 'dummy' stobex>still exists and is perfectly named? - cannot see why it>cannot be found if it's in your effects folder.>>PAI - you have to delete them manually as far as I know.>>Re the lear - if you think the CRJs are causing it just delete>the panel.cfg or even the panel folders - not required for fs>to see and use an aircraft, AI or otherwise.>>Hope this helps - wasted cpu cycles are a FR sucking pain.>>>regards,>MarkHi Mark and Brian, I'm a noob to AI, but not file names/extensions, but when I first created a "dummy" file I mistakenly created a stobx, not the requisite strobex, stored it for some odd reason and that found its way into my effects file (grabs hair and and does his best Chris Farley dunderhead routine...) Anyway, even though I edited the call for one aircraft.................Thanks for the info on the Lear - I wasn't aware the the panel folder etc wasn't even required in FS9.If I remove the taffic BGL for PAI aircraft will that be enough? Or do I need to fugure out a way to do a complete uninstall?Roger on the CPU cycles, I need all the help I can get lately and it's making me old x( Thanks again to you both for sharing your time and knowledge.Regards, KendallDell 8400 3.2 GHZ H.T.800 FSB/2MB L22 GB 533 DDR2X800XT 256MB/Catalyst driver - 6.9's6x Adaptive AA/16x HQ A/FIntegrated SoundDual Monitor: Dell 2405/1905CH Yoke/Pedals

Share this post


Link to post
Share on other sites

>If I remove the taffic BGL for PAI aircraft will that be>enough? Yup - the bgl file is the heart of any AI package - remove that and there will be nothing calling the corresponding aircraft, they'll just be taking up space in your aircraft folder.You seem to have the knowhow to be quite adept at AI useage at the back end - if you have not yet, download Lee Swordy's ttools202.zip and afcad221.zip in the library - the docs are THE guides and required reading to all things AI (for fs9 anyway :) ).regards,Mark

Share this post


Link to post
Share on other sites

Hi again Mark, Thanks for the vote of confidence and I did read through both guides to those excellent tools earlier last year when I considered adding some AI, but like many, found the whole process somewhat daunting and time consuming to learn. I'll have to revisit them with more free time over the winter months.I have always been reluctant to add/change things in the sim for fear of muxing things up. Interestingly, when I ran into these issues in the past, I would have just uninstalled back to what I had before the change, potentially missing out on a whole new dimension to the sim. But now with Filemon, one is able to at least check and see what is going on and possibly fix things, though I agree with you regarding it's limitations etc. I'm planning on a new rig sometime soon here and hopefully that will finally remove all worries about flyability and performance.(I hope anyways;))Thanks again and happy holidays.Regards, KendallDell 8400 3.2 GHZ H.T.800 FSB/2MB L22 GB 533 DDR2X800XT 256MB/Catalyst driver - 6.9's6x Adaptive AA/16x HQ A/FIntegrated SoundDual Monitor: Dell 2405/1905CH Yoke/Pedals

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this