Sign in to follow this  
Jure

To mip or not to mip

Recommended Posts

Hi,I have dilemma... Running an nVidia GeForce 7800 GTX I am privileged to a loadful of shimmering at different add-on airports. Let's take a look at the magnificent FlyTampa LOWW, for example:- I mipped everything that could be mipped and there's no shimmering anymore. BUT! There are horrendous stutters as I approach the area when textures get loaded. - With original textures, the airport is shimmering terribly, but everything is smooth as silk.What to do, except changing the video card? I played with settings till my eyes got sore, but I couldn't get rid of the shimmering with original textures (mostly non-mipped). FPS seem the same in both cases, by the way. Same goes for other airports, LOWW is just an example. I love it to pieces, but the shimmering is starting to get to me. My rig:Athlon FX-57GeForce 7800 GTX2Gb Corsair RAMASUS A8N32-SLI Deluxe (not running in SLI)etc....Regards,Jure

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

MIPS uses reduced size textures as the perspective makes thingsin the distance smaller. But, due to the smaller objects inthe distance, detail becomes smaller than a pixel, so appearsand disappears as you move view - so shimmer. Finally, AF (anisotropic filter) makes the distance sharper and counters blurry view and shimmer.MIPS and AF is done on the GPU - yours is reasonable.I recommend you do the following.... Turn on bi/tri linear filtering in FS9. Turn on x4 AF in the graphics card Set to MIPS to about 4.You should have good fps (ie CPU is not waiting for GPU). Nowtry increasing AF (x8, though probably not x16)Increase MIPS to 5 then try 6You have to find the play off with sharp distant textures (you will also need to increase the texture quality in FS9.cfg)and limits on fps due to the GPU taking too long to render theview. Higher MIPS will sharpen the distant view - but will resultin shimmer. Use AF to counter this shimmer.Tom

Share this post


Link to post
Share on other sites

Tom,thank you for your reply, quite informative! :)I played with settings some more and things are a bit better, although not yet perfect. I had everything set up pretty much as you describe and in the end the thing that gave me the best improvement was to move from "High quality" to "Quality" in the card's settings. Moving mips upwards from 4 didn't make much difference so I am back to 4. AA 4x, AF 8xRegards,Jure

Share this post


Link to post
Share on other sites

>I mipped everything that could be mippedHi Jure,May I ask you what you meant by "mip everything"? How do you mip or unmip? Is it the mip slider in FS you are talking about?Thanks!Jason

Share this post


Link to post
Share on other sites

Jason,by "mip everything" I mean the textures of an add-on airport. It is not a slider in FS! Open the "textures" folder of an airport add-on and look through the textures in there. I can usually tell by size which texture has mip maps and which not. For example, a size of 1025Kb is a 1024x1024 DXT3 texture and has no mip maps, whilst a size of 1366Kb has them. Different formats (DXT1, 16-bit or 32-bit have of course different sizes...)Anyway, use DXTBmp by Martin Wright or Imagetool by Microsoft to add mip maps. In imagetool you simply load the texture, press "Image/Create Mipmaps" and press "save". If, in Imagetool, you only see one image of a texture, then it has no mip maps. If you, however, see half of the texture in original size and then smaller versions of it to the right, then it has mip maps. So, in my experiments I went crazy and added mip maps to all textures found in FlyTampa Vienna/Textures folder that didn't have them. That got me stutters, so I reverted back to the original textures (which I saved before I started adding mip maps) :)Regards,Jure

Share this post


Link to post
Share on other sites

Best explanation I've seen yet on this topic, thanks.

Share this post


Link to post
Share on other sites

Hey Jure,Thank you for the explanation! I was curious because my FS stutters like crazy when it loads AI planes. Maybe I should "unmip" all the AI textures? (which will take a year :) ).I use DXTBmp. And I believe most if not all of my AI textures are in DXT3 format. How do I exactly "unmip" them in DXTBmp? Can I unmip everything or should I leave certain textures alone?Thanks!Jason

Share this post


Link to post
Share on other sites

Hey Jason,you're welcome. :)I have all my AI aircraft with mip maps, even added to those which didn't have them. Helps with FPS, so I keep those. If you want to "un-mip" a texture, load it into DXTBmp, then uncheck the Mipmaps/"Include when saving" tick box on the right side below the Alpha channel preview window and save. Be careful to preserve the correct type when saving, you have to specify the correct type -- DXTBmp won't save a texture in DXT3 only because you loaded a DXT3 type.Regards,Jure

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this