Sign in to follow this  
simba_nl

Don't get it, OOM error with lots of mem

Recommended Posts

I don't get it anymore,Made a nice nightfly on VATSIM in Germany and on final approach with the 767 I get a OOM.I have MEMSTATUS active and reported as peak,Mem: 60%Video 77%Running fs9 under XP-Pro with 2Gb ram and 320Mb video and the boot.ini tweaked with the 2560 (3Gb) switchAnyone a idea?Happy landings...(without OOM errors)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What else are you running? Ultimate Terrain/Active Sky/Level D 767?Does it only occur with VATSIM? Are you running Squawkbox or FSINN?Do you have latest FSUIPC 3.75 from Pete Dowson?Anything else going on in background? Anti-virus etc? What AV software are you running?Have you been able to duplicate? Does it always happen at the same time into flight or same location?KemoF15

Share this post


Link to post
Share on other sites

Simba,You have to modify your FS9.exe to use more virtual address space than 2GB.I use a program called CFF explorer.I followed the advice in an earlier thread in the FSX forum and it fixed this prob for me in XP pro. There are detailed instructions there.I will search and post a link...... if I can find it.Stu.Here it is, posted by Markus:I got several Out of memory erros when I fly with the great Alphasim SR71 longer distances. Sometimes the error occured five minutes after takeoff. The error occured under SP1 too.So I tried a solution I found for make STALKER ready for run with Windows Vista. The solution seems to work with FSX too. I got no error on flights which crashed before regulary with OOM.Try this only if you have at least 2 GByte of RAM and at your own risk.First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fsx.exe. Than start "CFF Explorer" and open the orginal fsx.exe file.Now go to NT Header/File Header and click File Header. Ther you find a button labeld "click here". Click it. And select the mark at "App can handle> 2gb adressest "Save the modified EXE, overwrite the orginal one (You have youre copy saved?).If you run Windows Vista 64 or Windows XP 64 youre ready and didnt need to read on. The rest is only for Windows Vista 32 or maybe Windows XP.Now make Windows Vista (32-Bit) ready to support more than 2 GByte.Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command window and press enter.After that restart windowsFor Windows XP there is a similar setting for the boot.ini, but I have no Link to it, should be found be google.For me it solve the problem.Too reset the Increased User Adressspace just start the commandline prompt with Admin right again and enter "bcdedit /set IncreaseUserVA 2048"Please post youre results here, so we can see if this is a solution or a workaround only.ByeMarkus

Share this post


Link to post
Share on other sites

Yes, Thanks Markus but only FSX is accepting this, you also have to modify fsx.exe to handle more then 2Gb. FS9.exe does noting with the 2 Gb switch.Happy landings...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this