Sign in to follow this  
Guest Stratus_Fractus

64MB or 256MB AGP aperture?

Recommended Posts

I have both options in my BIOS. My card is 128MB, so what setting would give me the best performance?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

128 gives my geforce4 much better performance. Try 64. When you take off look to the sides and see how the scenery slows a bit. Then set it to 128 and see how the scenery moves smoothly. Try it!Jose

Share this post


Link to post
Share on other sites

I'd love to set it to 128MB, but as I said my mobo doesn't have that option, only 64 and 256.

Share this post


Link to post
Share on other sites

When faced w the options that you state, set your agp aperature to 256. I am kind of curious though why you only have those 2 options. Are you currently running the latest bios for your particular motherboard?Bobby

Share this post


Link to post
Share on other sites

Below is a response from W. Sieffert to a question of mine. The relevant article recomends either 64 or 128 MB, but no more._______________Visit www.rojakpot.com and select the definitive guide to BIOS, then select AGP aperture size selection.W. Sieffert

Share this post


Link to post
Share on other sites

Interesting article. Contrary to what the article states though, I have acheived my best benchmarks and FPS when having the AGP sized to at least 128. Performance only increases when set to 256. Try it both ways and see what you come up with.Bobby

Share this post


Link to post
Share on other sites

Thanks. I run an Intel motherboard, it is up to date I believe, but knowing Intel motherboards they don't give a lot of BIOS options.

Share this post


Link to post
Share on other sites

FSFREAK:For some reason I'm still trying to figure out, whenever I choose settings over 16 MB, I get a windows unable to write to memory error. It may be Vcache settings. Anyone with any ideas please jump in.

Share this post


Link to post
Share on other sites

Hi Greg,Do be honest I don't think it really matters. I know, I know many will declare performance hikes with different settings but with modern GPUs carrying 128MB of DDR ram it is doubtful whether any of your system memory will in fact be needed for texture manipulation.Anyway, I have done a lot of research on the subject and the general recommendation appears to be to opt for an AGP setting of 128MB. But, it will do no harm to try either 64 or 256. The setting does not lockout your physical memory for use only by your graphics card. It merely reserves a max value that can be used if needed, which it won't, I suspect, unless you are into running some particularly graphic intensive application. Complex as FS is, I doubt whether it falls into this category. Maybe someone knows different?Having said all that, I have noted an increase in HD activity when I am flying over the VFR Photographic Scenery for East & SE England. Whether this reflects the movement of high resolution textures to and from the 128MB of GPU onboard memory or whether this is an indication of system memory use I just don't know. What I have found is that HD activity drops quite significantly if I uncheck 'Extended Texures' from within the sim. This also cuts down on loading times before you can fly. The negative side to this, of course, is you get those bland textures without detail in the distance. You can always reduce your visibility settings to 5-15 miles to counteract this.Mike

Share this post


Link to post
Share on other sites

My guess is that if this has always been the case then you may need to update your motherboard drivers. Check the manufacture's website and see if any are available.Mike

Share this post


Link to post
Share on other sites

In case anyone is interested, I finally solved the problenm set out above.I updated MB drivers and bios but no joy. I increased VCache Max Setting to 2000 MBs, but I don't think that had anything to do with the solution.I finally downloaded the latest version of Intel's Application Accelerator, and now I can select AGP Aperature sizes upto 256 with no Windows memory errors. To be honest, I really didn't notice an FPS difference between 16, 128 and 256 MBs. Nevertheless, I know have it set at 128.Thanks everybody for the advice.

Share this post


Link to post
Share on other sites

THe whole reason to increase this bios setting is to use the memory through the much faster AGP bus straight off your card. If you don't have a 256 meg card setting it to that won't change anything. Best Wishes, Randy J. Smith [h3]" A little learning is a dangerous thing"[/h3]AMD XP 2100 |MUNCHKIN 512 DDR RAM |ECS[/b ][i] K7S5A MB[/i] |GF3 64 MEG |WIN XP PRO |MITSUBISHI DIAMOND PLUS 91 19"

Share this post


Link to post
Share on other sites

I'm glad you finally got it sorted. When I mean drivers, I mean drivers and the Intel Application Accelerator is a driver for your disk drives.:-lolI don't have Intel chips on my main computer at the moment and I usually don't differentiate when I talk about drivers.In any case, you got it sorted!!

Share this post


Link to post
Share on other sites

Thanks. It was a good excersize to ugrade all the MB stuff. Only side effect now is that after booting up, selecting some programs (like FS 2002, Sandra) will result the computer not doing anything for approx. 30 seconds) and then firing up the program. Once the program is running, there are no problems. I updated MB drivers by just running the exec. Was there a specifc or recommended procedure to follow?

Share this post


Link to post
Share on other sites

Cruachan is correct.In theory, AGP Aperture size should not have an impact on performance because)a) most modern videocards have enough onboard memory to store all the needed game textures:( you don't lock out the memory for AGP only, it's only used if needed.However, some users report widely different results. Some get better performance by disabling AGP (setting the AGP size to <16MB) My guess is that some crappy motherboard chipsets are a bit flaky with AGP. For example, my KT266A would get unstable if I set AGP Apert. to 256MB. Using old chipset drivers or the Microsoft-supplied drivers may also produce undesired results.About your problems with the VFR scenery, I would guess the increased HD activity has to do with the system RAM, and not the AGP aperture size. Upgrading the system RAM should help, unless FS2002 has some upper limit for how much memory it can allocate for scenery textures (does anyone know if it has such a limit?).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this