Archived

This topic is now archived and is closed to further replies.

ghiom

FS9 loading time

Recommended Posts

HiRecently, I have noticed that FS9 takes longer to load up to the welcome screen. After that, when I load a flight and I select an runway, the bar stays long (apparently, maybe 1-4secs) at 0% displaying "loading scenery object", the rest of the process being quite quick.What could be the reason? What is FS9 initially loading?Thanks for your helpGhiom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The more add on aircraft/scenery/applications you add to the sim the longer it takes to load it all. I was at my Father-in-law's house the other day and he has a stock load of FS9 on his computer...I had to laugh at how fast it loaded. I usually start mine and go get a cup of coffee waiting for it to start up!! :)You can search the forum for solutions to speed up the loading times...IE. did you notice it taking longer after adding a new plane or scenery...I gave up looking for the culprit...I have too many add-ons now!!Good luck,Scott

Share this post


Link to post
Share on other sites

MaybeI don't have that many addons and AI traffic since I fly only in north america.What is strange to me is the pause for a few secs before the bar starts to advance....I am sure it has not done that always.Also, FS9 is very slow to start. 20-30secs. I remember recently it would be quick as a a flash, maybe 5 secs. When it loads, it does not look for sceneries, aircrafts only...and i have my famous csrss.exe registry access issue every time it opens a aircraft (as seen with procmon.exe). see my thread on the subject in the same forum.ThanksGhiom

Share this post


Link to post
Share on other sites

If you don't have that many add ons, maybe you could re-install and see if that helps?? Hope you get it figured out,Scott

Share this post


Link to post
Share on other sites

In fact, the problem is with AI planes.When FS9 loads, 80% of the time is taken to scan planes, AI or not actually.And everytime planes' model.cfg, aircraft.cfg is read, there is an access at the registry by csrss.exe, looking of a file that does not exist. So the reason why it takes so long to load I believe.Thanks to procmon.exe for this reporting.The question now is why and does it happen the same way for others...Refer to my other thread on the subject. Too bad, noone has never checked if they had the same behaviour of their system...That would help a lot to narrow the problem.ThanksGhiom

Share this post


Link to post
Share on other sites