Archived

This topic is now archived and is closed to further replies.

ecagan

Sporadic CTD I think are AI related

Recommended Posts

I have been having some issues with CTD both with and without FS9 error messages. I believe that they are AI related but I am stumped on how to fix it. I have narrowed down my issues to one particular AI file for Delta Airlines regional carriers but I cannot figure out what could be causing the issue. What's weird is that when I make the AI visible in my aircraft selection list, I sometimes have problems viewing the AI. I thought that if it really was a texture problem, the sim would CTD every time. In my case, I will select an AI that worked the last time I had the sim up and this time it wiil cause a CTD. I restart FS and I can view it again. Then, another AI causes the problem. Has anyone had this experience and figured out how to fix it? The AI in question are CDAI CRJ200 and EvolveAI ERJ 145 so far but I'm sure I will find others as I go along. I've done a lot of testing to determine which file it is and I'm sure it is AI related (deleted all scenery files and still had the issue).The issue also happens at the same time leading me to the AI conclusion. Any help would be appreciated.Eric

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

To add to my questions, are there any characters that the aircraft file doesn't like (illegal characters) or does it just have to match the title line? I have been using Traffic Tools to compile my traffic files. Does anyone have any other ways to check AI aircraft to see if they are corrupt? I'm not sure what to do at this point since I have previewed every aircraft I have and I cannot determine the problem.Thanks,Eric

Share this post


Link to post
Share on other sites

Eric,For now you can check two things. Make sure that:1.Your AI planes have DXT3 not 32bit textures2.You have the fx_strobex.fx file in your Effects** - if you don't, make one by copying and renaming the fx_strobe.fxAlso to find which repaints cause problems will never be an easy task, though it may be done. Eliminate or replace susspected AI aircraft - that's how I do it.No more ideas at the moment.Best regards,Rafal

Share this post


Link to post
Share on other sites

Thanks Rafal,I checked and have the effects file. I started searching my AI files for 32 bit textures and found one for a CDAI CRJ200. The only thing was that I had already deleted this file from the aircraft.txt being used in the traffic file so that one wasn't the problem. Just came across some other threads about 32 bit textures in AI so I will do more research on all my AI to determine if it's another aircraft.Does anyone know if AITA (AI Traffic Analyzer 2004) will register aircraft that fly into an area before the sim CTD due to the bad texture? That would at least help me narrow down the problem.Thanks,Eric

Share this post


Link to post
Share on other sites