Archived

This topic is now archived and is closed to further replies.

Guest ALT370

FS9 and Vista

Recommended Posts

Hi,has there already been posted a topic in these forums about FS9 used on Vista and the related problems?I cannot find anything after searching for it.If there isn't, could some using this combination (Vista/FS9) please advise me about possible problems occurring? I have heard about graphic issues with NVIDIA cards e.g.Thanks for any help,Axel.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm running FS9 on Vista 32 Home Premium. Works just fine once you've gone through the usual process of optimizing that comes with any new OS. You'll want to disable as many "automatic hand-holders" as you can (UAC, MS Auto-Update, etc...) and you'll want to make sure you're operating with Admin privileges. Once set up for gaming though Vista is every bit the OS Win98 or XP were. It is just as stable and (given suitable system specs) in some ways (memory management for one) even better than XP...

Share this post


Link to post
Share on other sites

There are some threads on this issue, but here's my capsule version from memory:- Be sure to install FS9 in a folder outside of the "Program Files" folder. Vista treats some files in that directory as read-only.- Turn off UAC in Vista for sure, and possibly DEP as well.- Right-click the FS9 icon and change compatibility mode to XP. Run the program as an administrator.- Get a copy of the nHancer utility if you have an Nvidia card and want your anti-aliasing to work. Here's how to set up a profile for FS9:http://www.simviation.com/cgi-bin/yabb2/Ya...;num=1201991487Hope this helps!John G.

Share this post


Link to post
Share on other sites

I've got it installed to the defualt program files folder. No problems here. However, I do have DEP and UAC off...

Share this post


Link to post
Share on other sites

I have FS9 (and FSX) installed on a Vista 32 Home Premium system and it runs fine. I have *many* addons installed, and everything runs great. The only problem I've had is in the last week when my FSUIPC reported problems with the digital signature not matching the certificate and disabling itself. After a quick scan of the FSUIPC support forum I found the solution to be a simple registry edit, although I don't know what caused the problem in the first place.Other than that one little problem, *everything* runs fine.As has been said, if you do a little reading on what is different in Vista and you are prepared to disable the likes of UAC you shouldn't have any problems. Bear in mind much of the Vista bashing is down to people who haven't properly familiarised themselves with the OS, and of course it is always in vogue to bash anything from Microsoft :)

Share this post


Link to post
Share on other sites

Hi,thanks for your replies, but what is UAC and DEP?regards,Axel.

Share this post


Link to post
Share on other sites

DEP - Data Execution PreventionUAC - User Account Control

Share this post


Link to post
Share on other sites

Hi,is there still the problem with NVIDIA cards that for solution you must switch in windowed mode?I really don't like it to fly with windowed mode, I like the full screen. And I even like to have all in AA for a smoother look.Axel.

Share this post


Link to post
Share on other sites

No problems here with Vista 32 Home Premium and FS9. Using Nvidia GPUs.Have UAC off as many above do and FS is installed in default Program Files folder. Also flying in Full Screen mode. Actually like Vista more than I thought I would. Al

Share this post


Link to post
Share on other sites

Actually, with Vista it's now the opposite - I get much better framerates in Full-Screen mode than in Windowed mode. I run nHancer for AA and have the AA setting disabled in-game. Works well.John G.

Share this post


Link to post
Share on other sites

I have FS9 running on Vista with nothing turned off, including UAC. FS9 is also installed in its default folder. In other words, all I did was to install it normally, no change. Running FSBuild, for example, I get the UAC asking for approval, but that's it, FS runs fine. Regards,Dave Vega

Share this post


Link to post
Share on other sites

>If there isn't, could some using this combination (Vista/FS9)>please advise me about possible problems occurring? I have>heard about graphic issues with NVIDIA cards e.g.As mentioned months ago, FS9 runs fine with Vista. You do not need to use nHancer to get AA to work, Nvidia

Share this post


Link to post
Share on other sites

Wow,thanks for your replies and the screenshots last posted let me hope not to give up FS9 ;)regards,Axel

Share this post


Link to post
Share on other sites

Hi,just want to ask why I cannot have this configuration enabled:AA in FS deactivated and AA activated in the NVIDIA Control Panel.On my old system it was possible to switch off the AA in FS menu.Now it has no effect to activate it in the NVIDIA Control Panel.Regards,Axel.

Share this post


Link to post
Share on other sites