Archived

This topic is now archived and is closed to further replies.

Smokin256

Kcdk Lewis Field Cedar Key, Florida And Ut Usa And Fs9

Recommended Posts

Greatings all! I made a flight from KSPG Albert Whitted field St. Petersburg Florida to KCDK Lewis field Cedar Key Florida yesterday. But when I got there I found no field anywhere in sight. So I made a flight to start there and found the airfield under water! I have only UT USA for addons on the east coast. It seems that UT USA has the island a couple hundred yards south of where the default FS9 places it. I have tried moving the runway and other parts with afcad2 but it doesn't move the runway at all. I can tell it's using the new afcad because I changed the name from "Lewis" to "Lewis field" just as a check. Even if it did work it wouldn't help me much because there are trees and buildings in the way. Does anyone know if there is an update or fix for this? Or is there a freeware tool that I can use to fix this?Cheers..................Todd

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ok here's an update. I had moved the runway. But afterwards I just started from the active runway for testing. Well I moved the runway but I forgot to move the start points :( . So now I've got everything in the proper positions but still none of the surfaces show up and the beacon and wind sock are still over in the channel several hundred yards away. So it remains to create an exclude for the proper area now. And then to create a flatten or move the existing one somehow. Off to study the faqs and tuts some more. :)Cheers................Todd

Share this post


Link to post
Share on other sites

Don't forget that UTX has a reporting tool available for these occurrences.

Share this post


Link to post
Share on other sites

Thanks Art! But it looks like they are no longer doing any updates or accepting any "issue reporting" for UT for FS9. I wonder if this problem still exists in FSX? I just kind of assumed it didn't. I will report it over there anyway.Well, I've been able to move the flatten into the proper position and got the background texture to show in the proper position. But I can't get the runway objects or anything else from AFCAD to show. The elevation in SBuilder for the flatten polys is still the same as it was originally 2.125 meters. Which should be 7.0 feet (or 6.972) But when sitting on the ground I'm at 10.7 feet. I've tried setting the elevation of the airfield and the runway in AFCAD to everything from 7 feet to 11.7 feet with no luck. There must be some kind of exclude or draw order problem going on but I can't find it. It shows the base texture then on top of that it looks like the airport background texture and the UT roads seem to show above that. Any thoughts on what I missed?I did wind up disabling the two default .bgls for the effected area because somehow or other I wound up with double flattens in them. One in the original location and one in the new. I don't know why :( .Thanks in advance for any suggestions. Cheers.................Todd

Share this post


Link to post
Share on other sites
Which should be 7.0 feet (or 6.972) But when sitting on the ground I'm at 10.7 feet.
With the 10.7 elevation are you sitting in a plane? Default Cessna 172 is about 3.6 above ground.

Share this post


Link to post
Share on other sites

You might want to check FreeFlow Florida. I has a lot of airport fixes.scott s..

Share this post


Link to post
Share on other sites

FSX with UTX has the same problem. I didn't find anything in the AVSIM library (although I've never gotten the library search to turn up anything, even when I know it's there), so I'll upload a relocated airport file. I also noticed that some of the little islands in the area have no land, just shorelines and water.

Share this post


Link to post
Share on other sites

Interesting! So is that the stock FSX? Or the UTX version with your relocation fix? I looks better in some ways than the FS9/UT USA version. Not so good in other ways. Typical of the FSX/FS9 dilemma :) . Well I can't find the reason why the airfield elements won't show up. I've compared The KCDK flatten and background polys to the ones for "The Cedars" FA71 next door and I can't find any differences. Other than the fact that KCDK has been moved and the other has not. Could it be that the location information used to position the airfield elements are contained in a different file than the one the sim uses to position ones aircraft?Thanks Scott, I looked into Freeflow Florida and it does look good. I'm convinced that it will fix the problem. But I want to try to fix it myself before I go that route. Cheers................Todd

Share this post


Link to post
Share on other sites
Interesting! So is that the stock FSX? Or the UTX version with your relocation fix? I looks better in some ways than the FS9/UT USA version. Not so good in other ways. Typical of the FSX/FS9 dilemma :) . Well I can't find the reason why the airfield elements won't show up. I've compared The KCDK flatten and background polys to the ones for "The Cedars" FA71 next door and I can't find any differences. Other than the fact that KCDK has been moved and the other has not. Could it be that the location information used to position the airfield elements are contained in a different file than the one the sim uses to position ones aircraft?
The FSX KCDK airport is the FS default modified with ADE. UTX USA does not change the default airports, but the changes to shorelines may leave the airport in the wrong location as happened at Cedar Key. This is the same for UT and FS9.Changing the default airport for FSX is easy with all of tools in ADE, but it might be a lot easier to use the FreeFlow Florida airport for FS9 and then change it with AFCAD to your liking. I don't know why we can't get the relocated airport runway to show up in FS9.

Share this post


Link to post
Share on other sites

Well I installed Freeflow Florida and it didn't fix the problem. Plus St. Petersburg, as beautiful as it was brought my poor old system to it's knees, with frame rates in the single digits. I've come to the conclusion that the location information must be in AP925210.BGL. Now I just got to figure out how to open it.Ok, update. Thinking of this I tried disabling the default AP925210.BGL and lo' and behold there's the runway! in all it's ugly FS9 glory :) ! Of course now all the other airports within the .BGL area are gone. No surprise there, but interestingly (to me anyway) KCDK in the "Go to airport" list now says "Lewis Field" as I named it in the afcad file. Instead of "Lewis" as it's named otherwise.Ok, so now I've got to figure out how to exclude the original information contained in AP925210.BGL. Or create another .BGL with the required info to put in my KCDK folder.BTW that diminishing wail you hear is me being sucked into the vortex of scenery design! :)Cheers.............Smokin256

Share this post


Link to post
Share on other sites

Ok, this is really frustrating! I got BGLXML version1.8. I used that to create AP925210.xml. (just as a test mind you, I don't want to edit the default .bgl but I haven't figured a way to exclude the airport data yet.) It seemed to work fine. I got the BGLcomp FS2004 SDK and copied the AP925210.xml to the BGLComp directory. Then I dragged and dropped the file on bglcomp.exe and I get a command window for a bit but nothing happens. I can do the same thing with the chelan.xml and the other example file and it makes a perfect chelan.bgl ect. just like it's supposed to. What am I doing wrong? This is driving me nuts! BTW I've tried typing bglcomp.exe <AP925210.xml> in the command prompt as described in the BGLComp help file in every conceivable combination and nothing works. Even with the chelan.xml that works fine by dragging and dropping. What am I missing!Cheers.............Smokin256

Share this post


Link to post
Share on other sites
Well I installed Freeflow Florida and it didn't fix the problem. Plus St. Petersburg, as beautiful as it was brought my poor old system to it's knees, with frame rates in the single digits. I've come to the conclusion that the location information must be in AP925210.BGL. Now I just got to figure out how to open it.Ok, update. Thinking of this I tried disabling the default AP925210.BGL and lo' and behold there's the runway! in all it's ugly FS9 glory :) ! Of course now all the other airports within the .BGL area are gone. No surprise there, but interestingly (to me anyway) KCDK in the "Go to airport" list now says "Lewis Field" as I named it in the afcad file. Instead of "Lewis" as it's named otherwise.Ok, so now I've got to figure out how to exclude the original information contained in AP925210.BGL. Or create another .BGL with the required info to put in my KCDK folder.BTW that diminishing wail you hear is me being sucked into the vortex of scenery design! :)Cheers.............Smokin256
I remember that Freeflow St Petersburg scenery when I used FS9. I had to delete it because of the framerate hit. I think some trees were the issue.I don't know of anyone who would mess with the default airport .bgls. If you placed your AFCAD file in the right place, it should override the default airport, but I have to admit that I had the same result as you when trying to relocate the airport. In FSX with the new ADE program it's easy. Another reason I won't be going back to FS9.

Share this post


Link to post
Share on other sites

Art, thanks for the heads up on the St. Petersburg issue. Yeah They did say one needed a particular set of trees to go with Freeflow Florida. I got them but I haven't installed them yet. I will try it with them installed before I decide whether to keep it or delete it. It's funny you mention putting the afcad in the right place. In my research last night I stumbled on a trick to put a copy of the updated afcad into scenery\world\scenery. This worked a treat! All I have to do is disable the default AP925210.BGL instead of editing it. Now I'm off and running. I got the old beacon and windsock over on the other island excluded. Now I just have to figure out how to add objects.I still need to figure out my BGLComp problem. I understand the bglcomp has been updated and the original caused errors like this. I think the fs2004_sdk_bglcomp2_setup.exe that I downloaded is the latest one but I can't confirm it. And I can't find any updates anywhere at microsoft.Cheers................Smokin256

Share this post


Link to post
Share on other sites

Update;I found and installed the trees called for in FFFlorida but it didn't help. still framerates in the single digits. So I uninstalled it.I've made some progress but I've run int a couple of snags. I did some work on Sugar Loaf Shores 7FA1 and Summerland Key cove FD51 as well. Here are some screens;Cheers.............Smokin256

Share this post


Link to post
Share on other sites