Archived

This topic is now archived and is closed to further replies.

Guest LeeGlen

The Old SimConnect not found trick

Recommended Posts

I have worked on my latest addon, ASX, for the last 6 hours trying everything I found to read except one. That's un/reinstall FSX. I ain't going there. Maybe!. I have FSX with SP2, Fusipc, WideFS, 3 Payware a/c, UTX, GEX, Cloud9, FScommander on a second computer, and all works ok with the current setup...not sure how many of these use simconnect. Along comes ASX and just can't find simConnect. My current setup has FSX on drive "D", ASX finds home on drive C. According to the log:19:55:51: Additional stations database load compete for 1704 stations19:55:51: SimConnect not found/disabled, Non-FS mode enabled.19:55:51: To use SimConnect, you must have Client version 10.0.61242.0 installed19:56:01: Module Found: C:\Program Files\HiFi\XEngine\Modules\ASX.DLL19:56:01: ASX module load commencing...(Log cut short except)9:56:03: Receive problem: Object variable or With block variable not set.(Error) Source = there are a bunch of these.Client vs 10.0.61242.0 is installed and visible in the add/remove program, listed within windows>WinSxS along with 60905 and 61259.I have removed .net FW 2.0 and reinstalled.Is there something maybe in the register that has a bad address although I could not find anything. Need some help please..Thanks lee

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Lee,You need to have used the SP1 SKD from FSX deluxe, SP1A SDK from MS and the SP2 SDK from MS.You also need to share the proper folders on your FSX machine for ASA. That is in the ASA manual. Have you gone through all the steps in the manual for a network setup?Thanks,

Share this post


Link to post
Share on other sites
Hi Lee,You need to have used the SP1 SKD from FSX deluxe, SP1A SDK from MS and the SP2 SDK from MS.You also need to share the proper folders on your FSX machine for ASA. That is in the ASA manual. Have you gone through all the steps in the manual for a network setup?Thanks,
Thanks Jim for the quick response. Initially I did not have SDK installed, but after the installation problem I installed SDK from the FS Deluxe disk. I checked the disk this AM for a SP1 SDK and there is no SP1 shown, unless this SDK is SP1. I downloaded SP1A and SP2 from Ms and installed it. My next steps included uninstalled FSX SP2, apparently SP1 is overwritten it does not show in the upgrade list, .net 2, ASX with SP4 update, and in the Win>SXS folder removed the simconnect 61242 file.My re-install was this way: .net 2, FSX sp1, SP2, ASX, SP4, with restarts between each install . I don't think I missed anything here. I am not using this on my 2nd computer. You mention steps for a network setup, ASX is on my primary computer.I thought possiblity of my AVG might be interfering with simconnect, but I have no problem with simconnect on other addons. Xengine is shown on the exception list.I had considered returning ASX, but the alternative is heavy in water and land textures. I only want the cloud effects. So we need to overcome this problem..Thanks for your help. Lee

Share this post


Link to post
Share on other sites

Hi,You talked about a second computer and made it sound like that is where AS was installed.You do not need the SDKs for a single computer install, only a network install.If Simconnect cannot be found on a single computer that means you need to uninstall SP2 and SP1 for FSX and reinstall SP1. Then see if AS works. If not, then look at the manual method described in the AS Simconnect Troubleshooting chapter.You don't need to adjust .NET anymore.Thanks,

Share this post


Link to post
Share on other sites

Jim, there is something that is causing ASX to install as though it is being installed on a client computer. I have uninstalled the service packs and reinstalled them many times to no avail. I decided to install ASX on my client computer then network them together. To my surprise it went flawlessly and launched . The network part might be beyond my talents. I'm still wondering if because my FSX is installed on drive "D" and ASX is in prog files on drive "C" would that make any difference. According to the log, it knows where FSX is located.Wore outLee

Share this post


Link to post
Share on other sites

Hi Lee,ASX installs the same way and runs the same way on a single install or a network install. For a network install there are things you must do with files and folders.It doesn't matter what drives things are installed on.The key is getting SP1 properly installed.Thanks,

Share this post


Link to post
Share on other sites

Hi,I have the ASA program installed, and encountered the same problems. I installed simconnect from SDK SP2, still the same problem. I de-installed FSX SP2, reinstalled it, and still the same problem.I have SKD SP2 installed. But I still hapen to have a copy of the SDK SP1a (which is normally overwritten when you install SDK SP2)I installed the simconnect from SDK SP1a, and now at least I don't get a warning about simconnect not installed.This I find very strange, the program works only with an older version of simconnect??And, how can I see that the ASA program is communicating with FSX. I'm having doubts, there are no warnings or whatever in the sim.Looking forward to your answers, Regards, Rob

Share this post


Link to post
Share on other sites

Hi Rob,The OPs issue is with ASX, which looks for SP1 to be properly installed which was the major level of SPs at the time of release. ASA first looks for SP2 to be installed.Is your install a single computer or network install? If it is a single computer, then you need none of the SDKs installed. Those are for network installs only.You can tell if ASA is working if ASA recognizes your current location in FS, weather in FS gets automatically set to User Defined, if you have Text Messages On in ASA, you get a depiction started and a depiction complete message in FS, or weather from ASA shows up in FS. If you watch the main ASA screen, there will be messages if Simconnect cannot be found.Also, you can post your ASA_Log.txt file and I'll be happy to take a look.Thanks,

Share this post


Link to post
Share on other sites

Hi,I have a single computer install.I'm not connected to FS, although ASA recognised my FSX installation.But it doesn't detect my position, weather is not set to User Defined and no text messagesWhere can I find the ASA_Log.txt. I searched my computer but I couldn't find it.I hope you can help me out.Rob

Share this post


Link to post
Share on other sites

Hi,The file can be found in:Documents and Settings/User Name/Application Data/HiFi/ASA/ASA_Log.txtThanks,

Share this post


Link to post
Share on other sites

different ways:Start ASA, let it initiate, and the start FSX from within ASAor, start FSX, and then start ASA later.Same result. I hope you can help.Best, Rob

Share this post


Link to post
Share on other sites

Hi,The next suggestion is to install the SP1 Beta from the top of this forum. Then give things a try.Thanks,

Share this post


Link to post
Share on other sites

Hi Jim,sorry to say, it doesn't work.Not with starting ASA first, or FSX first.I had to revalidate my key. (1 validation left?)Do you need any info to check out the problem?Cheers, Rob

Share this post


Link to post
Share on other sites