Archived

This topic is now archived and is closed to further replies.

Bert Pieke

Leaning mixture on default Baron

Recommended Posts

I'm used to watching the EGT gauge for mixture settings, and lean to just rich of peak inother aircraft. This does not seem to work in the Baron.. The EGT gauge only goes to 700 degrees and my temperatures are 700+ when I'mtrying to lean the mixture for best performance. So this gauge is pegged at the topand does not budge.All I can go buy is that the engine suddenly loses power as I reduce the mixture andthen I move it up a bit. Strangely, the fuel flow shows about the same as withfull rich mixture...None of this makes much sense to me :( Is there something special about this aircraft?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm used to watching the EGT gauge for mixture settings, and lean to just rich of peak inother aircraft. This does not seem to work in the Baron.. The EGT gauge only goes to 700 degrees and my temperatures are 700+ when I'mtrying to lean the mixture for best performance. So this gauge is pegged at the topand does not budge.All I can go buy is that the engine suddenly loses power as I reduce the mixture andthen I move it up a bit. Strangely, the fuel flow shows about the same as withfull rich mixture...None of this makes much sense to me :( Is there something special about this aircraft?
Running any addons?

Share this post


Link to post
Share on other sites

I've now changed the EGT gauges to show up to 900 degrees andthat makes for a workable solution.At 8000 ft cruise I lean to 15 gals/hr at 850 degrees EGT.Still wonder what the underlying problem is... is the gauge wrongor is it something else?Any RW Baron pilots/owners care to comment?

Share this post


Link to post
Share on other sites