Archived

This topic is now archived and is closed to further replies.

Guest UlfB

Initial load of wrong runway texture

Recommended Posts

Hi,While testing a new scenery build one of us stumbled over a problem with FSX not loading the correct runway texture. I've taken some snapshots of the problem. The airport is KADC (Waden Mun).First an initial load of the flight at KADC during the winter, 4th of february. No snow on the runway:The easiest way to load the correct texture is to open up the Time and Season dialog and click OK. FSX will then do a quick refresh and the correct texture is displayed:If I then change Time and Season to the 5th of april, this is what I get:Another refresh by opening up Time and Season window and clicking OK:Do you have the same issue? Do you know what's the cause and if it's possible to fix by some setting?Any help and information is very much appreciated :(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I would remove your CFG and build a new one. I had a similar problem where my default flight would not load correctly. This happened when I was trying different AA settings in nhancer. For some reason nhancer got all hosed up, or so I thought. After a fresh load of the VC driver and nhancer I still had the problem. If I selected a different setting like change the scenery slider 1 notch it would be fine. The only way I cold fix it was to build a new CFG. Hope that helps you!Jim

Share this post


Link to post
Share on other sites

Thanks Jim!Some intresting findings. I moved my fsx.cfg and let FSX build a new one. I loaded the scenery with the season set to february, which was preset as my system time is february. The runway texture with snow displayed all ok. I then changed the season to april and the snowy runway textures was still displayed. So this error still exists. Not that good, but intresting.I then changed the season to summer and saved that flight as default flight. Quit FSX and restarted FSX. I then changed the season to february for the saved default flight and loaded it. The runway texture without snow was loaded. So the problem seems to occur when you have a saved flight with summer season and change the season to winter and load the flight.I think that removing the fsx.cfg file resulted in me getting a default flight with winter season (FSX tied to my system time). As soon as I save a flight with summer season as the default flight, the problem will come back.I'd be greateful if somebody could confirm this behaviour of FSX. Maybe somebody on the previous beta team could confirm if this was a known error during beta testing of RTM, SP1 or SP2? Or is it a driver issue?

Share this post


Link to post
Share on other sites

I have SP1, and I've had the same thing happen. My FSX is running on system time as well. It's not really a big deal for me, as it'll eventually refresh and produce the right texture. The only gripe I have is when a concrete runway is covered in snow, it displays the runway as though it's an asphalt runway. Trying FSX Repair did nothing to solve that problem. Does anyone know if there's a fix to that?

Share this post


Link to post
Share on other sites

Bump :( How about this. Up till now there are four simmers in the community that acknowledge that they have this problem with initial load of runway textures. Is the loading of wrong texture a FSX "feature" or is it a driver problem. I would appreciate if you gave me a couple of minutes of your time to do a test. Make a saved flight during summer season your default flight. Start up FSX and change the season to winter. Will the correct runway texture with snow load?Please :(

Share this post


Link to post
Share on other sites
Bump :( How about this. Up till now there are four simmers in the community that acknowledge that they have this problem with initial load of runway textures. Is the loading of wrong texture a FSX "feature" or is it a driver problem. I would appreciate if you gave me a couple of minutes of your time to do a test. Make a saved flight during summer season your default flight. Start up FSX and change the season to winter. Will the correct runway texture with snow load?Please :(
I think this is not a driver problem. First in my CFG I would put "DisablePreload=1" in the "[Main]" section, to disable loading of the default flight before flight sim starts. This makes the whole scenery, textures, or in other words the world not load up at the starting menu. You will still have your default flight displayed, but the only thing is the world for the flight is not loaded during the splash screen. The only downside is the loading might take a little longer after you hit "Fly Now", but if you have a decent computer, this should not be much of a problem. :(After entering the cfg code, I would change it from the season flight simulator loaded when you started up (for exp. if the main menu displays winter after splash screen, change it to spring or summer), hit fly now, and see if it displays the right one. :(It sounds to me like when FSX grabs the system time in the menu before flight, it loads the texture up for that season (without the "DisablePreload=1" line), and even if the season changes, the correct runway texture does not load, because the runway texture you started with at first or before reloading is still in memory and directx has not re-rendered the textures properly. Also when you change the season in flight, you may have to make FSX reload the time twice before you get the runway texture, because only then will the textures re-render. Just like you had to do.

Share this post


Link to post
Share on other sites
I think this is not a driver problem. First in my CFG I would put "DisablePreload=1" in the "[Main]" section, to disable loading of the default flight before flight sim starts. This makes the whole scenery, textures, or in other words the world not load up at the starting menu. You will still have your default flight displayed, but the only thing is the world for the flight is not loaded during the splash screen. The only downside is the loading might take a little longer after you hit "Fly Now", but if you have a decent computer, this should not be much of a problem. :(After entering the cfg code, I would change it from the season flight simulator loaded when you started up (for exp. if the main menu displays winter after splash screen, change it to spring or summer), hit fly now, and see if it displays the right one. :(
Thanks for the tip. I have preload disable. Makes no difference.
It sounds to me like when FSX grabs the system time in the menu before flight, it loads the texture up for that season (without the "DisablePreload=1" line), and even if the season changes, the correct runway texture does not load, because the runway texture you started with at first or before reloading is still in memory and directx has not re-rendered the textures properly. Also when you change the season in flight, you may have to make FSX reload the time twice before you get the runway texture, because only then will the textures re-render. Just like you had to do.
Do you also have a problem with the initial load of runway textures if you have a saved default flight and change the season before loading the flight?

Share this post


Link to post
Share on other sites
Thanks for the tip. I have preload disable. Makes no difference.Do you also have a problem with the initial load of runway textures if you have a saved default flight and change the season before loading the flight?
This happened to me once, while changing the season in flight, but it has never occured changing the season from the main menu. Maybe weather is a factor?Try this:
  1. Load the default flight that came with FSX.
  2. After loading, change weather to clear all settings.
  3. Change plane to what you want in your saved default flight.
  4. Do what you need to do (engine off, etc.) before saving as the default flight.
  5. Save as default flight
  6. Quit FSX
  7. Load FSX, and change season in menu, with the clear skies still enabled.
  8. Hit Fly Now!, and see if it works!
  9. Quit again
  10. Start FSX
  11. Change settings to what you like (exp. plane, weather, time) and see if the problem is gone

If not, I guess you will you will have to change the time when the flight loads up so the textures will render again.Hoped this helped :(

Share this post


Link to post
Share on other sites

No it didn't work.Thanks for your effort to help! Very much appreciated.

Share this post


Link to post
Share on other sites
No it didn't work.Thanks for your effort to help! Very much appreciated.
No problem :( Sorry to hear it didn't work. As soon another light bulb lights up over my head I will post a suggestion. Good luck.

Share this post


Link to post
Share on other sites

Yes, I too have had this problem, in my case, when I have my default flight load, with KBWI my default airport and summer as the default season. The runway textures load as asphalt rather than as concrete, and sure enough, there is snow on the runway. I am also using an nVidia display adapter, and using nHancer to control the driver settings. The issue has appeared with both an 8800 GTS and 9800 GTX+ video card, and with numerous display drivers.It's only a minor annoyance, since if I go to the settings menu, select KBWI as the airport, and summer as the season, the runway textures then load properly. It only screws up when these setting load as the default.Go figure!Rich

Share this post


Link to post
Share on other sites

Rich,Thanks for your response. I'm still wondering if this is a general problem with FSX or only a problem for some users. I guess I have to settle with the conclusion: Maybe a design flaw in FSX SP2 - maybe not.

Share this post


Link to post
Share on other sites