Archived

This topic is now archived and is closed to further replies.

Guest tebinu

FS9 getting low FPS after couple of minutes

Recommended Posts

well, i have that problem for a couple of weeks now and i cannot remember what i did before. Its like when i start my flight, everything is ok but then suddenly it starts to gettin low FPS (down to 10 or less frames p second) then, when i minimize and maximize or change the view, its getting up again to the normal rate. so what the hell is going on there and why do i have to do that to keep my normal rate?edit: this returns from time to time so sometimes i have to do that 10 times and then its ok for rest of flight // normally i have 50fps, doesnt matter which aircraft/scenery)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

well, i have that problem for a couple of weeks now and i cannot remember what i did before. Its like when i start my flight, everything is ok but then suddenly it starts to gettin low FPS (down to 10 or less frames p second) then, when i minimize and maximize or change the view, its getting up again to the normal rate. so what the hell is going on there and why do i have to do that to keep my normal rate?edit: this returns from time to time so sometimes i have to do that 10 times and then its ok for rest of flight
My first thought is that you have something running in the background which from time to time is consuming cpu cycles.Some virus protection programs will run periodic checks and even your Operating System may be indexing files.Run with as little background programs and services as possible and you may see an improvement.Good Luck.

Share this post


Link to post
Share on other sites

Another thing, if you fly with complex planes or add-ons...depending on your settings, cfg file, and fps lock...the sim may slow down as you fly over land when it tries to render everything. Since I play at 60fps locked (i have to because of my trackIR) I need to hit "Refresh Scenery" every once in a while so my computer can catch up to all the loading going on, this did not happen when i used to play at 30fps locked.

Share this post


Link to post
Share on other sites

You did not cite your specs, so it would be hard to 'guess' what is REALLY wrong. Example: do you have 5400 or 7200 rpm HDrive?, amount of ram? NTFS or Fat32? Is indexing on? Last time you defragged? Etc, etc? Too many variables. Services are not always the root cause. Running IM type 'chores' in background (or, having a virus) would be more likely the cause of serious lag in sim (due to cpu 'activity' elsewhere).Chuck BNapamule

Share this post


Link to post
Share on other sites

i dont think its cause of my hardware. i got a brand new notebook with dual core cpu and geforce 9 series.. i can play fsx on it without problems. the problem is for a couple of weeks now. i turned off all background stuff but nothing happend. i will run a virus scan tomorrow to check that. thanks to this point !!:)

Share this post


Link to post
Share on other sites