Archived

This topic is now archived and is closed to further replies.

ahinterl

Help: Screen refresh rate problem

Recommended Posts

I have a CRT and run Vista x64 with 85Hz. When I fly in FSX in full screen mode, the monitor reports only 60Hz, and it's clearly visible that the screen refresh rate is terribly low.I have an LCD monitor (60Hz) connected to the 2nd DVI port of the graphics adapter and first thought FSX takes the lowest refresh rate of both screens since I have the desktop expanded to cover both monitors, but even after disabling the LCD in the NVidia control panel (it's black now) the problem doesn't go away.Due to the cabling that I use both monitors are connected to the DVI connectors of the graphics adapter via DVI-to-VGA adapters.Why does Vista run with the proper refresh rate and FSX not? I use the latest NVidia drivers as per today's date (but nothing else, i.e. no tweak utilities). I'd prefer full screen mode in FSX, I guess when I go to windowed mode the refresh rate would be correct...My system specs:Core2 8500, NVidia GTS 250 1GBAny help highly appreciated!Andreas

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You have a LCD. You also have a CRT as '2nd' monitor. You effectively lowered the video card capability to VGA level, so you can use the CRT monitor, yet want it to do it at 60 Hz? Don't think CRT can do THAT (no matter the cable). Top notch PC specs, ruined by a CRT monitor? Don't make sense.I would turn off PC power, disconnect the CRT , remove DVI to VGA cable (yuk!), plug LCD to DVI output, set res for desktop to what you expect to use in FSX, run the nVidia setup prog and remove the 2nd monitor, etc, and enjoy your LCD, 67 million colors, 1280x1024, 60 Hz in FSX and wait until you can get another LCD monitor to expand your desktop. (What you're doing is like someone removing half of the spark plugs in a car to 'increase gas milage', yet expect (no, DEMAND) that it cruise at 90 MPH (yeah, right!).Chuck BNapamule

Share this post


Link to post
Share on other sites
You have a LCD. You also have a CRT as '2nd' monitor. You effectively lowered the video card capability to VGA level, so you can use the CRT monitor, yet want it to do it at 60 Hz? Don't think CRT can do THAT (no matter the cable). Top notch PC specs, ruined by a CRT monitor? Don't make sense.I would turn off PC power, disconnect the CRT , remove DVI to VGA cable (yuk!), plug LCD to DVI output, set res for desktop to what you expect to use in FSX, run the nVidia setup prog and remove the 2nd monitor, etc, and enjoy your LCD, 67 million colors, 1280x1024, 60 Hz in FSX and wait until you can get another LCD monitor to expand your desktop. (What you're doing is like someone removing half of the spark plugs in a car to 'increase gas milage', yet expect (no, DEMAND) that it cruise at 90 MPH (yeah, right!).Chuck BNapamule
Are you joking? LCD are junk! :) Crt can usualy go Higher rez, better with color gamet and last longer - Bad energy and heat and you have scan lines if too big a dot ptich. my desktop is a Dell 2408 LCD, its nice but I miss my trinitron. Its the LCD 60hz holding back the CRT.

Share this post


Link to post
Share on other sites
I have a CRT and run Vista x64 with 85Hz. When I fly in FSX in full screen mode, the monitor reports only 60Hz, and it's clearly visible that the screen refresh rate is terribly low.I have an LCD monitor (60Hz) connected to the 2nd DVI port of the graphics adapter and first thought FSX takes the lowest refresh rate of both screens since I have the desktop expanded to cover both monitors, but even after disabling the LCD in the NVidia control panel (it's black now) the problem doesn't go away.Due to the cabling that I use both monitors are connected to the DVI connectors of the graphics adapter via DVI-to-VGA adapters.Why does Vista run with the proper refresh rate and FSX not? I use the latest NVidia drivers as per today's date (but nothing else, i.e. no tweak utilities). I'd prefer full screen mode in FSX, I guess when I go to windowed mode the refresh rate would be correct...My system specs:Core2 8500, NVidia GTS 250 1GBAny help highly appreciated!Andreas
I'm pretty sure that the video card cannot deliver two different refresh rates to the two outputs simultaneously... so either you choose to run at 60 Hz (LCD refresh rate) or 85 Hz, but without the LCD.
I'm pretty sure that the video card cannot deliver two different refresh rates to the two outputs simultaneously... so either you choose to run at 60 Hz (LCD refresh rate) or 85 Hz, but without the LCD.To do what you are wanting to do would require a second video card.

Share this post


Link to post
Share on other sites

Thank you for the suggestions so far.I'll detach the LCD and try with the CRT alone. Currently I cannot afford a 1600x1200 LCD, so I try to keep the CRT.Surprisingly, the graphics adapter indeed delivers two different refresh rates (85 Hz for the CRT and 60 Hz for the LCD) under Vista, I can set that in the NVidia Control Panel application and see this reflected on the on-screen-display info boxes of the displays.The problem is that when FSX switches to full screen, the Vista refresh rates aren't propagated and FSX downgrades to 60 Hz for some reason...Interestingly that this worked with an old ATI 9800 Pro under FS2004, same configuration (except that the 9800 Pro didn't have 2 DVIs but 1 DVI and 1 VGA connector instead).I hoped that there's maybe some parameter for the video driver that forces and locks a certain refresh rate, or that there's a parameter in FSX's .ini file that tells it what refresh rate to use.It's unclear to me on what basis FSX decides to change the refresh rate that's defined in the OS... I have the impression that my problem is video driver related...If everything else fails, I'll try some tweaking utilities for NVidia adapters and maybe run FSX in windowed mode (where I hope it keeps Vista's refresh settings).Andreas

Share this post


Link to post
Share on other sites

After doing a lot of research, I found out that there's a major issue with modern graphics adapters and monitors and games, namely that games (usually DirectX or OpenGL) run with only 60Hz on CRT screens.The widespread usage of LCD screens makes this problem not so evident, but it still remains for people who don't have LCD monitors.The combination of FSX, Vista and an NVidia GTS 250 let me run into that very problem. I discovered several methods to work around it, and I will test during the weekend and hope I'll find a solution.CRT users should be warned somehow... It's a pity that manufacturers of graphics adapters don't longer deliver refresh rate override options in their drivers...Andreas

Share this post


Link to post
Share on other sites