Jump to content

Archived

This topic is now archived and is closed to further replies.

Varmint007

non-shading illumination

Recommended Posts

I'm wondering if it's possible in Gmax (FSX) to configure an emissive (non-gauge) material with self-illumination so that it simply doesn't shade? While emissive, every blending mode I've tried results in some form of shading, becoming brighter or darker based on VC attitude relative to the sun. I know it's possible with gauge materials, but I would like to apply it to non-gauge materials as well.In FS9 I did this by editing the material properties of the .X file before compiling externally with BGLC_9. But I'll be damned if I see a way to do it through the Gmax material properties?Thanks,--Jon

Share this post


Link to post
Share on other sites
I'm wondering if it's possible in Gmax (FSX) to configure an emissive (non-gauge) material with self-illumination so that it simply doesn't shade? While emissive, every blending mode I've tried results in some form of shading, becoming brighter or darker based on VC attitude relative to the sun. I know it's possible with gauge materials, but I would like to apply it to non-gauge materials as well.In FS9 I did this by editing the material properties of the .X file before compiling externally with BGLC_9. But I'll be damned if I see a way to do it through the Gmax material properties?Thanks,--Jon
Jon, try using Additive Mode instead of Blend or Multiply-Blend.

Share this post


Link to post
Share on other sites
I'm wondering if it's possible in Gmax (FSX) to configure an emissive (non-gauge) material with self-illumination so that it simply doesn't shade? While emissive, every blending mode I've tried results in some form of shading, becoming brighter or darker based on VC attitude relative to the sun. I know it's possible with gauge materials, but I would like to apply it to non-gauge materials as well.In FS9 I did this by editing the material properties of the .X file before compiling externally with BGLC_9. But I'll be damned if I see a way to do it through the Gmax material properties?Thanks,--Jon
Hello again Bill. Actually, I FUBARed my question. I should have said I was looking for a mode that doesn't do anythingto the texture, essentially leaving it alone in shade or light. Yes, additive works great for making things bright, but in fact that's the problem; things get TOO bright once the material is combined with the ambient light. Do you know if final render alpha or any other setting can cap or attenuate the final "combined" result of additive?Thanks again for your always helpful advice.--Jon

Share this post


Link to post
Share on other sites

Ah, in that case try checking the box for "Use no base specular" (or words to that affect, I don't have Max/GMax open currently to verify)...

Share this post


Link to post
Share on other sites

Hi Bill,Yessir, I have no specular (for the lamps) and I even have "Ignore Background Specular" disabled. I think I've found a way around the problem by carefully adjusting the lightmap for that material. You see, the annunciator lamps aren't gauge maps at all. They're polygons which are shown/hidden with code. So instead of basically having a copy of the diffuse color in the night map, I went with a much less saturated version to compensate, and it seems to work ok, although not nearly as well as it did in FS9 by forcing the material not to shade (or get brighter). In FS9 the lamps were totally unaffected by ambient light after hacking up the ASMs. (which was wonderful).compare.jpgUnfortunately now I have yet another problem I don't understand. As you can see in the images, the center image is completely washed out by the vclight.fx. And I'm not talking about overall brightness, but the fact that the entire specular map for those materials is being ignored when this effect comes on. I have explicitly disabled background specular. So this begs the question, how are dome/cabin lights and the like actually working in FSX? Of course I could use night maps to simulate the wash, but I would like to have the entire cockpit light up without loosing all my specular maps! Do you know what's behind this?Thanks again,--Jon

Share this post


Link to post
Share on other sites

Man, that's looking nice! I see that the Blend mode seems to work best for you in this instance.I'm afraid I don't have an answer to the issue of how the .fx overhead lights are affecting the lighting of the panel textures... Perhaps lowering the intensity of the .fx might help tone it down a bit.

Share this post


Link to post
Share on other sites

Right, that was something I tried right away, but unfortunately didn't solve the real problem which is why the specular maps are being tossed out the window when the vclight.fx comes on. If you look at the holes for the screws for example, you can see that everything is a uniform wash and the specular mapping is just not "on" any more. Conversely if a material has no specular map at all it's not affected by the vc light at all.I'm really surprised nobody has mentioned a problem with vclight.fx in FSX before. Maybe I'm just missing something painfully obvious (it's been known to happen!), but something is definitely broken here. All maps including specular and bump work just fine until you hit that damned cabin light. --Jon

Share this post


Link to post
Share on other sites

I've probably never noticed because I don't use specular maps at all in the VC... or, at least not so far! ;)

Share this post


Link to post
Share on other sites
I've probably never noticed because I don't use specular maps at all in the VC... or, at least not so far! ;)
Well just to follow up, I've narrowed it down to the normal map. As far as I can tell, and I really hope I can find a solution, if any VC material contains a normal map and a vclight.fx of any radius or color is turned on, you'll get the result in the center image above. Only the diffuse texture is output and it will no longer shade in any way, instead appearing washed out and completely flat.I've tried a sample test with a number of builds and the result is always the same regardless of the blending mode. Normal map + VClight = FUBAR :(

Share this post


Link to post
Share on other sites
Well just to follow up, I've narrowed it down to the normal map. As far as I can tell, and I really hope I can find a solution, if any VC material contains a normal map and a vclight.fx of any radius or color is turned on, you'll get the result in the center image above. Only the diffuse texture is output and it will no longer shade in any way, instead appearing washed out and completely flat.I've tried a sample test with a number of builds and the result is always the same regardless of the blending mode. Normal map + VClight = FUBAR :(
I've seen this too... But I hadn't tried to debug it. ...Normal maps recently added.

Share this post


Link to post
Share on other sites

I don't use normal maps for VC textures either. I bake any "bumps" onto the Diffuse textures, or "fake it" using Photoshop's excellent "Texture Filter" to add a subtle "Sandstone" effect to the plain color(s).

Share this post


Link to post
Share on other sites

×
×
  • Create New...