Archived

This topic is now archived and is closed to further replies.

J van E

DX10 with Vsync ON! (?)

Recommended Posts

Maybe this is old news, but I didn't know it, so... here it goes.I've been flying with the DX10-preview option ever since I installed FSX (on Windows 7 64 bit) a few weeks ago. It runs great but some things are not too good: my main problem with DX10 is that you can't use Vsync (ON) (ingame FSAA isn't a problem for me). Still, DX10 runs so much better that I stuck with it. Since nHancer didn't seem to have any use for DX10 (FSAA not supported), I didn't install nHancer for my GTX285. This week I bought a SSD specially for FSX and after installing it all (Windows 7 and FSX) I decided to give NickN's setup another chance, so (amongst others) I installed nHancer and set it up according to the instructions. I am using the lastest official driver right now, 195.62. Well, DX9 and Nick's setup didn't do enough for me in DX9 so I decided to switch back again to DX10. I decided to leave all nHancer settings as they were, because I've been installing things for days now and didn't feel like uninstalling nHancer right now. I started FSX, loaded a flight and immediately I noticed... Vsync was working!!! The tearing was gone!!! The screen was rock steady! Apparently what nVidia's driver can not do (force Vsync ON with DX10 preview), nHancer CAN do! So all you DX10 lovers who still have Vsync off and don't like it, you might want to give it a try and see if it works for you too (hence the (?) in the topic title, because I am not 100% certain what made Vsync work).EDIT:I have to add btw that setting up the system completely according to NickN's settings (apart from the defrag) I have to say FSX with DX10 had some benefit from it all: things run a bit better now: when I look around with the TrackIR there may be some small stutters, but when I keep my head (sort of) still everything is pretty smooth. Before settings things up like this I also had some occasional stutters when NOT looking around.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jeroen,Just curious because I'm not sure what you think you are seeing or not seeing in DX10 preview, but neither nHancer or the Nvidia Control Panel can be used to force Vsync on in FSX. Vysnc was hardcoded off in FSX SP2 DX10 Preview and FSX itself will not allow the parameter to be overridden (FSX has exclusive control of the parameter under DX10 Preview and it will always be off no matter what). The only thing that could fix Vsync under DX10 Preview would be for FSX to recoded and we know that is not going to happen. Is it possible that you are maintaining your framerates high enough now that the tearing is not as visible as it once was?Regards,Bob

Share this post


Link to post
Share on other sites

Jeroen isn't seeing things, he's right. It is in fact working on Win 7 64 bit, at least for me. I was never able to get it working on Vista, so I'm not sure what changed in Win 7, or whether it was the newer Nvidia drivers or Nhancer that did it, but Vsync works perfectly in it. I've tried to break it by using unlimited frames and using very odd number framerate locks, 23, 25, 27 etc, ones that should nicely fight with the native LCD refresh, and it still works. DX10 was a non-starter for me since screen tearing gives me a headache in minutes, but now it's certainly worth messing with. In windowed mode the tearing is very clear, but in full screen... rock solid. Water that looks great in DX9 still looks a little scary, but that shouldn't be too hard to fix up, and with the progress being made on the taxiway flickering issue I think DX10 may actually be useful to more people soon. :) Performance for me isn't any better, but it isn't any worse either.Cool stuff.-Mike

Share this post


Link to post
Share on other sites

Ah, I am happy haldir noticed the same! Sargeski, Vsync off in FSX is very (let me repeat: VERY) obvious, specially with my TrackIR, so now it DOES work it also is VERY obvious! No mistake possible! :( Rock solid indeed.I've used FSX before with the 196.25 driver on Windows 7 64 bit but without nHancer Vsync did not work, so I think it is nHancer that somehow got it done. It's a miracle and a very nice one because to me Vsync off was the biggest problem with DX10 (because it is so obvious: lower ingame FSAA isn't as obvious: I got used to that).

Share this post


Link to post
Share on other sites
Ah, I am happy haldir noticed the same! Sargeski, Vsync off in FSX is very (let me repeat: VERY) obvious, specially with my TrackIR, so now it DOES work it also is VERY obvious! No mistake possible! :( Rock solid indeed.I've used FSX before with the 196.25 driver on Windows 7 64 bit but without nHancer Vsync did not work, so I think it is nHancer that somehow got it done. It's a miracle and a very nice one because to me Vsync off was the biggest problem with DX10 (because it is so obvious: lower ingame FSAA isn't as obvious: I got used to that).
Thanks for the reply guys. Thats very good news. Can anyone running Vista X64 chime in with their results. So we can figure out if this is due to Windows 7 or the NVIDIA drivers. It would be nice to nail it down.Keep your fingers crossed and maybe somehow they'll get the AA and AF working as well.

Share this post


Link to post
Share on other sites
Thanks for the reply guys. Thats very good news. Can anyone running Vista X64 chime in with their results. So we can figure out if this is due to Windows 7 or the NVIDIA drivers. It would be nice to nail it down.Keep your fingers crossed and maybe somehow they'll get the AA and AF working as well.
O, yes, I will keep my fingers crossed...! I never expected THIS to happen, so who knows...!On another forum someone said that with the old (and popular) 182.50 driver Vsync doesn't work no matter what, so it seems you need the 195.62 driver, but my own experience is that without nHancer it also doesn't work! So it seems you at least need the 195,62 driver, nHancer and probably Windows 7, although I haven't heard the results of someone with Vista. I also hope more people will test this, so we can see what exactly is needed.I just did a flight that was quite heavy during approach until now, even with DX10, but after setting the system up with NickN's suggestions, everything stayed smooth until the end. I could tell a little the system had to work hard (mainly because autogen popup became more apparent and closer to the plane) but it stayed smooth nonetheless (fps also dropped of course but I learned not to care about fps: it was still above 25 btw (yes, I don't care but I DO check :( ). Having Vsync on really makes it all look smoother also, of course!!! And a LOT easier on the eyes!So, my conclusion for now, for those who are struggling to get FSX running properly: get a SSD, put Windows 7 64 bit and FSX on it (I have a dualboot system now, with that SSD completely dedicated to FSX), get the 196.25 driver and nHancer. set everything up as NickN suggested (forget about defragging with the SSD), use the DX10 preview, get used to the ingame FSAA and ENJOY! :(

Share this post


Link to post
Share on other sites

Well no way no how can I get Dx10 Preview to have FSAA. With or without nHancer and with or without any driver. Currently using 195.81, and they are just fine when using Dx9.0c.Any ideas?

Share this post


Link to post
Share on other sites

Right now the only way to get FSAA in FSX is to enable it in FSX itself.

Share this post


Link to post
Share on other sites
Right now the only way to get FSAA in FSX is to enable it in FSX itself.
I tried that too.

Share this post


Link to post
Share on other sites