Jump to content

Archived

This topic is now archived and is closed to further replies.

Capt. Windh

OK.. Please help the noob out!

Recommended Posts

Unfortunately you probably have your settings too high. Using similar settings gives my i7 similar performance.One thing though that did help me get a few more fps is turn the antializing off in xplane. Set that to go in your video card driver settings.You might want read this thread where some of these issues were discussed:http://forums1.avsim.net/index.php?showtopic=269536
Ok, Geofa, thanx. But where can I change color depth? And is it no problem that it still says "Demo" in the startup?/Johan

Share this post


Link to post
Share on other sites
Guest Setanta
Ok, Geofa, thanx. But where can I change color depth? And is it no problem that it still says "Demo" in the startup?/Johan
The way you're set up you're running X-Plane in a window which means that it will use the colour depth that your monitor is set to before you run X-Plane (assuming that it works the same way as it does on Mac on PC). If you activate the full screen mode (Top left of the options screen) then you can choose what resolution and bit depth X-Plane uses from the pop up menu where it says 'Default Monitor Settings'. However, with a modern graphics card changing the bit depth is unlikely to give you much of a frame rate increase and may even cost you frame rate :/ It's very much a case of YMMV though.You should be getting much better frame rates than shown at those settings though. Possibly a driver problem. X-Plane uses OpenGL and works it relatively hard so it can expose driver problems that other software doesn't. Historically the 8800GT has had a few problems in the past. One recommendation I did come across was 'Make sure you have your system set to single-display mode in nVidia's control panel. Using multi-display is known to cause severe slowdowns in some OpenGL games.' though this was from 2007 so I'd expect it to have been sorted by now ;)As to the 'Web Demo' - if you want to get around that install X-Plane from your original disks and run the updater available from X-Plane.com. - Only way to be sure that it isn't causing a problem for you.Setanta

Share this post


Link to post
Share on other sites

Hi Johan, it should not say demo if u have disc 1 kept in your drive. Graphics card is just as important as CPU for xp, so make sure drivers are update and that u have (preferably) 1 gig of video memory. I have that and this means that u don't have 'compress textures' clicked. That makes ALL the difference, sell your grandma to avoid doing this, the clarity of xp really comes through then!Xp will always revert to 19 fps once it struggles, then will invoke the fog of war if it gets worse. My best assisters I've found- try minimising other ai planes, use medium level airport scenery setting, u don't need high car/ boat settings, try 20km vis. Best to start medium generally, increase an indiv setting, restart xp and if it goes well, increase something else. Doesn't take long. If u are greedy and start changing too many settings, u can temporarily cause chuggy performance, when restarting will fix! Fun stuffTry these great org links:http://forums.x-plane.org/index.php?showtopic=42965http://forums.x-plane.org/index.php?showtopic=42965http://wiki.x-plane.com/Setting_Up_X-Plane...est_Performance

Share this post


Link to post
Share on other sites
The way you're set up you're running X-Plane in a window which means that it will use the colour depth that your monitor is set to before you run X-Plane (assuming that it works the same way as it does on Mac on PC). If you activate the full screen mode (Top left of the options screen) then you can choose what resolution and bit depth X-Plane uses from the pop up menu where it says 'Default Monitor Settings'. However, with a modern graphics card changing the bit depth is unlikely to give you much of a frame rate increase and may even cost you frame rate :/ It's very much a case of YMMV though.You should be getting much better frame rates than shown at those settings though. Possibly a driver problem. X-Plane uses OpenGL and works it relatively hard so it can expose driver problems that other software doesn't. Historically the 8800GT has had a few problems in the past. One recommendation I did come across was 'Make sure you have your system set to single-display mode in nVidia's control panel. Using multi-display is known to cause severe slowdowns in some OpenGL games.' though this was from 2007 so I'd expect it to have been sorted by now ;)As to the 'Web Demo' - if you want to get around that install X-Plane from your original disks and run the updater available from X-Plane.com. - Only way to be sure that it isn't causing a problem for you.Setanta
Good catch-I use two displays. I found turning it to a single display gave me another 10 fps. Trouble is-I am used to and want to use two displays..I also have a 8800gt.

Share this post


Link to post
Share on other sites

Gentlemen, you have helped me to solve the performance issue.. The culprit was.... *drumroll* not flying in Full Screen mode.... I should have known... :(Turning on the full screen mode got rid of any performance messages, I fly now with most settings set to max, without any framerate issues!And it is STUNNING!Now it

Share this post


Link to post
Share on other sites
Guest Setanta
Hi Johan, it should not say demo if u have disc 1 kept in your drive.
D'oh - I should have realised that would sort it out ;)
Graphics card is just as important as CPU for xp, so make sure drivers are update and that u have (preferably) 1 gig of video memory. I have that and this means that u don't have 'compress textures' clicked. That makes ALL the difference, sell your grandma to avoid doing this, the clarity of xp really comes through then!
Good advice, though I'd add a couple of comments. Re GPU vs CPU - it largely depends on what setting you're changing. When it comes to shaders and texture memory constraints you're looking at the GPU as the limiting factor. This is also true for AA and AF, and interestingly enough trees. When it comes to AI aircraft and objects (including ground traffic) you're limited by CPU. Most fairly modern graphics cards can handle reasonably high settings in the areas where they are the limiting factor, where even the best CPUs tend to run out of steam fairly quickly with the current incarnation of X-Plane (mainly due to the fact that 90% of the processing is limited to a single processor/thread).Avoiding 'compress textures' is a good thing though how much it degrades the visuals depends on the particular situation at the time and the aircraft you happen to be using. I have a 512Mb card and find that I can run at 'extreme res' without problems. Note that the figure given at the bottom of the rendering options screen doesn't refer to the amount of graphics memory X-Plane requires on the card but the textures loaded by X-Plane itself. You can generally get away with about 150% of the memory in your card.
My best assisters I've found- try minimising other ai planes, use medium level airport scenery setting, u don't need high car/ boat settings, try 20km vis. Best to start medium generally, increase an indiv setting, restart xp and if it goes well, increase something else. Doesn't take long. If u are greedy and start changing too many settings, u can temporarily cause chuggy performance, when restarting will fix! Fun stuff
Again good advice. I'd also add that the 'world detail distance' setting is set to maximum by default and reducing this can make huge differences in frame rate, especially with the CPU bound stuff.
Good catch-I use two displays. I found turning it to a single display gave me another 10 fps. Trouble is-I am used to and want to use two displays..I also have a 8800gt.
I should be surprised that this hasn't been sorted out long ago, but somehow I'm not :( Given Microsoft's history of encouraging people to use DirectX in part by screwing with OpenGL support within Windows I sort of expected it :( Whether it's a driver issue or something in the OpenGL implementation, sadly it's outside of LR/X-Plane's control. :( Still, at least it explains some of your performance issues, though it doesn't really help a lot if you want to use multiple monitors.SetantaAhhh, just saw the preceding post :) Glad to have been of some help :)Setanta

Share this post


Link to post
Share on other sites

×
×
  • Create New...