Archived

This topic is now archived and is closed to further replies.

JBZ

Anti-Aliasing Help

Recommended Posts

Hello All,I have done much searching through this forum and others to help me find an answer. I know anti-aliasing has been discussed before, but after reading through and trying some of the various tips I am still having an issue.Here is my system:MSI P55-GD65 MainboardIntel i7 860 2.6 GHz OC to 3.5 GHz8 GB Kingson DDR3 MemoryATI HD 4870 (Single Core) 1 GB DDR5ATI CCC 10.2Windows 7 64 bit (updated)Vizio 32" HDTV @ 1680x1050FSX SP2REX, GEX, UTXMy FSX Settings:Frames: UnlimitedResolution: 1680x1050x32Anisotropic FilteringAA UncheckedGlobal Textures: Very HighLens FlareAdvanced AnimationsLOD Radius: LargeMesh: 100Mesh Res: 5mTexture Res: 1mWater: Low 2.xLand Detail TexturesScenery Complexity: Very DenseAutogen Density: DenseSpecial Effects: HighCCC 3D Settings:AA: 8x Wide TentAniso Filtering: 16xCatalyst A.I.: DisabledMipmap: High QualityWait for Vertical Refresh: Off unless specifiedAdaptive AA: QualityOpenGL: Triple BufferingNow, onto my problem. My game runs very smooth, in the picture below I'm getting 90-100 fps in the Sad Diego area without weather in the default baron. In full overcast weather I can get about 30-60 depending on the plane. The biggest problem I'm having is even objects close up like cockpit radio stacks, building and ground textures right below me, I'm getting horrible jagged edges. When I look into the distance and turn the plane, it looks like the ground is moving like water because the AA is so bad. I've tried enabling FSX AA and disabling CCC AA. I've tried reducing the AA. I've even gone as far as removing the current drivers and trying an older driver with no result. Can someone help me? I thought I read a thread in a forum that stated that ATI AA got really bad after a certain driver set, but I can't find which one. If I knew, I would try the older driver.-Jeremy

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jeremy,You have a nearly identical machine to mine.The main problem stems from two things actually: First, Adaptive AA (which antialiases inside textures and around alpha-test objects like trees, power poles etc) is broken in FSX in the ATI driver. I've tried to get them to fix it to no avail. The other issue is the ATI driver's lack of a clamped negative LOD bias for anisotropic filtering. Without that, there's always going to be some level of shimmering as the scene moves. I wouldn't use the Wide-Tent AA filter btw, Box is normal multisample AA and that's what I use. The other options will tend to blur the image too much and they rely on shader-based methods that the FS engine isn't really well suited to providing the card a good platform for. You probably want to leave Catalyst AI on too by the way, that's just their name for game-specific fixes/tweaks in the driver.If you download ATI Tray Tools at Guru3D, there's a few other things you can enable like High Quality AF mode that will help to some degree with this.

Share this post


Link to post
Share on other sites
Jeremy,You have a nearly identical machine to mine.The main problem stems from two things actually: First, Adaptive AA (which antialiases inside textures and around alpha-test objects like trees, power poles etc) is broken in FSX in the ATI driver. I've tried to get them to fix it to no avail. The other issue is the ATI driver's lack of a clamped negative LOD bias for anisotropic filtering. Without that, there's always going to be some level of shimmering as the scene moves. I wouldn't use the Wide-Tent AA filter btw, Box is normal multisample AA and that's what I use. The other options will tend to blur the image too much and they rely on shader-based methods that the FS engine isn't really well suited to providing the card a good platform for. You probably want to leave Catalyst AI on too by the way, that's just their name for game-specific fixes/tweaks in the driver.If you download ATI Tray Tools at Guru3D, there's a few other things you can enable like High Quality AF mode that will help to some degree with this.
I haven't had any issues with the AF, no blurry textures. I tried ATI tray tools but the only issue I was trying to solve was the AA which tray tools didn't help. Oh well, I can live with it, I'm getting killer frame rates and I'm about to buy a 4850 to crossfire with the 4870. I know people say that crossfire is hit or miss but I'm not doing it for improved performance so I'll let you know how it goes.

Share this post


Link to post
Share on other sites

Do you play other games at all? If not, then the Crossfire is really a waste I think, especially with ATI - it might make sense with a 5 series because those cards can do supersampling AA, but the 4 series can't even do that.

Share this post


Link to post
Share on other sites

Yes you are correct, which is why I'm not doing it for performance. I'm doing it for the multi monitor support. instead of spending $400 on a TH2Go, I spent $100 on a 4850 and will use eyefinity. Once the 5 series come down in price, I'll upgrade but I already spent 350 on my 4870 when it came out and at the moment there's no need to replace it. BTW, how's your i7 run at 3.8? I have a corsair water cooler on mine and at 3.5, doesn't exceed 60 degrees under load. Thought about taking it higher, but I'd hate to blow it up lol.

Share this post


Link to post
Share on other sites

Eyefinity is a Radeon 5 series-only feature man, might want to rethink that.My chip runs great at 3.8 - disable hyperthreading btw, that's the main producer of heat at higher speeds. It does absolutely nothing for you in FSX or most any game for that matter anyway. On water I bet you can hit 4GHz really easily with HT off. Vcore voltage might have to come up to 1.4 or so for 4GHz. (I'm at 1.35 for 3.8)

Share this post


Link to post
Share on other sites

Hmm interesting. 60+ FPS. I can barely do anything higher than 30 without FPS peaks and stutters and my system is packed with the best of the best I could find.Are you running settings at Max?

Share this post


Link to post
Share on other sites

As far as the ground is moving like water, yes I have noticed this with some very small textures, but rarely I might add, and this is with a GTX295.

Share this post


Link to post
Share on other sites
I'm getting 90-100 fps...
Why not limit FPS to 60? With a monitor refresh rate of 60 Hz you can

Share this post


Link to post
Share on other sites
That's not true, with no vsync you can go much higher, albeit with tearing etc...
I didn't know that. Thanks for the clarification, Ryan!Cheers,- jahman.

Share this post


Link to post
Share on other sites

Sorry I haven't posted in awhile, been busy working. Alright so I got my 4850 in today and Crossfired it with my 4870. To my surprise I actually saw a performance increase by about 10 - 15 fps in the clouds. So, once again, running smooth as ever, however, I still have that lingering problem. Because the picture doesn't really show my problem in detail, I created a short clip using Fraps. It can be downloaded here: http://www.thenewawe.org/test.rarAs you can see in the video, it's the ground textures I'm really having issues with. The jaggies aren't from the video being recorded by Fraps or condensed, that's what I really see when flying. I really have no idea what could be causing this. I downloaded ATI Tray Tools again and configured it to AA 8x Box and AF x16 with HQ Textures enabled, still no joy. Here are my FSX Settings:GRAPHICS TABFrames: UnlimitedFiltering: TrilinearAA CheckedGlobal Texture Res: Very HighLens Flare CheckedAdvanced Animations CheckedAIRCRAFT TABGlobal Setting to Medium HighSCENERY TABLOD Radius: LargeMesh Complexity: 100Mesh Res: 5 mTexure Res: 1 mWater: Low 2.xLand Detail Textures checkedScenery Complexity: Very DenseAutogen density: SparseSpecial effects: HighWEATHERCloud Draw Distance: 80 miThermal Visualization: NoneDetailed CloudsHigh coverage densityAbsolutely no traffic, I fly online all the time so I don't need AI traffic on and I certainly don't need to see boats and cars.Also note that I have tweaked my FSX.cfg according to Nick's Tweaks.

Share this post


Link to post
Share on other sites

Well, I found the cause of my problem and how to "fix" it. Because my HDTV is meant to be a TV and not a computer monitor it lacked a controlling device that most computer monitors have. This controller basically fakes faster refresh rates causing pixels to load faster than they need to. Because my HDTV didn't have this, I ended up with the jaggies up to my aircraft nose. I accidentally stumbled on the fix when I was in my CCC and saw LCD Overdrive. I clicked it and set it to 200 and started FS. To my surprise, the jaggies were gone but my textures were a bit blurry. I then returned to CCC and changed the setting to 100 (low) and viola! There are still some jaggies in the far distance, but it's way better than what it was before. I'm sure if I played with it some more I could find a balance between no jaggies and no blurry textures, but I'm happy with the way it is now.

Share this post


Link to post
Share on other sites