Archived

This topic is now archived and is closed to further replies.

Guest Rex247

Cannot get Vsync fix to work

Recommended Posts

I've tried every single fix there is for attempting to turn on VSync in FSX and none of it works. I've done as Bojote has said: I've turned "Wait for Vertical Refresh - On, unless application specifies" in CCC. I've added the line to my fsx config, and it simply doesn't stop the screen from tearing. I can't understand why this fix works for many others but not me. Can you help? Thank you AVSIM. The screen tearing is completely ruining my experience in fsx with my new 5850.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've tried every single fix there is for attempting to turn on VSync in FSX and none of it works. I've done as Bojote has said: I've turned "Wait for Vertical Refresh - On, unless application specifies" in CCC. I've added the line to my fsx config, and it simply doesn't stop the screen from tearing. I can't understand why this fix works for many others but not me. Can you help? Thank you AVSIM. The screen tearing is completely ruining my experience in fsx with my new 5850.
Rex247:Have you added the following lines to your fsx.cfg?[GRAPHICS]ForceFullScreenVSync=1 // Fixes vSync natively (Fullscreen)ForceWindowedVSync=1 // Fixes vSync natively (Windowed mode)If so, which driver are you using? I am using the latest Catalyst 10.9a (hotfix) and it works great with my 4870X2 (try at your own risk):10.9a hotfixMajor V

Share this post


Link to post
Share on other sites
Rex247:Have you added the following lines to your fsx.cfg?[GRAPHICS]ForceFullScreenVSync=1 // Fixes vSync natively (Fullscreen)ForceWindowedVSync=1 // Fixes vSync natively (Windowed mode)If so, which driver are you using? I am using the latest Catalyst 10.9a (hotfix) and it works great with my 4870X2 (try at your own risk):10.9a hotfixMajor V
I'm using 10.9 and have been using both those lines in my cfg file with no effect. The only tearing fix that worked for my system so far was D3Doverrider. Currently I'm looking for ways to eliminate the black screen problem associated with it.

Share this post


Link to post
Share on other sites
I'm using 10.9 and have been using both those lines in my cfg file with no effect. The only tearing fix that worked for my system so far was D3Doverrider. Currently I'm looking for ways to eliminate the black screen problem associated with it.
10.5 here, I have those two lines and they work perfectly for me - and this is with 3840 x 1024.At this time there is no fix that I'm aware of, that will fix those D3DOverider black screens.

Share this post


Link to post
Share on other sites
10.5 here, I have those two lines and they work perfectly for me - and this is with 3840 x 1024.At this time there is no fix that I'm aware of, that will fix those D3DOverider black screens.
Before I go installing an older driver, which I wouldn't mind, is the fact that the 2 lines don't work really the fault of the driver?

Share this post


Link to post
Share on other sites
Before I go installing an older driver, which I wouldn't mind, is the fact that the 2 lines don't work really the fault of the driver?
Rex247, did you try nicks guide yet ?

Share this post


Link to post
Share on other sites
Rex247, did you try nicks guide yet ?
You mean NickN? Yes I use most of his settings.

Share this post


Link to post
Share on other sites

Hey Rex,I hate to be redundant, but are you absolutely sure that you added:[GRAPHICS]ForceFullScreenVSync=1 // Fixes vSync natively (Fullscreen)ForceWindowedVSync=1 // Fixes vSync natively (Windowed mode)where it's supposed to be?When I first did it, I put it under the wrong section by accident.Might be a good idea to post your config for others to have a look?I certainly hope you get it sorted out. It was driving me nuts trying to figure it out before I found the .cfg fix.

Share this post


Link to post
Share on other sites

Yes. I made a new profile in FSX, added those lines, saved it and I loaded the profile. My OS is Windows 7 32-bit. I use Catalyst 10.9. I'm running FSX: Acceleration. Here's my config file:

[GRAPHICS]TEXTURE_MAX_LOAD=1024ForceFullScreenVSync=1 // Fixes vSync natively (Fullscreen)ForceWindowedVSync=1 // Fixes vSync natively (Windowed mode)NUM_LIGHTS=8AIRCRAFT_SHADOWS=1AIRCRAFT_REFLECTIONS=1COCKPIT_HIGH_LOD=1LANDING_LIGHTS=1AC_SELF_SHADOW=0EFFECTS_QUALITY=2GROUND_SHADOWS=0[sCENERY]LENSFLARE=1DAWN_DUSK_SMOOTHING=1IMAGE_COMPLEXITY=5[DISPLAY]BLOOM_EFFECTS=0SKINNED_ANIMATIONS=1TEXTURE_BANDWIDTH_MULT=40UPPER_FRAMERATE_LIMIT=30[PANELS]QUICKTIPS=0PANEL_OPACITY=100[TERRAIN]LOD_RADIUS=4.500000MESH_COMPLEXITY=100MESH_RESOLUTION=22TEXTURE_RESOLUTION=29AUTOGEN_DENSITY=5DETAIL_TEXTURE=1WATER_EFFECTS=4[WEATHER]CLOUD_DRAW_DISTANCE=3DETAILED_CLOUDS=1CLOUD_COVERAGE_DENSITY=8THERMAL_VISUALS=1DownloadWindsAloft=1DisableTurbulence=0[TrafficManager]AirlineDensity=59GADensity=59FreewayDensity=12ShipsAndFerriesDensity=30LeisureBoatsDensity=30IFROnly=0AIRPORT_SCENERY_DENSITY=3

Share this post


Link to post
Share on other sites

I've been thinking about it and the screen tearing isn't that game breaking. I was thinking about using DX10 because there were no black screen flashes, but the AA doesn't work at all which my card is fairly good at. So it seems the disease is better than the cure.

Share this post


Link to post
Share on other sites
I've been thinking about it and the screen tearing isn't that game breaking. I was thinking about using DX10 because there were no black screen flashes, but the AA doesn't work at all which my card is fairly good at. So it seems the disease is better than the cure.
This is nuts, Rex!OK - When you have the two lines added to the cfg file - are you still using D3Doverrider or any other ATI tools? (besides CCC)

Share this post


Link to post
Share on other sites
This is nuts, Rex!OK - When you have the two lines added to the cfg file - are you still using D3Doverrider or any other ATI tools? (besides CCC)
Nope, so they aren't conflicting. Is there anyone out there that can vouch it works with W7 32-bit, FSX: Acceleration and the 5850? Because If they can I really want to know how.

Share this post


Link to post
Share on other sites
Nope, so they aren't conflicting. Is there anyone out there that can vouch it works with W7 32-bit, FSX: Acceleration and the 5850? Because If they can I really want to know how.
Sorry, Rex; this one's like a brick wall. Your cfg looks ok, we're a bit different, but I see nothing that would prevent vSync from working.I'm running Win7-64 Professional, with the ATI 5870 gpu. In CCC I set "Use Application Settings" for AA - Narrow-tent"Use Application Settings" for AFCatalyst AI - Advanced - not disabled.MipMap - "Quality" (third bar)AA Mode - Performance[GRAPHICS]SHADER_CACHE_PRIMED_10=1693458482SHADER_CACHE_PRIMED=1693458482TEXTURE_MAX_LOAD=1024NUM_LIGHTS=8AIRCRAFT_SHADOWS=0AIRCRAFT_REFLECTIONS=0COCKPIT_HIGH_LOD=1LANDING_LIGHTS=0AC_SELF_SHADOW=0EFFECTS_QUALITY=2GROUND_SHADOWS=0TEXTURE_QUALITY=3IMAGE_QUALITY=0See_Self=1Text_Scroll=1D3D10=0ForceFullScreenVSync=1 // bojoteForceWindowedVSync=1 TEXTURE_MAX_LOAD=1024HIGHMEMFIX=1 // bojoteALLOW_SHADER_30=1 // SHADER_CACHE_VERSION=9872434 // this can be any number, forces rebuild of shader cache.STALE_BUFFER_THRESHOLD=24 // bojoteChangeTime=4.000000TransitionTime=4.000000SHADER_PARTIAL_PRECISION=1SHADER_OPTIMIZE=1//[Display]BLOOM_EFFECTS=0SKINNED_ANIMATIONS=1TEXTURE_BANDWIDTH_MULT=10 // 70UPPER_FRAMERATE_LIMIT=24WideViewAspect=TrueTextureMaxLoad=21[bufferPools]UsePools=0[Main]DisablePreload=1FIBER_FRAME_TIME_FRACTION=0.24[JOBSCHEDULER]AffinityMask=12[DISPLAY.Device.ATI Radeon HD 5800 Series.0]Mode=3840x1024x16Anisotropic=1AntiAlias=1

Share this post


Link to post
Share on other sites

I reinstalled FSX this morning and before installing Acceleration, I noticed I didn't get screen tearing! After I installed Acceleration, vsync stopped working. This is before I even used any tweaks, I just moved back and forth with the mouse and the screen didn't tear before acceleration. Does this information help me?

Share this post


Link to post
Share on other sites
Yes. I made a new profile in FSX, added those lines, saved it and I loaded the profile. My OS is Windows 7 32-bit. I use Catalyst 10.9. I'm running FSX: Acceleration. Here's my config file:
This appears to be your custom settings config file, not your FSX.CFG file. Try adding these lines to the same location in the FSX.CFG file. FSX may need these settings while it is loading rather than after you have reached the free flight window.Rick

Share this post


Link to post
Share on other sites
This appears to be your custom settings config file, not your FSX.CFG file. Try adding these lines to the same location in the FSX.CFG file. FSX may need these settings while it is loading rather than after you have reached the free flight window.Rick
I only recently learned there was another file. It works now, thank you.

Share this post


Link to post
Share on other sites