Jump to content

Archived

This topic is now archived and is closed to further replies.

martyneale

Cirrus clouds popping in and out at edge of visibility with 4870x2

Recommended Posts

Hi,I have noticed a problem with FSX using ATI 4870x2 - at the edge of the screen cirrus clouds pop in and out of view - see the following to understand the issue

The much hyped swarmcloud fix has no effect on this issue and I do not see the issue in X plane 9 - what is going on?

Share this post


Link to post
Share on other sites

If I remember well, in some place in FSX options panel, you should find the "Thermal streams" visualization option (sorry, I'm italian and don't know the exact name in english), this option is related the gliding flight.Maybe you have it enabled now.Mauro

Share this post


Link to post
Share on other sites
If I remember well, in some place in FSX options panel, you should find the "Thermal streams" visualization option (sorry, I'm italian and don't know the exact name in english), this option is related the gliding flight.Maybe you have it enabled now.Mauro
I am asking about the cloud pop up at the edge of the screen, not the thermal visualisation.

Share this post


Link to post
Share on other sites

Ok, sorry, it took a little to me to see what you where intending.Maybe you have a cloud overlay due to some add-on like REX or similar. Try to change cloud setup parameter to see if something happens.

Share this post


Link to post
Share on other sites

Hi,Try increasing your cloud draw distance in FS and see what happens.

Share this post


Link to post
Share on other sites
Ok, sorry, it took a little to me to see what you where intending.Maybe you have a cloud overlay due to some add-on like REX or similar. Try to change cloud setup parameter to see if something happens.
I am using flight environment x now - before I was using Real Environment x and had exactly the same issue. Is this a problem you have had?

Share this post


Link to post
Share on other sites
Hi,Try increasing your cloud draw distance in FS and see what happens.
This has no effect on the issue and neither does reinstalling the software - I am guessing the FSX software is faulty as there was a similar problem in previous versions - see here - http://www.flightsim.com/vbfs/showthread.php?54909-Flickering-clouds-at-visibility-edge. The fix can't be used in FSX as there is no sight distance slider.

Share this post


Link to post
Share on other sites
Is this a problem you have had?
No, sorry, I'm using REX (without overdrive pack) on my system with an XFX ATI 5770, but I haven't any issues.

Share this post


Link to post
Share on other sites
No, sorry, I'm using REX (without overdrive pack) on my system with an XFX ATI 5770, but I haven't any issues.
Can you post a video of panning with cirrus please?

Share this post


Link to post
Share on other sites

Happens to me all the time (using Nvidia) - it's an FSX thing, possibly to increase performance?? Have to live with it, I guess.

Share this post


Link to post
Share on other sites

You could try this,How to fix cloud popping// March 6th, 2009 // Tips & TweaksXHello there! If you are new here, you might want to subscribe to the RSS feed for updates on this topic.Powered by WP Greet BoxHave you ever noticed clouds popping instantly popping in to and out of view now and then, especially after upgrading to Acceleration? This is called “cloud popping” and minor, but annoying aspect of FSX. Changing your settings within FSX won’t solve it, fancy 3rd party cloud textures won’t solve it and tinkering with your FSX.CFG won’t solve it. Many people just learn to live with it, but you don’t have to as it can be fixed forever rather easily, though in a rather obscure manner.The problem isn’t with any internal settings, but with the cloud shader and how it caches materials. To fix it once and for all go to:<your root FSX install directory>\ShadersHLSL\miscOnce there look for SwarmCloud.fx and make a backup of it. Simply copying it into the same folder and renaming the copy SwarmCloud.ORIGINAL will do the job. Next, open the original SwarmCloud.fx file in Notepad (or another text editor of your choice) and find the following entry several lines down from the top:bool NewMaterialUsage = true;Change this value from true to false being sure to keep the semi-colon at the end, then save and close the file.Next go to the following directory:Windows XP:C:\documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\Windows Vista:C:\Users\<your username>\AppData\Local\Microsoft\FSX(If you can’t find this folder, you might need to ensure “Show hidden & system files/folders” is enabled first, which you can do through the Control Panel>Folder Options>View tab).Once there find the folder called “Shaders” (which houses a cache of all complied shaders) and delete all of it’s contents (not the folder itself, just the contents). You can also move the contents of the shader folder elsewhere for a backup if you prefer although deleting will be fine since FSX will rebuild it all the next time it runs.That’s it, start up FSX enjoy the fact that you’ll never see clouds popping in and out again. If for some reason you need to undo this change, simply edit SwarmCloud.fx changing “false” back to “true”, delete the contents of your shaders directory again and you’ll be back to default with it’s come-and-go clouds.If you liked this post, please share it...

Share this post


Link to post
Share on other sites
You could try this,How to fix cloud popping...
On a fresh FSX install that "fix" makes the cumulus clouds appear as black squares and rectangles so it is useless. I mentioned in my first post that it doesn't work.Update with acceleration installed it has no effect on the cumulus clouds but leaves the cirrus popping in and out of view! So it is a waste of time.

Share this post


Link to post
Share on other sites
Happens to me all the time (using Nvidia) - it's an FSX thing, possibly to increase performance?? Have to live with it, I guess.
Cheers thanks. So it isn't specific to ati cards. what kind of testing lets that get through lol?

Share this post


Link to post
Share on other sites
You can see my last settings here http://forum.avsim.n...-solved-for-me/And Sure, that's it http://www.youtube.c...h?v=t9secjTdvcM , without fraps running I had more than 100 fps in that situation.
Right thanks for all your help! I have figured out the problem! The issue is caused by panning with the mouse. If you pan with the keyboard using the default camera configuration settings the panning is fast enough not to see the clouds popping up - but if you use the mouse and spacebar - the new option in fsx - you see the problem. It is caused by the programmers using the same techniques for displaying clouds as in previous versions but not updating the code to reflect the new smoother panning option. The default pitchpanrate of 30 and headingpanrate75 hide the problem as in your video. Does anybody know how to change the panning settings for mouse?Can you make a video panning using mouse and spacebar?

Share this post


Link to post
Share on other sites
You're right!With mouse panning I've similar issues. I never noticed cause I never use mouse Applause.gifThis is the video http://www.youtube.c...h?v=OuC2d-fl-k0
Excellent work! Well done. I will make the Microsoft Flight team aware of this thread and hopefully we won't see this issue again! It was disgraceful that this got past testing as having a realistic sky is essential to any flight simulator and the fact that mouse panning is broken ruins a key aspect of the game. However we now know how to at least avoid the problem! What do other avsim forum members make of this?

Share this post


Link to post
Share on other sites

×
×
  • Create New...