Jump to content

Archived

This topic is now archived and is closed to further replies.

d191br4d

Run-Time Error '52'

Recommended Posts

Howdy,I purchased and installed RC today. After going through and fixing the first run-time error with the missing .dll file, I ran into this one and no mention of the error on these forums. The error occurs every time I read back clearance delivery. As soon as I get to the point of contacting ground for PB and Start it starts playing random chatter and the run-time error shows up. I've tried a lot of the fixes mentioned, from adding RC and FSX to my anti-virus whitelists, running without AV or Firewall, rebuilding scenery DB, clicking on .fpl/.wx and choosing the folder again.I'm not sure if this is a new thing, or an easy fix, so I am waiting to upload any logs until requested. I also re-downloaded the latest version of FSUIPC today based on another forum post.Thanks in advance for your help,Brad S.

Share this post


Link to post
Share on other sites

Run time error 52 officially means bad file name or missing file. Since you state you are having audio problems it could be:incomplete or corrupted installation of scripts or audio folders, something fouling up ram, etc.If you are using VISTA or Win 7, have you created a shortcut to RC with a property set to run as admin so it has full system access to what it needs including your FS and scenery folders and folders in your Documents folder? RC does a lot of hard disk reading and writing to create combined audio phrases and takes some ram to do this and .tmp files. To minimize ram usage, just try a flight with just RC and FS using a default aircraft. In RC options display.txt should be off as well as prerecorded chatter. AI chatter should be on and Interact with AI on.If you are using an onboard sound chip some memory resources are used as opposed to an add-on sound card.What is your Windows operating system and FS version? Let us know how you make out with the updated FSUIPC now at 3.997b for FS9 and FSUIPC 4.709b for FSX from http://forum.simflight.com/topic/66139-updated-modules/. Have you rebuilt your scenery database from within RC using the latest MakeRunways 4.46 from http://forum.simflight.com/topic/66136-useful-additional-programs/ ?FSUIPC now uses the registry path for FS to install. Make sure your FS registry path is correct with this free utility FSX/FS9 Registry Repair Tool (36KB) from;http://www.flight1.com/view.asp?page=libraryIn VISTA or Win 7 you will need to right click on that .exe and select run as admin for it to have registry access.

Share this post


Link to post
Share on other sites
Howdy,I purchased and installed RC today. After going through and fixing the first run-time error with the missing .dll file, I ran into this one and no mention of the error on these forums. The error occurs every time I read back clearance delivery. As soon as I get to the point of contacting ground for PB and Start it starts playing random chatter and the run-time error shows up. I've tried a lot of the fixes mentioned, from adding RC and FSX to my anti-virus whitelists, running without AV or Firewall, rebuilding scenery DB, clicking on .fpl/.wx and choosing the folder again.I'm not sure if this is a new thing, or an easy fix, so I am waiting to upload any logs until requested. I also re-downloaded the latest version of FSUIPC today based on another forum post.Thanks in advance for your help,Brad S.
this is almost always caused by a strange character in the tail number or the gate number. click controllers, and look at the gates. remove any question marks. look at the plane information, is there a slash or something strange in there?jd

Share this post


Link to post
Share on other sites
this is almost always caused by a strange character in the tail number or the gate number. click controllers, and look at the gates. remove any question marks. look at the plane information, is there a slash or something strange in there?jd
Issue Resolved! Thanks JD - I replied to your e-mail last night as well. I guess it doesn't automatically pull in gate information since that's not included in the flight plan, and left a ? in the departure gate field. If you do include gates does the program give you detailed taxi information? Currently, without the gate information included, it just says to taxi and hold on departure, or taxi to gate on arrival.Thanks,Bradd

Share this post


Link to post
Share on other sites

There is no progressive taxi to or from a gate in RC4. If you include a gate ID in the RC controller page RC will announce those.I have no idea why you are seeing a default question question mark in the gate field. Mine have always been blank. Valid characters are alphanumeric with no punctuation of any kind.There is at least one payware add-on that some users have that runs in a pop-up window for graphic taxi path guidance.In version 5 departure we have tested spoken and text taxi path information as part of ground clearance to the runway delivered in one ground response. It is on the feature list whenever it gets released.

Share this post


Link to post
Share on other sites

×
×
  • Create New...