Archived

This topic is now archived and is closed to further replies.

mbunjes

oc mcp problem

Recommended Posts

JD, I recently aquired the Opencockpits MCP and it works flawlessly with the PMDG 737.However, when I start RC4, the heading increase rotary (ctrl-shft-H, which as far as I can see is not used in RC)) stops working.Decrease is still possible.I disabled all keyboard commands in RC except the number keys and the repeat last instruction key.Could you please assist ? regards Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go into your rcv4 folder. Make a copy of keyboard.dat and rename the copy to keyboard.hld as a backup. The next step must be followed exactly! Open keyboard.dat using the open-with by right clicking on the file name, choosing notepad if you have it. If not use wordpad. You will see number 840. Highlight the 40 with the mouse to type over it and put in 01 so it looks like 801. Do not change any spacing or the commas. Save the file as text type but keep the keyboard.dat extension. This will put a command of ctrl-shift-! in there. I hope that is safe to use. This field might have been a special command for jd to use. It is beyond the keyboard assignment table and not displayed. If you have problems put back the copy as keyboard.dat but still keep that safe copy as your license key is in it. Let me know if that solves that paroblem and does not create another.

Share this post


Link to post
Share on other sites

Ron, that seems to have solved the problem, great, thanksThat's ctrl-shft-exclamation mark, right ? I seem to have no conflicting commands anymore. regards Martin

Share this post


Link to post
Share on other sites

That's is what I used. If you detect another conflicting combination here's how to get the number for an innocuous setting in keyboard.data: Bring up the keyboard assignments tab in RC. Do not save any changes. Somewhere enter the key combination giving you a problem (after insuring the conflict is not already in the visible section of the table). Note the number in the rightmost column change upon entering the conflict and write it down. Now modify that line to get an innocuous substitute and write that down. Cancel the changes and close RC. Following the safe backup I mentioned open keyboard.dat and look for the conflicting number. High light it by dragging the mouse of it being careful to cover the number only, not any spaces or commas, and type in your new number not adding any spaces. Save it and you should be good to go. The five numeric fields before the license key are the ones not displayed on the key assignments tab. If the offending command assignment is not displayed in the assignments tab, then those last five numbers are where it might be if it is an RC caused problem.

Ron, that seems to have solved the problem, great, thanksThat's ctrl-shft-exclamation mark, right ? I seem to have no conflicting commands anymore. regards Martin

Share this post


Link to post
Share on other sites