Jump to content

Archived

This topic is now archived and is closed to further replies.

ArjenVdv

Can't run FSX on my new system - "MSXML 4 SP2 component not installed." PLEASE HELP!

Recommended Posts

Hello,I've just gotten my new system (as you can see in my signature, updating GPU soon). I installed Windows 7 Home Premium 64 bit, along with the motherboard's drivers, then I downloaded the NVIDIA driver for my card, restarted my pc so I got a normal full HD screen. Then I activated Windows 7. After that I installed FSX without any problems. But when I was trying to run it though, it was saying this: "The MSXML4 SP2 component is not installed. Please reinstall Flight Simulator to restore or repair this missing component."I did that and still I get this message. Could anyone please help me? I've never had this problem on any of my previous pc's before. I'm kinda fed up with FSX actually, I love to fly. But I've been spending more time solving problems than playing the game itself. There's always something wrong with FSX. It would be really nice if you guys could help me!Thanks in advance,


Arjen Vandervelde

Share this post


Link to post
Share on other sites

First, update WIndows 7 ... Check updates and update it. When finished, re-check updates again, will appear new updates ...Otherwise, you can download the MSXML SP2 directly from:http://www.microsoft.com/download/en/details.aspx?id=19662


José Fco. Ibáñez /// i7 6700k (Delid) @ 4,6 Ghz /// Asrock Z170 OC Formula /// 16GB RAM G.Skill Ripjaws V 3200 /// GTX 1070 Founders Edition 8GB /// LG 27UD58 4K 27' // OCZ Vertex 4 SSD (X-Plane 10) & SAMSUNG 850 EVO SSD (P3D V3) /// Windows 10 Pro x64

 

sig_FSL-By-Wire.jpg

Share this post


Link to post
Share on other sites

Yep, always get the updates on a fresh windows install.Also, it might be a good idea to kill your overclock while installing since it's a brand new system. That's never been a problem for me, but I've heard of others getting bad installs due to an OC they thought was stable. (not saying that's your problem either, just offering a tip)


Kenneth Weir

My Saitek yoke mod

 

i7 2600k @ 4.7

8GB Gskill CAS7

2x GTX580 SLI Surround + GT520 Accessory

Win7x64

Share this post


Link to post
Share on other sites

Guys thanks for all this. I simply downloaded MSXML 4 SP2 from microsoft.com, and everything is working fine now! Silly me, I was just thinking that FSX would install that automaticly (because it was saying so...), but unfortunately it didn't. After downloading and installing it it's working now, hopefully I can now enjoy FSX on max settings on my new rig! Just ordered the Saitek Cessna stuff, hopefully get it tomorrow! :D


Arjen Vandervelde

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    44%
    $11,005.00 of $25,000.00 Donate Now
×
×
  • Create New...