Jump to content
Sign in to follow this  
Guillaume D

RC4 not responding to keyboard inputs

Recommended Posts

Dear all,I have searched throught the forum extensively and could not find a solution so far. It seems the problem impacted quite a lot of users so you may be able to help me. I'm a registered user since 2 days, and RC4 does not react to keyboard inputs.RC4 seems to work fine. But I get no response from any number entered on either the keyboard or number pad.I am running Win 7 64bit with FSX. I am running as ADMIN, starting RC4 after the plane is fully ready for flight at the parking. I have set-up the keyboard shortcuts as CTRL + NUM PAD 1, 2, 3, etc...in order to not conflict with other FSX shortcuts. I am using the default 737 and A321.I have the latest version of FSUIPC.Please help. RC4 seems to be a very good software and so far can't use it !Thanks

Share this post


Link to post
Share on other sites
I have set-up the keyboard shortcuts as CTRL + NUM PAD 1, 2, 3, etc...in order to not conflict with other FSX shortcuts.
Numpad keys are probably not a good choice as their input depends on whether Num Lock is on or not. Best to choose regular main keyboard keys. I use Ctrl Shift 0-9 ; and / without problems.RegardsPete

Win10: 21H1 19043.1865
CPU: 9900KS at 5.5GHz
Memory: 32Gb at 3800 MHz.
GPU:  RTX 24Gb Titan
2 x 2160p projectors at 25Hz onto 200 FOV curved screen

Share this post


Link to post
Share on other sites

A typical problem is frequently due to dragging the inflight RC menu window around the focus is not set back to the aircraft panel panel view. The RC window should not have focus.Try running RC with just a loaded FS flight (default aircraft as you are doing) and no other add-on that might capture key strokes.FS by default uses the num pad keys for steering and other uses and I'm not sure if it defeats the numlock operation when it initializes.In addition as installed you might find the selection keys not as described in the default setting in the manual. Checkout the keyboard assignments tab in RC to verify what the current settings are.

Share this post


Link to post
Share on other sites

Hi Pete and Ronzie. It was easier than I expected. Just followed the advice, did not use the NUM PAD and instead I assigned CTRL + ALT + X, C, V, etc making sure it does not interfere with standard FSX strokes. Now works like a charm.Great software, will feel more like in real ATC environment now, look forward to fly the SIDs and STARs of my favourite airports !Thanks again for the good and quick support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...