Archived

This topic is now archived and is closed to further replies.

F100

Probleme avec simconnect

Recommended Posts

C'est dit dans le titre, j'ai un souci avec simconnect.

De janvier à juin, j'avais abandonné Fsx pour P3D. Avec P3D Plan-G se connecte correctement avec simconnect, et MyTraffic me fournit du traffic Ai.

Avec les évolutions de shader Dx10, je suis revenu à Fsx mais plus rien ne se connecte avec simconnect : Plan-G voit Fsx avec FsuiPc mais donne une erreur de time-out avec simconnect, MyTraffic ne genere pas d'Ai, et l'afficheur du Saitek n'affiche pas les fréquences radio.

J'ai fouillé sur la toile, mais sans trouver tellement d'autre solution qu'une réinstalle au minimun de Fsx (quasiment excluStraight%20Face.gif ) voire Seven (totalement exclu :mad: ).

 

Je ne peux pas croire qu'il n'y a pas sur le faux-rhum un wizard du simconnect qui va pouvoir m'aider...

D'avance, merci

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Philippe,

 

A tout hasard, essaye de ré-installer Simconnect à partir du SDK. Chez moi, ça se trouve dans

C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib\SimConnect.msi

 

Si tu n'as pas installé le SDK, il se trouve sur le DVD de FSX. Une fois installé, il faut le mettre à jour en fonction de ta version de FSX (SP2 chez MS ou Acceleration à partir du DVD)

Share this post


Link to post
Share on other sites

Merci JP.

J'ai déjà tenté cette manip, mais l'installation avorte avant la fin sans explication et bien qu'elle soit paramétrée en 'version précedente de Windows' (je suis sous Seven 64).

Je pense que j'ai dû plier un fichier de config. Je vais faire une installation sommaire de Fs sur mon portable pour voir ce qu'il y a dans les fichiers .cfg et .ini

Share this post


Link to post
Share on other sites

ça m'intéresse aussi car moi aussi Simconnect n'est plus reconnu par PlanG et FSrealWX.

Share this post


Link to post
Share on other sites

J'ai enfin réussi à reconnecter Plan-g avec simconnect.

Si vous faites la manip, soyez prudents et ne lésinez pas sur les sauvegardes

D'abord, dans panneau de configuration>programmes et fonctionnalités j'ai trouvé 2 exemplaires de "Microsoft Flight Simulator SimConnect Client vxxxxxx" que j'ai désinstallés . Attention, ne touchez pas à "Microsoft ESP SimConnect Client Vxxxx", c'est la version P3D.

 

J'ai réinstallé simconnect à partir du sdk (c:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib\SimConnect.msi). C'est visiblement la présence des versions déjà installées qui plantait mes tentatives d'installation

A l'issue de cette manip, Plan-G ne se connectait toujours pas.

J'avais dans un coin un ancien fichier SimConnect.xml contenant ceci :

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">

<Descr>SimConnect Server Configuration</Descr>

<Filename>SimConnect.xml</Filename>

<Disabled>False</Disabled>

<!-- Example Global (remote) IPv4 Server Configuration-->

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>IPv4</Protocol>

<Scope>global</Scope>

<MaxClients>64</MaxClients>

<Address>127.0.0.1</Address>

<Port>500</Port>

</SimConnect.Comm>

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>Auto</Protocol>

<Scope>local</Scope>

</SimConnect.Comm>

</SimBase.Document>

 

Je l'ai copié dans c:\Users\-nom utilisateur-\AppData\Roaming\Microsoft\FSX\SimConnect.xml.

J'ai paramétré Plan-G de la façon suivante :

fichier>options>Connection FS, connection avec : simconnect,mode reseau : IPv4, Ordinateur Fsx : Localhost, Port : 500.

 

Et ça roule.

 

Pour être complet et vraiment maitre de la situation, il faudrait bien connaitre le parametrage de simconnect.xml. Je vais voir ce que je trouve

Share this post


Link to post
Share on other sites