Jump to content

Archived

This topic is now archived and is closed to further replies.

jcomm

Icy Archer III

Recommended Posts

I have an icy Archer III with RC1 :-(

 

Any suggestions? It allways loads like this, no matter what weather conditions we've got...

 

 

Share this post


Link to post
Share on other sites

Just turn on the defroster fan. It is over on the right middle of the panel, just below the transponder.. My Archer III only ices when the temp drops below freezing, although the windshield will sometimes get foggy if the fan isn't on. .

 

Perhaps your weather settings are setting themselves below freezig when you load up, or maybe it isn't really summer in Portugal after all. :lol:

Share this post


Link to post
Share on other sites

Thx Donald! I thought there might be a defrost system, but couldn't find it ;-)

 

Nooo... it's hot & humid around here :-), and I was using RW weather...

Share this post


Link to post
Share on other sites

There are other click spots that are not obvious. Click on or around the papers on the left top of the dash panel and you get a nifty Archer checklist. Click the yoke to get rid o it. Click on the left Kolsman window in the altimeter and it is easy to read QNH or barometric pressure. Turn of the radios, and you will see a set of headphones.

Share this post


Link to post
Share on other sites

Click on the left Kolsman window in the altimeter and it is easy to read QNH or barometric pressure

 

Ah! Not knowing about that one made me use the data output to be able to read the QNH and set the altimeter accordingly! Thx!!!!

Share this post


Link to post
Share on other sites

×
×
  • Create New...