Jump to content

Archived

This topic is now archived and is closed to further replies.

Guest jlindbe

DX10 Preview and Nvidia Optimus

Recommended Posts

Guest jlindbe

Hi -

 

I currently have FSX on my laptop which has Nvidia Optimus (Intel HD4000 & GT640M). When in DX9 mode FSX shows the GT640M as my graphics card. Once I go to DX10 Preview my only option is the HD4000. Has anyone experiences this? Is there a fix? Any help would be greatly appreciated as on my old laptop I was able to use DX10 and preferred it to DX9.

 

Thanks,

 

John

Share this post


Link to post

You could try disabling the HD4000 in Device Manager or Bios so the laptop only runs on one video card.

Share this post


Link to post
Guest jlindbe

You could try disabling the HD4000 in Device Manager or Bios so the laptop only runs on one video card.

 

Thanks. It looks like even though the HD4000 card is showing the GT640M is still working, as the card temp rises and the control panel lists FSX as being used by the card.

 

John

Share this post


Link to post

Optimus technology automatically switches on and off. You can however force the technology to always use the NVIDIA card for a pariticular application.

  1. Right Click on your desktop and open the NVIDIA Control Panel
  2. In the left pane, expand 3D Settings and select Manage 3D Settings
  3. In the right pane click on the Program Settings Tab
  4. Add your FSX.exe to the Select a program to customize: list
  5. Under Select the prefered graphics processor for this program: select High-performance NVIDIA processor

Performing the above steps will ensure that FSX always runs on the NVIDIA card. Just keep in mind that Optimus technology was designed to automatically switch between GPUs to conserve battery life.

 

Regards,

 

Bob

Share this post


Link to post
Guest jlindbe

Thanks Bob. That is what I ended up making sure was set. For some reason FSX kept showing the HD4000 as the graphics card, even though the GT640 was active. It confused me for a bit. But I turned on the option to display when the Nvidia card was running in the tray tools, and sure enough once FSX started the Nvidia card kicked in.

 

John

Share this post


Link to post

Hey Guys,

I'm a long time reader and a first poster here on Avsim.

I was having the same problem with my Asus UX32VD, (Nvidia 620M and Integrated Intel 4000).

Upon clicking DX10 Preview, I restated FSX and the Integrated Intel 4000 GPU would show up as the primary graphics device, and the Nvidia device would disappear.

 

I looked around the last two days, there isnt much help out there, just a few dead end forums, but it appears this issue only applies to mobile laptop simmers. I decided to do my own testing and came to the same conclusion that the Nvidia GPU is in fact being utilized, as verified by GPU-Z's activity sensors.

 

However, I'm still wondering if there are some performance losses or FSX internal conflicts that this is affecting. If anybody knows how to get FSX, using DX10 Preview, to properly recognize and register the Nvidia GPU that would be excellent. FYI, I did follow the steps outlined by Sargeski, this was my initial solution as well, unfortunately it still didnt fix the problem.

Share this post


Link to post
×
×
  • Create New...