Jump to content

Archived

This topic is now archived and is closed to further replies.

finfly

OOM take N

Recommended Posts

After I got sorted out corrupted traffic files FSX found new way to irritate me. I'm now getting OOM errors at major airports if I have AI traffic enabled. Small airports load just fine and some times larger airports too.

 

I've now spend a day finding and trying various solutions to this. And two weeks fight to get FSX running.

 

There were no problems with my old setup with only 4gb's of RAM. This new one has 8gb's worth of RAM.

 

Any idea how to forge forward other than dumping AI altogether? I only have few ideas and very little interest to fight with this, so sorry about the irradiated tone.

 

-Is there possibility my RAM is faulty? CPU-Z shows all 8gb's OK though.

-I remember reading somewhere ASUS motherboard had issues with RAM configuration. Something here?

-Is my 500W PSU unable to cope with my setup, details are in attached image.

 

My graphic settings are in medium and AI traffic slider is in 20%

 

I really would appreciate any help!

Share this post


Link to post
Share on other sites

Your memory frequency appears to be wrong. Running CPU-Z, is the frequency one of the frequencies shown in the timing tables under the SPD tab? Are you using the X.M.P. profile (provides the best use of your installed system memory)?

 

It was me who stated I read somewhere that ASUS boards have a hard time setting the correct memory settings. This is only if you allow the ASUS board to set your frequency, timings, and the DRAM voltage automatically (auto is in all of those fields).

 

My system memory is rated at DDR3 1600MHz and I have that setting in the Memory Frequency. ASUS puts Auto in this setting if you have it automatically set up an overclock. Your memory frequency is 804 times 2 equals DDR3 1608MHz? Doesn't seem correct to me.

 

Your PSU should be okay as long as you don't overclock. You have the unlocked CPU so you can overclock and, in that case, I would go for at least 700 KW.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Sorry to bother you again Jim!

 

I tried with X.M.P enabled, still got the crash but memory frequency is now 1600Mhz. I did bit more research and it seems that I got wrong kind of memory. Apparently Intel CPU want's RAM with voltage of 1,5V and mine are 1,65V. According to this tread it means stability issues: http://www.tomshardw...voltage-setting

 

So much for buying motherboard and memory in bulk package to avoid issues. Time to write to supplier and hope I can change those, I guess.

Share this post


Link to post
Share on other sites

Apparently Intel CPU want's RAM with voltage of 1,5V and mine are 1,65V.

 

Okay. I'm using 1.65v RAM. For the X.M.P. profile, you should be able to set your DRAM voltage to 1.65. The other profiles, 1.50. So you are okay. I don't agree with the OP in the link you posted at all and the responder was correct. You will have problems if you use one of those profiles (under the SPD Tab) with the max voltage of 1.5 and you make it 1.65. You should also see in your ASUS bios on the Tools tab the correct frequencies/voltages, and timings for the memory it sees loaded on your system.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I did heavy reserch yesterday and some fighting with my vendor. End results were:

-Intel really don'tapprove over 1,5V voltage for RAM. If I would burn my CPU with 1,65V setting for RAM it would be out of warranty.

http://communities.i...om/thread/30798

Luis_Intel Jul 31, 2012 11:24 AM (in response to comp999)

Regarding your first question there is not any Intel processor that supports more than 1.5V memory.

 

About the list you sent, it only shows tested hardware with the system configuration described for third party motherboards manufacturers (checking only the i7-3770K processor). Based on the fact that the processor is a “K” unit (unlocked) those manufacturers tested memory over specifications with that specific processor to show customers that the processor supports it in combination with the specific motherboard, everything if the processor is overclocked, however that doesn’t means that we validate that memory to be used with the processor. From our side we don’t validate memory beyond 1.5V because the Memory Controller Hub (MCH) was not designed to support more than that.

 

The policy says that the customers can overclock their systems by their own risk, this because it is not supported by Intel and besides in case the processor fails due overclocking the warranty will not cover it.

 

-Running 1,65V 1600Mhz memory at full frequency but using only 1.5V voltage could have stability issues. (That's my situation)

-1,65V & 1600Mhz is cheaper combination so it is widly used

 

Anyhow it seems that I can have my memory replaced at no cost to 1,5V RAM. Let's hope this really happens and solves my problem.

Share this post


Link to post
Share on other sites

Back to square one. My vendor communicated that changing voltage to 1.65 won't ruin the warranty, so I tried X.M.P profile. Now setting look good but the FSX still won't load with all traffic activated. I can get to select flight screen and even load the flight in middle of nowhere, but JFK or EGGL, no hope.

And data from AppCrashView:

Fault Module Name : ai_player.dll

Exception Code: 0x00037489

 

I would appreciate any ideas and help.

Share this post


Link to post
Share on other sites

Glad you finally set your profile and memory to X.M.P. Your AI setting should be no higher than 40% and I recommend 30% (I know your OP says you have your AI set to 20% which is below normal and shouldn't be causing your problem. Just covering bases). The ai_player.dll usually occurs when there are too many requests for resources on your system and it just cannot handle it. What AI program are you using? WOAI? If you turn AI off in your fsx settings, will the crash still occur? If not, it's your AI program. Individuals who have had this fault module error and the exception code have fixed this problem by deleting or renaming the FSX.cfg, then restarting FSX and letting the config rebuild. This indicates to me that they had a bad 'tweak' enabled or they had their FSX settings set too high. You can try that too and, if you rename the fsx.cfg to fsx.orig your can simply rename the .orig back to FSX.cfg if this did not work.

 

Hope this helps.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

My AI is custom built and updated from PAI packages dating back to 2005. Almost everything has been replaced since. Sim works fine without traffic so I guess (sigh) next option is really thoroug housekeeping of my AI. It is going to take days to complete so I report back after I finish it. Fingers crossed it helps.

 

btw. There isn't native FSX cobitable version of ACA2005 is it?

Share this post


Link to post
Share on other sites

btw. There isn't native FSX cobitable version of ACA2005 is it?

 

I did a Google search for ACA2005 FSX and got this as one of the hits (bgl conversions for FSX) - http://aifs2.pvdveen.net/.

 

This is one of the reasons why I just went with MyTrafficX. It gets messy putting these packages together. Good luck!

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Now finally everything seems to be in control.

For future problems I had and the solutions

 

-Sim won't load past splash screen: corrupted AIFP conversion from FS9 to FSX

-OOM errors: Check RAM settings in BIOS

-Crash in 86% while loading flight in some airports: still few corrupted files

 

AIFP has some of ACA2005 functionality for FSX, most of the rest are in ACA2007 Light.

 

If you Jim wouldn't be 500 miles away I would buy you a beer. You have been such wonderful help! Thank you a lot!

Share this post


Link to post
Share on other sites

Glad you were able to get the AI problem fixed! Here's hoping for a happy and crash free New Year!

 

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

×
×
  • Create New...