Archived

This topic is now archived and is closed to further replies.

Guest Mik75

Performance issues

Recommended Posts

Hi there!

First of all, I have to say that I really love the fantastic MJC Q400. I rarely fly anything else since it is out! It is one of the most immersive aircraft addons ever released in my opinion.

There is one single issue that takes away a little bit of the fun, especially over dense sceneries:

On take offs or approaches and landings, I get regular stutters and wildly jumping FPS. I recognised, that every time Pro ATC/X becomes active and the ATC chatter sounds are being played back, or I am contacted by ATC, this drop in performance occurs. Then, my steady frames (externally locked at 30), can drop as low as 15-17. And, in some cases, I get really hefty stutters when Pro ATC is playing back voices.

I can observe that really nicely on a performance monitor on my G19: Normally, all CPU cores are active, but 2 more than the others. That's a little different with the Q400, the third core is between 80-100% most of the time, probably due to the external FDE of the Dash 8. If Pro ATC comes active, all cores go up to 100% and the performance drops so significantly. That gets better as soon as the audio playback of ATC is over. Other than Pro ATC, Opus FSX, Track Ir and the ACARS software of the VA I'm flying for, are running in the background. So it is a quite busy environment. The NGX doesn't suffer from this phenomenon. And, on flights without Pro ATC and the ARCAS running, the Q400 is super smooth too.

Here is my system specs, I know that it's not a high end system, but I actually thought it should have enough power to handle my kind of flying:

i5 3570K @ 4.4 GHz

16 GB CL9 RAM

GTX 670 2 GB

all installed on a 480 GB SSD

Win 7 64 bit

 

settings within FSX are in the middle, traffic is set to 23%

 

Thanks in advance for your help!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You seem to has self diagnosed the problem, I think it's ProATC you need to have a discussion with, as playing back audio shouldn't be using anywhere near 100% CPU. Either there is an issue with that software or perhaps the type of sound device you are using. If it's not a dedicated sound card with its own processor that you use then you are likely using a motherboard integrated sound device and they take CPU cycles/time from the main processor (thus robbing FSX and the Q400 of cycles) rather than one on a dedicated sound card.

 

Majestic on the other hand are running another simulator outside of FSX for their FDE, a much more complex computational task than creating sounds, and so it can and will be expected to use all the spare CPU cycles available at times, depending on the CPU it is running on and the load it is under.

I've been using integrated sound devices for a few years now and I fully intend to replace mine with a dedicated sound device as games are getting more and more demanding as far as sound goes.

Share this post


Link to post
Share on other sites

Thanks for your fast and detailed answer.

I think, I'll try to run Pro ATC on my networked laptop. Maybe that will free up some resources to keep the FSX performance smooth.

Share this post


Link to post
Share on other sites

It's certainly worth a try, it should help you rule out once and for all whether ProATC is really to blame.

Share this post


Link to post
Share on other sites

Michael, please provide some feedback on networking ProAtc helps in performance.

 

 

And Andy thanks for the info on sound cards, had no idea that an external sound card could give better performance

Share this post


Link to post
Share on other sites

Sure, I'll report back here as soon as I have some results. Hopefully, I'll find the time to set up everything up tomorrow.

Share this post


Link to post
Share on other sites

Michael, please provide some feedback on networking ProAtc helps in performance.

 

 

And Andy thanks for the info on sound cards, had no idea that an external sound card could give better performance

 

Sorry, it took quite a while until I found the time to install Pro ATC/X on my laptop and set up everything in the network. The setup itself went avsolutely flawlessly. No problems at all. And the result is perfect! The performance issues in the Q400 (and in the PMDG J41) are completely gone, everything is smooth as silk, even over dense scenery!

Beside Pro ATC, I have Aivlasoft EFB, the Arcars of my VA and Navigraph's Chart software running on my laptop, and I had not a single stutter on my last 3 flights!

Everyone with a second computer should give this a try. It is also very cool to hear the voices of Pro ATC through the laptop's speakers. It's very immersive and very handy to adjust the volume of the ATC on the fly...

Share this post


Link to post
Share on other sites

Thanks for the feedback on networking ProATC. Appreciated :smile:

Share this post


Link to post
Share on other sites