Archived

This topic is now archived and is closed to further replies.

mikeinflight

3 monitor main panel flashing cursor

Recommended Posts

So I have downloaded the new panel.cfg files for all aircraft to solve the problem of the flashing cursor when doing a Shift+1 for the main panel.  All of the other 2D windows are resized perfectly and work great.  The problem is on the main panel only on some of the aircraft.  On some aircraft it fixes the problem where the main panel is perfect.  There are some where it is still having the issue where the main panel doesn't pop up and I get the dreaded flashing cursor like the computer is constantly thinking.  Any ideas on a fix for this?  I'm not that well versed on reconfiguring the panel.cfg files as far as resizing.

 

If anyone has had the same issues I would love to hear how you fixed it.

 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Which aircraft is giving you grief?

 

See if you can comment out unwanted pannels in panel.cfg file with a "//"

 

This is what I have for the Aerosoft Aibus Extended. I basically don't care for their 2d Panels or menus.

 

 

[Window Titles]
Window00=Main Panel
//Window01=Horizontally Panel Bar
//Window02=Vertical Panel Bar
//Window03=Checklist Info
//Window04=Horizontally Wing View Bar
//Window05=Vertical Wing View Bar
Window06=Left MCDU
//Window07=DEBUG

 

 


If anyone has had the same issues I would love to hear how you fixed it.
 

Share this post


Link to post
Share on other sites

Issues with the Lear 45 and I think the Beech Baron 58 and possibility one or two others.  I run a 4th monitor where I like to put the main panel and have the three on top with the view with nothing. This issue doesn't work for that.  Any ideas?

 

Which aircraft is giving you grief?

 

See if you can comment out unwanted pannels in panel.cfg file with a "//"

 

This is what I have for the Aerosoft Aibus Extended. I basically don't care for their 2d Panels or menus.

 

 

[Window Titles]
Window00=Main Panel
//Window01=Horizontally Panel Bar
//Window02=Vertical Panel Bar
//Window03=Checklist Info
//Window04=Horizontally Wing View Bar
//Window05=Vertical Wing View Bar
Window06=Left MCDU
//Window07=DEBUG

 

Share this post


Link to post
Share on other sites

Hi Mike,

 

Did you remember to apply the fixes to the mini panels as well?

 

Here is a possible workaround;

 

1.  Start the flight with say, the lear jet that's giving the problem,

2.  Using the 'W' key on your keyboard, cycle through the views untill you get 'no instruments', ie full panel,> mini panel, > then view only. Stay on view only.

3.  Go to the menu, (press alt ), select aircraft, then change aircraft, select the same one, ie, lear jet and OK.

    should be, when you return, the flashing curser will be gone.

4. From menu, go to views, select new view,  instrument panel,  then drag the new instrument view to your 4th monitor.

 

5. If the curser returns, repeat steps 1 - 3.

 

This works sometimes with that horrible spinning thing.

 

Ron D.  :unsure:

Share this post


Link to post
Share on other sites

Hi Ronski,

 

Thanks for the input.  I am not aware of the mini panel fixes.  I only have the panel.cfg file I believe for the fix.  Where can I find the mini panel fixes?  What does this exactly fix?

Hi Mike,

 

Did you remember to apply the fixes to the mini panels as well?

 

Here is a possible workaround;

 

1.  Start the flight with say, the lear jet that's giving the problem,

2.  Using the 'W' key on your keyboard, cycle through the views untill you get 'no instruments', ie full panel,> mini panel, > then view only. Stay on view only.

3.  Go to the menu, (press alt ), select aircraft, then change aircraft, select the same one, ie, lear jet and OK.

    should be, when you return, the flashing curser will be gone.

4. From menu, go to views, select new view,  instrument panel,  then drag the new instrument view to your 4th monitor.

 

5. If the curser returns, repeat steps 1 - 3.

 

This works sometimes with that horrible spinning thing.

 

Ron D.  :unsure:

Share this post


Link to post
Share on other sites

The flickering cursor may be due to the resolution you use.  What you describe is because an instruction cannot be completed.  The flickering is showing that it continues to try.

 

I have found that it only occurs when the set resolution is higher than 3840 x 1024.

 

If it only occurs when you call shift+1 you can resolve it by resizing the panel by amending the panel config.  Or, avoid using that particular panel.

Share this post


Link to post
Share on other sites

Hi Mike,

 

The mini panel is the four or two stand alone gauges that appear when you cycle through the views. ('w' key)  most work OK, but some need to be reduced.  As Jonabird points out, this only happens with the new ultra wide resolutions, as the gauge bitmap cannot stretch across such a wide screen.

 

Go into your main FSX folder and look for 'Gauges'  here you will find the mini panels, open in notepad.

scroll down and you will see something like this;

 

[minipanel100]

position =7

size_mm=600,100

window_size=0.9, 0.2

 

the window size is the one that needs to be reduced by 1/3, so change it and then save.

 

window_size= 0.3, 0.2

 

Ron D.

Share this post


Link to post
Share on other sites

Jonahbird,

 

All the panel are resized but for some reason when I bring the main panel up that is the only one where the cursor flickering happens.  I do understand its a resolution issue.  But its only a problem on some of the main panels on certain aircraft.

The flickering cursor may be due to the resolution you use.  What you describe is because an instruction cannot be completed.  The flickering is showing that it continues to try.

 

I have found that it only occurs when the set resolution is higher than 3840 x 1024.

 

If it only occurs when you call shift+1 you can resolve it by resizing the panel by amending the panel config.  Or, avoid using that particular panel.

Share this post


Link to post
Share on other sites

Mike

 

Ron has the answer.  His suggested change should fix it. He meant to say to 1/3, by the way - i.e. by 2/3

 

Frank

Share this post


Link to post
Share on other sites

So here is the newest thing I have found.  All of my aircraft when in Free Flight mode have no issues with the 2D windows.  The problem seems to happen now when doing some of the missions.  For example one of the missions that uses the Lear 45 gives me the flashing cursor but when in Free Flight it does not happen.  

 

Are the missions using a different panel.cfg file?  What is going on here?  It doesn't make sense.

 

Thanks for the help.

Share this post


Link to post
Share on other sites

Hi Mike,

 

some of the missions are locked and prevent you from changing aircraft etc.  Most missions are in 3D view, but yes, the Lear is in 2D.

 

So,  Try this when selecting a mission, make sure to check the box,   'Enable changes in selected mission' (no rewards given).

 

Then, when it starts,  press Alt, from menu, go to aircraft, >change aircraft,>  select the same one and see if it loads the modified panel.cfg file.

 

I can't try this myself as I'm away from home, but it's worth a shot.

 

Ron.

 

ps. thanks for the correction Frank, I was never good at fractions. :drinks:

Share this post


Link to post
Share on other sites