Jump to content

Archived

This topic is now archived and is closed to further replies.

Faisal altheyab

Simconnect with active sky 2012

Recommended Posts

hello 

i recently configured simconnect on my main and 2nd pc . so when i tried out aitraffic on my main pc it said that it was connected so every thing is fine up to now . then i went ahead and bought and installed active sky 2012 on my 2nd pc during installation it asked me for the fsx path and the appdata path i gave it the correct path but when i fired it up for the first time it said : fsx disconnected so i tried multiple times of restarting active sky and also i installed xgauge on my main pc but it still didnt work but the weird thing is that when i change textures on my 2nd pc and open fsx on my main pc the textured i just installed are there and im very sure . so this means that active sky has a connection to fsx but it says that its disconnected . 

 

my .xml 

 

<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <Disabled>False</Disabled>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.100.150</Address>
      <MaxClients>64</MaxClients>
      <Port>500</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
 
   <SimConnect.Comm>
   <Disabled>False</Disabled>
   <Protocol>Auto</Protocol>
   <Scope>local</Scope>
   </SimConnect.Comm>
</SimBase.Document>
 
 
 
my .ini : 
 
[simConnect]
level=verbose
console=0
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=0
;file_max_index=9
 

 

Share this post


Link to post
Share on other sites

The best solution I can offer is to go to the HiFi website and submit a trouble ticket.  They provided excellent assistance for my issues in the past.  On page 87 of their users guide, they have a very good SimConnect Troubleshooting guide and Networked Simulation Configuration.  Hopefully you have gone through those guides.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

The best solution I can offer is to go to the HiFi website and submit a trouble ticket.  They provided excellent assistance for my issues in the past.  On page 87 of their users guide, they have a very good SimConnect Troubleshooting guide and Networked Simulation Configuration.  Hopefully you have gone through those guides.

 

Best regards,

Jim

i have used their guide for installing simconnect . anyway i will post a ticket 

thanks

Share this post


Link to post
Share on other sites

Hi,

 

My Simconnect Setup, I use P3D so for you it would be FSX..

 

 

===================
Configuring Simconnect
===================

1.Folders to share:

    A. D:\P3D

    B. C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D

    C. C:\Users\Mike\My Documents\Prepar3D Files

-----------------------------------------------------------------------------------------
The folders shown above should be shared with read/write permissions
-----------------------------------------------------------------------------------------

2. Your P3D Computer is the server computer (Copy WideServer.dll & WideServer.ini into P3D's "MODULES" folder).

3. Your networked computer is the client.

4. Your firewall software must be configured to allow SimConnect communications on port 500,
   this includes windows firewall and applies to all computers, both SERVER and CLIENT(s).

5. There are two files which must be configured on the server, they are:

    A. SimConnect.xml  |  Location - C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D
    B. SimConnect.ini  |  Location - C:\Users\Mike\My Documents\Prepar3D Files

----------------------------------------------------------------------------------------------------------------------------------------------------------------------    
NOTE: For use with Prepar3D:  You MUST copy the fsx.cfg file into your Clinet's C:\Users\Mike\My Documents\Prepar3d Files Folder
----------------------------------------------------------------------------------------------------------------------------------------------------------------------

--------------------
SimConnect.xml
--------------------
<?xml version="1.0" encoding="Windows-1252" ?>
- <SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
- <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>IPv4</Protocol>
  <Scope>global</Scope>
  <Address>192.168.0.40</Address>
  <MaxClients>64</MaxClients>
  <Port>500</Port>
  <MaxRecvSize>4096</MaxRecvSize>
  <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
- <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>Auto</Protocol>
  <Scope>local</Scope>
  </SimConnect.Comm>
  </SimBase.Document>


--------------------
SimConnect.ini
--------------------
[simConnect]
level=verbose
console=0
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=0
;file_max_index=9


10. Copy the simconnect.msi to all client computers and run the file.

11. Copy the SimConnect.cfg file into the following folder on all client computers.

    A. C:\Users\Michael\My Documents

--------------------
SimConnect.cfg
--------------------
[simConnect]
Protocol=IPv4
Address=192.168.0.40
Port=500
MaxReceiveSize=4096
DisableNagle=0

 

 

I run Prepar3D on my Flightsim computer and Wide Client, ActiveSky 2012 and Flight Sim Commander on my Main computer via crossover cable. Hope you find this helpful.
 

Share this post


Link to post
Share on other sites

Hi,

 

My Simconnect Setup, I use P3D so for you it would be FSX..

 

 

===================

Configuring Simconnect

===================

 

1.Folders to share:

 

    A. D:\P3D

 

    B. C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D

 

    C. C:\Users\Mike\My Documents\Prepar3D Files

 

-----------------------------------------------------------------------------------------

The folders shown above should be shared with read/write permissions

-----------------------------------------------------------------------------------------

 

2. Your P3D Computer is the server computer (Copy WideServer.dll & WideServer.ini into P3D's "MODULES" folder).

 

3. Your networked computer is the client.

 

4. Your firewall software must be configured to allow SimConnect communications on port 500,

   this includes windows firewall and applies to all computers, both SERVER and CLIENT(s).

 

5. There are two files which must be configured on the server, they are:

 

    A. SimConnect.xml  |  Location - C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D

    B. SimConnect.ini  |  Location - C:\Users\Mike\My Documents\Prepar3D Files

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------    

NOTE: For use with Prepar3D:  You MUST copy the fsx.cfg file into your Clinet's C:\Users\Mike\My Documents\Prepar3d Files Folder

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

--------------------

SimConnect.xml

--------------------

<?xml version="1.0" encoding="Windows-1252" ?>

- <SimBase.Document Type="SimConnect" version="1,0">

  <Descr>SimConnect</Descr>

  <Filename>SimConnect.xml</Filename>

  <Disabled>False</Disabled>

- <SimConnect.Comm>

  <Disabled>False</Disabled>

  <Protocol>IPv4</Protocol>

  <Scope>global</Scope>

  <Address>192.168.0.40</Address>

  <MaxClients>64</MaxClients>

  <Port>500</Port>

  <MaxRecvSize>4096</MaxRecvSize>

  <DisableNagle>False</DisableNagle>

  </SimConnect.Comm>

- <SimConnect.Comm>

  <Disabled>False</Disabled>

  <Protocol>Auto</Protocol>

  <Scope>local</Scope>

  </SimConnect.Comm>

  </SimBase.Document>

 

 

--------------------

SimConnect.ini

--------------------

[simConnect]

level=verbose

console=0

;RedirectStdOutToConsole=1

;OutputDebugString=1

;file=c:\simconnect%03u.log

;file_next_index=0

;file_max_index=9

 

 

10. Copy the simconnect.msi to all client computers and run the file.

 

11. Copy the SimConnect.cfg file into the following folder on all client computers.

 

    A. C:\Users\Michael\My Documents

 

--------------------

SimConnect.cfg

--------------------

[simConnect]

Protocol=IPv4

Address=192.168.0.40

Port=500

MaxReceiveSize=4096

DisableNagle=0

 

 

I run Prepar3D on my Flightsim computer and Wide Client, ActiveSky 2012 and Flight Sim Commander on my Main computer via crossover cable. Hope you find this helpful.

 

hello 

thanks for the help i have already done what you have told me days ago but im currently facing problems with activesky that cant be resolved easily i have already sent them an email and they will hopefully help me to solve this problem 

thanks anyway 

 

Best Regards 

Faisal

Share this post


Link to post
Share on other sites

hello 

i have another question . i have read many guides and they all say before configuring simconnect for both the pc's you need to configure the ports . so what i have done is checked if port 4506 (which i will use) is occupied on my pc and it was not so i opened windows firewall advanced on both of my pc's and added a new rule for the inbound and outbound ports and i used TCP protocol . is this right or should i do something else 

thank you

Share this post


Link to post
Share on other sites

×
×
  • Create New...