Archived

This topic is now archived and is closed to further replies.

BrzI

Are these bugs ?

Recommended Posts

I set a zoom of 0.60 for all camera views in VC. They are then displayed in 0.50 zoom !?

 

If I disable DHM I expect the views to be rock solid. But they still move a little due to acceleration. I would like them to stay exactly where I set them when I set up the views and disabled DHM. Am I missing something ?

 

I use full-screen in FSX.

 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The acceleration can be an FSX effect not an Opus one. You should check your FSX settings as FSX can produce head acceleration effects.

 

When you set the zoom setting in the camera view did you Save All Cameras after editing each view? When you re-open the Cameras dialog your zoom setting should show in the dialog. Note the zoom is only set when there is a zoom change or a view mode change between Opus camera views. If you alter the zoom setting in FSX manually with the + and - keys then you must put it back or select a different Opus view mode. Any internal changes with FSX are not known about by the camera software, and zoom operations are very inefficient so the camera software will only reset the zoom when it thinks it has to.

 

Stephen

Share this post


Link to post
Share on other sites

So I should turn off FSX head accleration effects ? OK...that makes sense....did not see any mention of it in the how-to. But then again, I have been known to miss the obvious before :lol:

 

Yes, after every change I click on "Save all cameras"

 

So...if the FSX defined default VC zoom is 0.80 and I load up the aircraft that has a defined default OPUS view zoom of 0.60 why does it show in zoom 0.50 ?

Share this post


Link to post
Share on other sites

Mine doesn't, it sets the zoom level I have set in the camera definition. The default VC zoom in Opus was chosen to match the standard default in FSX VCs. I will double check next time I'm at the computer but I have never experienced problems and no one else has reported any problems regarding zoom.

 

Try configuring a VC view with a different zoom and switch between the two. As I said the zoom will only be reset if it thinks it has to.

 

Stephen

Share this post


Link to post
Share on other sites

standard default zoom in FSX VCs can be changed by users to suit their needs. It also depends on the default flight.

 

So...if I move around the Opus defined views I should be able to eventually come back to my defined Opus zoom level....!? I still don't get this... :(

Share this post


Link to post
Share on other sites

It is impossible to know what the zoom level is inside FSX. There is NO provision in SimConnect that allows software to determine what zoom level is in use or what zoom level changes have been made by the user. So Live Camera has to assume the standard FSX set up. Zoom adjustment is also very slow and laborious in FSX so its not something you want to be doing all the time (as described in our Live Camera guide). Hence, its best to stick with Live Camera and the default zooms and use Live Camera Control for ad hoc head (eye point) adjustments. That's the only way the adjustments and zooms can be kept under control. No one would be happy if Live Camera (or any other camera interface) reset the zoom level each time a camera view is selected, the process is just far to slow and laborious to bother with.

 

Live Camera will reset the zoom level when it determines either a change in zoom level setting going from one view to a similar one, or when you change view mode, going from VC to a custom external aircraft view for instance. FSX only allows control over VC, 2D, and Custom External View types.

 

Stephen

 

Camera and view mode control was one of those things never really completed or covered fully by SimConnect. It would have most likely been upgraded if development had continued on the FSX code. But alas it never was so we are all stuck with the very limited control and non existent monitoring or view related reporting through SimConnect.

 

Stephen

Share this post


Link to post
Share on other sites

So what is the standard FSX zoom in VC ?

 

Ok. Let me chew on all of this. Thanks for the quick reply Stephen.

Share this post


Link to post
Share on other sites

I am away from my PC at the moment but if you click on the Default button it will set it to the default zoom value.

 

Cheryl

Share this post


Link to post
Share on other sites

Sorry to but in, but this can be helpful, the standard zooms for all views can be found by the use of the Backspace key. :)

Share this post


Link to post
Share on other sites

Need some help here folks :

 

1. Where do I disable head movements in FSX ? Or do I specify it in individual aircraft.cfg files ?

 

2. When an aircraft loads up the VC zoom level is inherited from the default flight .FLT file. When I however hit the Backspace button it resets to a different value. This tells me it is reading the zoom factor from somewhere else. Where could that be ?

 

Thanks

Share this post


Link to post
Share on other sites

No idea. You had best google that, I think you will find plenty of information on the web. You can turn off the body acceleration effect in our cameras but I think you are talking about something else.

 

You can find the default zooms by going into our camera dialog and selecting default in the zoom dialog. The default for VC is 0.7. Selecting the backspace resets to FSX default 0.7. We have just tried switching between captain and first officer camera views (with different zoom rates) and it works as expected.

 

Do you have any other addons running which would alter the eyepoint such as ezdok or accufeel.

Share this post


Link to post
Share on other sites

I have a TrackIR installation that I seldom use. I find it nauseating - so I have disabled TrackIR in the Opus Live Camera setup screens.

 

Here is what I did.

 

I set 0.50 default VC zoom in the FSX\cameras.cfg

I set 0.50 default VC zoom in the default flight .FLT file

Set my views in Opus. They all show just fine in my required 0.50 zoom.

BUT...

The zoom factor in the Opus Live Camera setup says 0.60. Also, when I press the "Backspace" key the zoom defaults to 0.60.

This tells me that there should be another config file somewhere where the default VC zoom is specified. Anybody know where that might be ?

 

Whatever the case....I am fine with the current setup. As long as I don't hit "Backspace" (which I never do anyway)...my views will show the way I want them to.

 

Hope this helps somebody. With the the release of the T7 and a new i4770K under my desk I am now ready to finally say goodbye to 2D panels :-)

 

Thansk for the feedback gents.

Share this post


Link to post
Share on other sites

Not sure I understand why you are changing the camera.cfg files but you seem to be making progress. Its not really anything to do with Opus which just assumes the FSX standard zoom settings for each view type. If you change them then the software will be totally unawares of what you have done. You can find the default zoom settings by clicking on the Default button in the Cameras Zoom dialog.

You must appreciate the software cannot 'read' what the zoom actually is, there are no facilities in SimConnect which allows software to do this or have any knowledge of what zoom setting is being set by you or by the cfg files. So Opus will just show what level is set in the camera definition, whether this is in sync with FSX depends entirely on FSX using its default zoom settings for each view type.

What you do inside FSX by altering the cfg files and using the backspace key stays 'inside' FSX. Opus has NO knowledge of this so any comparisons are likely to be in error.

The zoom figure in Opus is simply a number with respect to what it thinks the default is. The only way to set the zoom in FSX is to actually first set it to x1, then step so many times coarse and again so many times fine. There is no feedback or measurement read inside FSX.

When you hit Backspace you are changing the zoom internally within FSX and NO software has any knowledge of this change.

Anyway you seem to have reached a steady state, just remember doing anything inside FSX, using the plus, minus, or backspace keys, stays internal to FSX. The software will just carry on assuming nothing has changed. It can do no more than that.

Stephen

Share this post


Link to post
Share on other sites

The reason I am tinkering with the settings is that I have wideview aspect turned off. I find the zoom effect excessive - especially in spot views. But that narrows down my view in the VC - which is why I need to zoom out much more.

 

Anyway, I am happy with my setup. The T7 is gorgeous.

 

Thanks for the elaborate replies...Have a great day.


btw.. if anybody knows where FSX reads the zoom factor from when you hit the "Backspace" key I would appreciate the info....

Share this post


Link to post
Share on other sites

Understood, don't think I can remember not using WideViewAspect.

 

Good luck.

 

Stephen :-)

 

If I find anything that may help I will let you know.

 

Stephen

Share this post


Link to post
Share on other sites