Archived

This topic is now archived and is closed to further replies.

Constantine

FSX /PMDG 737NGX and CH YOKE

Recommended Posts

Hi Guys

I received kind help in he past with my CH USB 3 lever yoke Elevators problem basically unable to get a normal response from the elevators which either pitch up or pitch down on slightest touch on yoke they never centre on the aircrafts controls synopic (sys)  have tried calibrating with CH Control Manager

and later with FSX calibrator,  have set FMC trim then Trim wheel on takeoff  have Elevator Trim on Y Axis and Trim Up Trim Down set on rocker switch on Yoke.

 

Strangely though I removed my Yoke from my Windows 7 Ultimate 64bit Desktop and put it onto my

Windows 7 Home Premium 64Bits Laptop and the Yoke worked perfectly with elevators realigning after being used to pitch up or down, obviously my Laptop is unsuitable for my FSX  just wondered if this

situation may give a clue as to why it's malfunctioning on my Desktop.

 

My specs

Windows 7 Ultimate 64Bits

CPU Intel i5 4670  16GB

Graphics: NVIDIA GeForce

GTX 760 2GB

Hard Disk SSD 120 GBs

 

FSX Gold Edition with Accelerator

PMDG 737NGX

 

               Any suggestions please, I'm grounded

                                          Many Thanks

                                             Richard

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Calibrate your yoke and trim switch with either FSX, FSUIPC, or CH Control Manager.  Make sure you only calibrate it in one place.  If you calibrate it in the CH Control Manager, then make sure you delete the axis controls in FSX and FSUIPC.  If you have it cxalibrated in more than one place, that causes problems like you are having.

 

Rob

Share this post


Link to post
Share on other sites

I use FSUIPC.  If you've never tried FSUIPC, I'd recommend it.  I did use CH Control Manager, however, after figuring FSUIPC out, It seems to work better and I can set the settings faster.

 

I've not had any problems with the PMDG 737NGX, nor any other a/c.

 

 

Rod

Share this post


Link to post
Share on other sites