Jump to content

Archived

This topic is now archived and is closed to further replies.

jetsmell

No Simconnect

Recommended Posts

I have FSX with Accelerator. I just purchased  OPUS and it's not in the drop down menu in FSX. I checked the FSX Config file and there's no simconnect in it. There is a Simconnect in the OPUS File. Do I need a Simconnect in FSX  , and if so how do I install it there ? Thanks

Share this post


Link to post
Share on other sites

To install Simconnect you first should install the Microsoft Flight Simulator SDK (Software Development Kit). and then you can run the SimConnect.msi file to install SimConnect.

because of my setup I have done this on another PC on my home network (client), whilst FSC runs in a desktop PC on the same network. I don't know if that is your case.

Also, there is quite a bit of information about SimConnect right here on the SimConnect AvSim forum

http://forum.avsim.net/forum/255-ms-fsx-simconnect-forum/

Share this post


Link to post
Share on other sites

But, there is no need to install simconnect on the sim computer. It installs all necessary files when installing FSX. If your running a client computer, yes you need the simconnect.xml etc.

Share this post


Link to post
Share on other sites

Time Out!

 

When you install FSX, Simconnect is automatically installed, not into FSX but into Windows, just as RW stated.

 

There is no designation in the FSX.cfg file for Simconnect.

 

DO NOT do anything with the SDKs if we are talking about a single FSX computer.

 

Re-Boot your computer and restart FSX and see if there is an Opus entry under the Add Ons tab when in a flight. That is the only place you will see Opus referenced in FSX.

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "MS FSX Simconnect Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

Hi,

 

I run P3D 2.0, all you have to do is change the file locations that are shown below to match your FSX setup. You'll also have to change the IP addresses to reflect your own. I run Wide Client, AS2012, FS-Commander and FTG-ACARS via the below setup, you may not need all the info shown below, but it should help you get setup.

 

 

===================
Configuring Simconnect
===================

1.Folders to share:

    A. D:\P3D

    B. C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D

    C. C:\Users\Mike\My Documents\Prepar3D Files

------------------------------------------------------------------------------------------
The folders shown above should be shared with read/write permissions
------------------------------------------------------------------------------------------

2. Your P3D Computer is the server computer (Copy WideServer.dll & WideServer.ini into P3D's "MODULES" folder).

3. Your networked computer is the client.

4. Your firewall software must be configured to allow SimConnect communications on port 500,
   this includes windows firewall and applies to all computers, both SERVER and CLIENT(s).

5. There are two files which must be configured on the server, they are:

    A. SimConnect.xml  |  Location - C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D
    B. SimConnect.ini  |  Location - C:\Users\Mike\My Documents\Prepar3D Files


--------------------
SimConnect.xml
--------------------
<?xml version="1.0" encoding="Windows-1252" ?>
- <SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
- <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>IPv4</Protocol>
  <Scope>global</Scope>
  <Address>192.168.0.40</Address>
  <MaxClients>64</MaxClients>
  <Port>500</Port>
  <MaxRecvSize>4096</MaxRecvSize>
  <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
- <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>Auto</Protocol>
  <Scope>local</Scope>
  </SimConnect.Comm>
  </SimBase.Document>


-------------------
SimConnect.ini
-------------------
[simConnect]
level=verbose
console=0
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=0
;file_max_index=9


10. Copy the simconnect.msi to all client computers and run the file.

11. Copy the SimConnect.cfg file into the following folder on all client computers.

    A. C:\Users\Michael\My Documents

--------------------
SimConnect.cfg
--------------------
[simConnect]
Protocol=IPv4
Address=192.168.0.40
Port=500
MaxReceiveSize=4096
DisableNagle=0
 

 

Hope this helps

Share this post


Link to post
Share on other sites

×
×
  • Create New...