Archived

This topic is now archived and is closed to further replies.

Cruachan

FSUIPC v4.923 (problems encountered)

Recommended Posts

Hi,

 

I have Prepar3D versions 1.4 and 2.0 installed. Both we're running fine - version 2.0 without FSUIPC and version 1.4 with a previously registered version of FSUIPC.

 

Now, I have installed FSUIPC version 4.923 and it appeared to install correctly in the modules folder of both installations of Prepar3D. The registration key was accepted by the installer.

 

However, the following issues have been noted:

 

1. The log files indicate that registration has only been applied to Prepar3D 1,4

2. When I attempt to access FSUIPC from the Addons menu option from within the running 1.4 the screen goes black and recovery becomes impossible. Alt + Tab is unhelpful. Prepar3D then has to be stopped via the Control Panel.

3. Prepar3D version 2.0 runs okay, but accessing FSUIPC confirms that it is unregistered. The log file also confirms this to be the case.

 

If I remove the FSUIPC files from the modules folder of Prepar3D version 1.4 then it runs correctly once again.

 

Anyone else encountered these issues?

 

Mike

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Rendi,

 

Windows7 Pro 64bit

 

Regards,

 

Mike

Share this post


Link to post

Problem Solved!

 

When Rendi asked me the question regarding which o/s I am using, a light went on and I proceeded to investigate and ticked all the Permissions for 'Sharing' and Security' for the Prepar3D and and Prepar3D folders/sub-folders. And, for good measure, I created an additional category under 'Sharing' called 'Everyone' - tip from the OpusFSX OpusFSX_Getting_Started_Single_PC.pdf - thanks!

 

I then deleted everything from the 'Modules' folders in both sims except for the uipchist.bin and SimConnectP3D(2).dll files as I thought they might have had something to do with the original LM installations.

 

The FPUIC installer was then run once more as Administrator and an 'FSUIPC4 Install.log' file was again created in the Prepar3D' Modules' folder (but not the Prepar3D v2 'Modules' folder). 2 other files were missing from the Prepar3D v2 Modules folder:  'FSUIPC4.log' and 'FSUIPC4.key'.

 

The 'FSUIPC4 Install.log' was examined carefully from top to bottom and all appeared well including the following text at the foot of the file:

 

"All installer tasks completed.
Registration for FSUIPC4 was successful! (result code 00)
"

 

So, feeling confident, I ran both Simulators again and no issues appeared this time.... except FSUIPC was still unregistered in Prepar3D v2! Bummer!

 

Then, I had a brainwave: I copied the 'FSUIPC4.key' file across from the Prepar3D 'Modules' folder and it worked!! All is now well, and both installations appear as Registered with all FSUIPC options available.

 

So, it would appear that the FSUIPC installer failed to copy across 3 files into the Prepar3d v2\Modules folder: FSUIPC4.log, FSUIPC4 Install.log and the all-important FSUIPC4.key file.

 

Apologies for the somewhat lengthy explanation, but I thought it might be helpful to those of you who still have Prepar3D 1.4 and FSX installations on your drives. Also, the Permissions side of things (turns out may not have been relevant to this issue, but is now being regarded by me as preparing the way for the future) was an education as, to date, I haven't encountered any related problems despite not having installed each simulator to C: root. I just accepted the default paths for installation.

 

Mike
 

Share this post


Link to post

So, it would appear that the FSUIPC installer failed to copy across 3 files into the Prepar3d v2\Modules folder: FSUIPC4.log, FSUIPC4 Install.log and the all-important FSUIPC4.key file.

 

But it does here and does too for most everyone else.

 

Could you please come to the FSUIPC support forum and show me there the Install log itself. I'd like to understand what is different on your specific system. it cannot be the access permissions on the P3Dv2 Modules folder as those are set when it creates that folder, and if they were wrong it could not install FSUIPC4 or the FSUIPC Documents folder and its contents.

 

Really, the FSUIPC support forum is THE place to report FSUIPC problems and to find solutions.

 

Thanks,

Pete

Share this post


Link to post