Sign in to follow this  
1981mvf

USB Headset starting fs2crew causes freezing in fsx? Its a weird one

Recommended Posts

Hi Guys.

 

I have a issue with FS2Crew and my USB headset. I will try and provide as much info as I can, I have spent close on 5 hours trying to find the issue and no joy so far.

 

Basically I have a clean install of windows 8.1 with FSX on a second hard disk. Windows defender etc will not scan the FSX hdd and UAC is off.

I have FSX running great apart from when I start fs2crew. Thats when I get the issues and only with a USB headset.

 

My rig has now got a AsRock Z87 extreme6 mobo with i5 4670k running at 4.3Ghz gt560 ti from asus running stock & 8 GB ram running also at stock 1600.

its stable and has all the latest drivers. Re downloaded & installed all again from the Asrock website.

 

I tried different USB ports and still get the same issues. I had a working Trust headset, but after windows 8.1 on some usb ports it gave a exclamation mark under device manager.

So I got a new Plantronics 628 which installs on any port without errors. Same problem in FSX though.

 

The FSX problem.

 

When I  get into fsx everything works fine, even if I use the USB headset for listening. As soon as I start Fs2Crew, thats when I get pauses or freezes from 2/3 seconds to even 30s to a minute or so.

The previous trust headset was freezing much more regularly, so this headest is marginally better but still impossible to use at the moment.

 

I have tried also to reinstall SP1c and also FS2Crew NGX and I have emergency but for now have just left it as NGX. I tested Emergency at the beginning and that also gave same results. So after I uninstalled I  never got to reinstalling emergency NGX yet. No point if im having issues with the standalone NGX version.

 

I also disabled all non used audio devices on the mobo and I disabled special utilities that were supposed to make the usb devices transfer data faster (Xfast usb)

 

I have never had problems with usb headset and Fs2Crew before on my old rig, In fact its always worked fantastically!!  so im guessing it is an issue to me and my hardware. But I really do not know what else to try? 

 

Many Thanks,

Regards,

Mark Fernandez

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Mark,

 

Weird one, which I haven't had reported before.

 

From experience, the only thing that will induce massive freezes and pauses is if you don't have your speech recognizer set to ENGLISH US.

 

In your case, since it worked on your old rig, that's probably not it.

 

It sounds hardware related as you say, as if there is an issue between your Headset and Windows 8.1

 

Can you borrow a mic from someone else to see if you get the same result with a different mic?

Share this post


Link to post
Share on other sites

Hi Bryan.

 

Thanks for the reply.

 

I have 2 usb headsets, both show the same problem the original shows the problem a bit more than the new one.

 

I have got UK and US english on my system. I use UK for the system and have set US for the speech, I am going to try now and test changing everything to US.

Thanks!

Share this post


Link to post
Share on other sites

 

 


Ok, tried setting everything to US english and I am still getting the issue unfortunately?

 

That wouldn't make a difference.

 

Does anyone else have any ideas?

 

Out of our 1000s of users, this is one I haven't heard of before.

 

Since it worked fine on your old rig, there's obviously something weird going on with your new rig... something weird with the USB ports.

 

Do you have a microphone that uses "jack" style... not USB?

Share this post


Link to post
Share on other sites

I have purchased a jack style headset will test later when it arrives. 

The usb issue is annoying as everything looks ok, it just seems to cause an issue in fsx. Guess I might need to wait for new intel chipset drivers to be released.

 

So hopefully the jack will work.

 

I will let you know how I get on later.

 

Cheers

Share this post


Link to post
Share on other sites

Update.

 

Tried a new jack headset. Windows can see it fine. Went to fsx then started fs2crew and it saw the headset but not the mic, was going to exit and start again but in fsx the pauses and freezes started again. It must be a chipset issue or a windows 8.1 problem. Maybe even directx?

 

If any one has any ideas I would be interested. 

If the chipset works in the desktop enviroment should it also work in games enviroment?

 

cheers

Share this post


Link to post
Share on other sites

I use Windows 8.1 with no issues as do a lot of Simmers.

 

Doubt it's DirectX related.

 

 

Total long shot, but try these settings:

 

Problem: The FO's volume is jumpy.

Solution:
 

  1. Go to Control Panel -> Hardware and Sound -> Sound -> Communications.  Select "Do Nothing" when Windows detects communications activity and click apply.

Communications.JPG

 

 


Problem: When I'm flying in FSX with FS2Crew running, if I change to the desktop and then change the task back to FSX, I loose my FS2Crew sounds.

Solution (Based on Windows 7 / 8 ):

  1. Right click on the speaker in the taskbar (lower right near the clock).
  2. Go up to "Playback Devices".
  3. Right click on the audio device that is in use for your FS2Crew and go to "Properties".
  4. Now click on the "Advanced" tab at the top.
  5. Now uncheck the two boxes as shown below.

 
sound_panel.png

Share this post


Link to post
Share on other sites

Thanks for the tip, I have tried the above and it still does not work.

I tried going to the intel website and running a online diagnostic, incase any drivers were missing, Or not the latest. Everything up to date and correct. 

 

The jack style headset will not work properly in fsx, it only detects the headset speaker. It still causes pauses. 

 

I have tried lowering the quality from 24 bit to 16 bit. That made no difference.

Went back to the plantronics usb.

 

I have a new uefi bios available. But it does not address chipset issues just processor list support. I may try updating anyway just incase.

 

Will let you know how it goes later.

Thanks again

Share this post


Link to post
Share on other sites

Still no joy,

 

I heard on another forum that if the mic gain was up to high it could tie up resources?

So I t tried muting the mic in fsx, but it was a mixed bag still. So not sure that was the issue.

 

Looks like im going to have to use the button version from now on. 

You have to love technology, it always seems to find a way to annoy you on some level.

 

Bryan thanks for the suggestions, if you or anyone else can think of anything in the future, let me know.

 

Cheers & Happy Christmas.

Share this post


Link to post
Share on other sites

Solved.

 

After giving it another go and trying all kinds of stuff I got it fixed in the middle of the night.

Problem was software.

 

FSUIPC  - installed the latest version and everything is fine!

 

Thought I would mention it here in case it helps others.

 

Cheers

Mark!

Share this post


Link to post
Share on other sites

Mark,

 

Glad you got it sorted.

 

However, can you be more specific on what you did to fix the issue in case someone has the issue.

 

Are you saying installing the latest version of FSUIPC fixed it for you?

 

Thanks,

Share this post


Link to post
Share on other sites

Hi Bryan.

 

Yes just installed the latest version of fsuipc. 4.927a. Thats when my problems were solved.

 

Before that I had tried disabling pretty much all sound related drivers. Even just using the headset.

I tried process viewers to see if that flagged up anything, I tried simconnect log. Found a missing entry in xml.dll removed it, still had issues.

Then I saw fsuipc might have issues with auto save. Checked, it was disabled. Then I thought I would see if I had the latest version. Thats when I installed the latest version and everything started working again.

 

Re enabled all sound devices, still working.

 

So it looks like FSUIPC v4.927a was the fix for me.

 

Hope this helps.

Cheers

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this