Archived

This topic is now archived and is closed to further replies.

captain420

FSDECODER has stopped working

Recommended Posts

Just installed a fresh copy of OpusFSX for P3D v2, and upon downloading new weather update it pops a window saying FSDECODER has stopped working. This is on a new installation of P3D v2. So I close the error window and the weather seems to have updated in my p3d window. I can tell because the clouds and skies drastically change. But not sure why I am receiving that error everytime I go to update the weather.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The FSDECODER error means you most likely do not have any GRIB upper wind and temperature data, just basic weather.

 

When you say you have installed a fresh copy of OpusFSX for P3D v2, what exactly do you mean. There must be ONLY one single installed copy of OpusFSX on your system installed in its own folder (e.g. c:\OpusFSX). You can open the FSXSERVER Configure dialog to select or change the simulator type before you restart and run the simulator (FSX or P3D).

 

You can also use the new command line argument to create two desktop icons for your FSXSERVER program. Add the command line argument FSX in one to select the FSX sim, and use the argument P3D in the other to select the Prepar3D sim type.

 

For example, the command lines for these icons would be something like,

 

c:\OpusFSX\FSXSERVER.EXE FSX

 

and,

 

c:\OpusFSX\FSXSERVER.EXE P3D

 

Both 'starting in' c:\OpusFSX.

 

If you have multiple copies of OpusFSX installed then that might explain the FSDECODER error.

 

Stephen

Share this post


Link to post
Share on other sites

What I meant to say was that I have FSX and P3D both installed and am sharing OpusFSX between the both. Sorry for the confusion. So you're saying this error is related due to lacking GRIB data? If so, how can I fix this? I never had this problem before with version 3.10, but trying this new one out, it's giving me fsdecoder errors. 

 

UPDATE: It seems to be working now. I had set an ICAO for the destination and max cruise altitude field. I removed them completely and now weather update is fine again. 

Share this post


Link to post
Share on other sites

Very glad to hear Aaron.

 

Check the Recommended Practices notes via the Question Mark icon on the Weather dialog, I have also posted some information in the Please Help topic after editing the rather inconsiderate previous topic title. But there's plenty of useful information in there.

 

Regards

Stephen

Share this post


Link to post
Share on other sites