Sign in to follow this  
Lude2Envy

New RC Problem

Recommended Posts

I've been getting some strange behavior from RC that just started recently. I run it over my network and haven't changed or installed anything. It started with some short flights less than 100nm. I would get handed off to approach, and then approach would never give me clearance to descend or vectors. It would just let me keep flying past my last checkpoint. It did this on 2 different flights.

 

Today, while flying a longer flight from KLAX to KATL, I would hit the assigned key to transfer to a different controller, and then nothing would happen. The pilot wouldn't call up the controller to check in. I hit control-shift-K to switch comms to the copilot and then he would call up ATC. Before starting this flight, I set RC to create a log, but had to close RC and restart it before I left the gate because after getting ATIS and trying to call up Clearance, nothing would happen. 

 

I've never had this problem with RC before so I'm not sure what's going on. Has this happened to anyone else? Thanks. 

 

EDIT: Now the copilot isn't calling up ATC when being handed off. 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Make sure the COM1 is correctly tuning.

 

Be sure your versions of FSUIPC 3 and 4 full and interim are current from:

http://forum.simflight.com/topic/66139-updated-modules/

in case there are timing problems.

 

It also would not hurt to update makerwys.exe from:

http://forum.simflight.com/topic/66139-updated-modules/

and then run RC scenery rebuild.

 

After loading a plan into RC open its controller tab and insure each airport has comms appropriately listed. Don't sweat Unicom.

 

You seem to have a progressive problem. Be sure you have enough empty space on your HD so system RAM paging can occur if necessary although FS and RC do not tolerate RAM paging very well due to delays while Win swaps files.

 

Run just RC and FS repeating a troublesome flight. If that is OK add in your background apps like weather.

 

BTW, insure UT2 is adjusted to render ai at maximum distance so RC can see it in time to assign non-conflicting runways.

 

To check for RAM usage I use this utility:

http://technet.microsoft.com/en-us/sysinternals/bb896653

Process Explorer will show various system loading information including RAM paging if you setup the graphs and columns. Its upper table (you can in preferences avoid opening the lower table) will show you your CPU loading as divided among running tasks. Also hovering the mouse over task names will show the full command liner useful when multiple instances of the same .exe or .dll are running each called up for a different task.

 

If you have a dual monitor system run it in a separate window otherwise alt -tab to it during a test flight. By default it polls every second. The graphs at the top show a short history for ram, disk i/o, etc., and where you see peaks hovering the mouse over it and sliding it around will name the task using the peak.

 

Progressive problems also might indicate a memory leak which will show in Process Explorer.

 

In RC options avoid Display Text and Prerecorded Chatter as these slow RC and just demand more resources.

 

In FSX fsuipc4 uses SimConnect and sometimes apps running on a network client can get stuck due to network traffic in the WideFS pipeline demands on SimConnect. Be sure you have the latest WideFS installed as well.

 

If you want to try an RC reinstall make a safe copy of keyboard.dat and rcv3.dat. in a folder outside of FS and RC. One of those contains your RC key and both have paths, history, key assignments, and other RC data. You can then place those in the main RC folders (one set for each RC FS version) to get back your settings.

 

Finally, I see you are using an SSD. Those have a limited number of write erase cycles for each sector and those get remapped in the drive electronics when it is estimated they get faulty. While a large number of cycles will work and there are plenty of spare sectors for remapping, eventually they can run out and then an SSD needs replacement. Estimate the age and use of the SSD. See  Crucial's support site for any information. Be sure you are not writing temporary files and in Win preferences not assigning your SSD as temp folder or swap drive to limit erase and writing of files on it.

Share this post


Link to post
Share on other sites

- The most current versions of FSUIPC and WIDEFS are installed. 

 

- Makerwys and scenery rebuild have been run after every scenery install. 

 

- All comms load in controller page.

 

- I have over 400GB of free space on both hard drives in my client computer.

 

- UT2 is set to max distance

 

- All of my 3rd party apps run on a separate computer with 8GB of RAM. 

 

- Memory in client computer was RMA'd a few months ago. MEMTEST shows no errors over a 24 hour run. Haven't had any problems with RC and the new memory until now. 

 

- Display Text and Pre-recorded chatter are both disabled. Never used either of them. 

 

- The SSDs are in my sim computer. The computer running RC and my other apps has a regular HDD. 

 

I appreciate all of your input. I run ASN, REX4 TD, Aivlasoft EFB, RC, DeltaVA ACARS, PFPX, and TOPCAT all from my client computer. All network connections are wired and run at 1GB/s. RC is the only one giving me problems. The ACARS runs over WideFS with no problems. ASN and EFB run through simconnect with no problems. I guess reinstalling RC is my only option at this point.

Share this post


Link to post
Share on other sites

I think it is network or system performance issues on your client mostly. Run process explorer on each to check cpu and ram loading.

 

As stated try running just FS and RC and then adding apps until it breaks.

 

With short hops there is a greater load on performance. Try turning off ai as well.

 

Until you can run a log which may or may not work with your type of problem it is hard to say where RC fails.

 

You are really placing a huge load on WideFS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this