Sign in to follow this  
Guest jtwillia

FSD Piaggio/ILS Problems

Recommended Posts

For some reason I can't get to the FSD website from my home computer, so I'll ask it here: for some reason the plane doesn't fly ILS approaches very well. Descends too quickly, and without manual intervention it would miss the runway by about 2 miles. ILS frequency, approach course, speed, gear, flaps were all set correctly.ricardo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ricardo,Lots of people have problems with the Avanti's ability to fly an ILS approach. (Including actual Avanti pilot who otherwise loves the plane.)Not sure yet what causes the problems--or if there is a solution.Mike

Share this post


Link to post
Share on other sites

I would ask in the FSD forum. I was a Beta tester for the Avanti and I never experienced any issues with flying an ILS either by hand or coupled with the AP. I don

Share this post


Link to post
Share on other sites

Flew another approach - same problem (doing everything "by the book") Flew the same approach with the Aeroworx King Air - no problem. I'm going to retire this plane until this gets fixed or a solution is offered. There just aren't enough hours in the day to constantly fiddle and fumble around with this kind of stuff. ricardo

Share this post


Link to post
Share on other sites

Again I would recommend that you ask on the FSD forum if you hope to find a solution. I have not heard of this problem myself so I cant offer any suggestions.Douglas

Share this post


Link to post
Share on other sites

Which Approach?Regards,JoeJOIN The AVSIM RTW RACE FLIGHT TEAM****************Grab My FREEWARE Voice recognition Profiles here:[a href=http://library.avsim.net/esearch.php?CatID=fs2004misc&DLID=58334]Cessna 172 Voice Profile[/a][a href=http://library.avsim.net/esearch.php?CatID=fs2004misc&DLID=60740]FSD Avanti Voice Profile[/a].You will need the main FREEWARE Flight Assistant program to use it, get it here:[a href=http://library.avsim.net/esearch.php?CatID=genutils&DLID=39661]Flight Assistant 2.2[/a]

Share this post


Link to post
Share on other sites

Airport doesn't matter. Happens at all. Same airport/approach flying the King Air, no problem.ricardo

Share this post


Link to post
Share on other sites

Flew the Avanti for all of the race this year, and so did several others.Everyone agrees the ILS tracking is abysmal.Aircraft turns too slowly, constantly loosing the localiser (and yes, yaw dampener and wing leveler off) and can't track the glideslope at all.Approach from below as recommended for FS, and on intercept it'll drop like a rock at 2000fpm and over, then sometimes recover and overcompensate by climbing at just over stallspeed until it gets way above the GS, then repeat itself.Manual tracking is quite posible though.This has been posted in the FSD forums several times in the past, I think people just got tired of repeating it over and over.

Share this post


Link to post
Share on other sites

That's not quite accurate. We have had some reports of this, while others say they cannot duplicate the problem. We can't duplicate it either. We submitted these reports to our beta testers, and likewise, they could not duplicate the problem either.The last time it came up I suggested that perhaps the flight computer and LNAV/VNAV modes have not been switched off, per the manual. Never heard anything back after that, so I assumed that is what the cause of the problem was.Rest assured if we can duplicate the problem, and it has something to do with the aircraft, we will release a correction for the problem. I think we have a pertty solid reputation for updating our aircraft. We are about to release an upgrade on the Cheyenne, which was originally released 4 years ago.http://www.fsd-international.com/team/TD_forum_sig.gif

Share this post


Link to post
Share on other sites

>That's not quite accurate. We have had some reports of this,>while others say they cannot duplicate the problem. We can't>duplicate it either. We submitted these reports to our beta>testers, and likewise, they could not duplicate the problem>either.>>The last time it came up I suggested that perhaps the flight>computer and LNAV/VNAV modes have not been switched off, per>the manual. Never heard anything back after that, so I>assumed that is what the cause of the problem was.>>Rest assured if we can duplicate the problem, and it has>something to do with the aircraft, we will release a>correction for the problem. I think we have a pertty solid>reputation for updating our aircraft. We are about to release>an upgrade on the Cheyenne, which was originally released 4>years ago.>>http://www.fsd-international.com/team/TD_forum_sig.gifI'm not using the stock fsgps/fmc that came with the plane, I'm using the reality xp garmin gps. Might this be the problem?Approach is armed (then coupled)Switch on the garmin flipped from gps to vloc.Is there something I'm overlooking?thanksricardo

Share this post


Link to post
Share on other sites

Tim,I think it was to me that you might have made that suggestion. I thought I got back to you but might not have. I still have the problem but have gotten discouraged about continuing to report it. My impression is that if your beta team says no problem then the user must be the problem. I give up after two attempts. I love this plane for it's speed and used it extensively in the RTW race but the appr mode on the auto pilot almost cost me a leg on my run to NWWW. I don't trust it at all. Your milage may vary.

Share this post


Link to post
Share on other sites

Tim,I tried to logon to the FSD forum with this problem ..registered, got a password,, it was rejected when i tried to logon on 2x,, got a new password...no deal couldn't logon.. so I lookd out here to post - and AMAZING...found this thread...I just purchased the Avanti after doing all the research I could, getting excited about it for 2 weeks...(I'm not a true novice, i don't think, but don't fly complicated aircraft yet)...and then today...started flying it... exact same problems as above... impossible to track an ILS,, tried several times, (occasionaly there are some problems with other planes also, but not like this) but also... more problems..tried different airports and approaches..First-just for your info----When I downloaded, I could't find a way to put it anywhere except on desktop !tried not to.....didn't seem to be any options... so I did,, then installed it..successful.. read the readme file...etc...did the load manager.'.SAVE'When i loaded the plane it was in 'engines running' mode, instead of dark - which was FINE with me..just what I wanted..something simple to begin with.. flew one of my saved flites...1-AP climb to altitude didn't work properly..in fact not at all...wouldn't track what i set up on the VSI ,, up, down,,,I would set, say, 2000 fpm, it would climb 1000 etc etc...I would change the VSI..no luck..so I hand flew the climb, once i reached altitude the AP WOULD hold the altitude..didn't use fmc, lnav, vnav etc..2- no GS...GS didn't even appear either on the HSI or PFD(attitude indicator)3- FD would not track even the localizer.. steep turns to who knows where.. FD was indicating far to the right... I was perfectly lined up...turned it off , on again.. up down. mostly steep right... etc..switched to my trusted Beech 1900D voila, no problem... back to the Avanti,, no good...Any help would be appreciated.Bill Youhass

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this