Sign in to follow this  
jfri

Volumetric fog a tremendous hit on performence

Recommended Posts

I tried some fog at a non demanding airport. My fps dropped to single digits and severe stuttering. Without the fog no problem with 37 fps and smoothness. Cloud shadows impact on fps is nothing compared to this. Is this also your experience ? As it is now the feature is useless. Any hope in 2.3 ?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Not a problem on my system.

 

Volumetric Fog = On

Enable Terrain to Receive Shadows=On

Cloud Shadow cast distance=30,000M

Shadow Map Count=High

FPS locked at 30 in Precision X and it rarely drops below that setting.

 

Only .cfg addition is AM=255 to utilize all 8 threads. Not using Nvidia Inspector. In Nvidia Control Panel have Vertical Sync set to Adaptive.  That is all the tweaks I am using in P3DV2.2. I have found that performance on my system is far better without all the tweaks in the.cfg and NI. I am a compulsive tweaker and have had to learn that all the suggested tweaks just don't work all that well for me.

 

Hope this helps a bit.

 

Lyn

Share this post


Link to post

 

Is this also your experience ?

Yes, it is. I like to use some fog to stop from seeing the autogen pop in beyond the LOD radius.  I have orb x global & vector and have found using the orb x weather themes are less of a hit. I believe theme #2 is overcast with a nice mist(fog).

 

performance on my system

 

Lyn

system specs? Excellent name by the way!

Share this post


Link to post

Yes, great name! Short for Lyndon.

 

PC specs in "My PC" Icon. It is certainly interesting how some of these tweaks are very system specific, isn't it?

 

Lyn

Share this post


Link to post

 

 


Not a problem on my system.



Volumetric Fog = On

Enable Terrain to Receive Shadows=On

Cloud Shadow cast distance=30,000M

Shadow Map Count=High

FPS locked at 30 in Precision X and it rarely drops below that setting.



Only .cfg addition is AM=255 to utilize all 8 threads.

 

Why should it be a problem on my system which seem more powerful than yours ?

I also found out that it's not 'volumetric fog' setting that causes the problem but simply fog itself. Disabling volumetric fog didn't change anything. BTW if I set up exact the same setting in FSX I have 37 fps and no stutter.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this