Sign in to follow this  
sehadi

Linda stopped working when assinging buttons to pmdg T7

Recommended Posts

Hi I tried finding the solution for the issue described below but did not find any solution/ topic on this issue

 

 

pls help me

 

I am using Linda since one month and assigned the keys to various aircraft's successfully  but when i am doing the assignment with PMDG 777 it gives me the error

 

 

" "[E] *** LUA Error: cannot open linda-cfg/aircrafts/PMDG 777/config-mcp.lua: No such file or directory"

 

After this no button  works and i have to restart the fsx  then it works fine when i start fsx again and all the keys i have assigned works as well

 

some times this error comes up after one assignment some time after 2 and some times after 3 

 

but all these assignments works fine when i start fsx again

 

 

I have no MCP combo so its already disbaled in settings

 

 

 

and below is the log when linda starts in console

 

HID Device changed
********* FSUIPC4, Version 4.929 by Pete Dowson *********
Reading options from "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"
Running inside FSX on Windows 7
Module base=5DCC0000
User Name="-------"
User Addr="----------------"
FSUIPC4 Key is provided
WIDEFS7 not user registered, or expired
System time = 13/07/2014 15:04:04
FLT path = "C:\Users\---\Documents\Flight Simulator X Files\"
Trying to connect to SimConnect Acc/SP2 Oct07 ...
FS path = "D:\Microsoft Games\Microsoft Flight Simulator X\"
Run: "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\linda.exe"
LogOptions=40000000 00000001
SIM1 Frictions access gained
[E] VRI port 1 "com3" failed to open
Wind smoothing fix is fully installed
G3D.DLL fix attempt installed ok
SimConnect_Open succeeded: waiting to check version okay
Trying to use SimConnect Acc/SP2 Oct07
Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)
Initialising SimConnect data requests now
FSUIPC Menu entry added
D:\Microsoft Games\Microsoft Flight Simulator X\FLIGHTS\OTHER\FLTSIM.FLT
D:\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR
 
 
--- NEW LOGGING SESSION -----------
 
 
D:\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\PMDG 777-200LR\B777-200LR.AIR
KEYDOWN: VK=65, Waiting=0, Repeat=N, Shifts=0
.. Key not programmed -- passed on to FS
KEYUP: VK=65, Waiting=0
System time = 13/07/2014 15:06:38, Simulator time = 14:49:15 (10:49Z)
Aircraft="PMDG 777-240LR Pakistan International Airlines - PIA"
Weather Mode now = Theme
Starting everything now ...
LUA.0: beginning "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\ipcReady.lua"
LUA.0: ended "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\ipcReady.lua"
LUA.1: beginning "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\linda.lua"
LUA.1:
LUA.1: [iNIT] Loading...
LUA.1:  Aircraft: PMDG 777-240LR Pakistan Internation
LUA.1:  Aircraft module detected: PMDG 777
LUA.0: beginning "D:\Microsoft Games\Microsoft Flight Simulator X\Modules\linda/system/init.lua"
LUA.0:  AivlaSoft library loaded...
LUA.0:  FSX standard library loaded...
LUA.0:  IVAO library loaded...
LUA.0:  RealityXP library loaded...
LUA.0:  Weather library loaded...
LUA.0:  A2A MAP library loaded...
FS Control Sent: Ctrl=69822, Param=64
LUA.0:  Loading a fallback joysticks config...
LUA.0:  Loading PMDG 777 joysticks config...
LUA.0:  Module: PMDG 777 Started...
LUA.0:  Ready to go, Captain!
LUA.0:
LUA.0:   LVars watching list cleared...
LUA.0:   Offsets watching list cleared!
Advanced Weather Interface Enabled
FS Control Sent: Ctrl=65615, Param=0
FS Control Sent: Ctrl=65615, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=65607, Param=0
FS Control Sent: Ctrl=69834, Param=64
FS Control Sent: Ctrl=65861, Param=536870912
FS Control Sent: Ctrl=65861, Param=536870912
FS Control Sent: Ctrl=65861, Param=536870912
FS Control Sent: Ctrl=65861, Param=536870912
FS Control Sent: Ctrl=65861, Param=536870912
FS Control Sent: Ctrl=69834, Param=64
FS Control Sent: Ctrl=69862, Param=64
FS Control Sent: Ctrl=69834, Param=64
FS Control Sent: Ctrl=69862, Param=64
[E] *** LUA Error: cannot open linda-cfg/aircrafts/PMDG 777/config-mcp.lua: No such file or directory
 
at this point i was assigning the key and when saved i got this message
 
 
thx
AA

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Open the fsuipc4.ini  file and find the section called [VRinsight] and delete it and the line or two after it starting with Com=. I know you say you disabled it but according to the FSUIPC log it said this "[E] VRI port 1 "com3" failed to open" that means its not actually properly disabled, doing the above in the opening sentence should solve that issue.

Share this post


Link to post
Share on other sites

Alternatively, simply go to the Combo MCP set up page in LINDA and uncheck the Enabled box.

Share this post


Link to post
Share on other sites

I presume he had already done that, as the OP did say it was disabled, both in bold and underlined ;). Linda isn't the most stable program and I have heard on more than one occasion that the tick is removed from the MCP enable box and yet it continues to act as if VRi support is enabled. Removing the section mentioned from the FSUIPC4.ini as advised is the only way to 100% guarantee it being disabled it seems. At least that was the case in 1.13 and earlier, I've still not upgraded to Linda 2 yet as I go by the philosophy, if it ain't broke, don't fix it. I don't use my FCU and I am actually considering selling it now that VRinsight no longer want my services. I've got a mint MCP1 as well with a brand new PCB in it that has less than a hour of use on it, that will probably be sold too.

Share this post


Link to post
Share on other sites

Thank you very much for your help. I really appreciate

As Andy mentioned that this program is not very stable and I think he is right coz I setup my throttle buttons to work as altitude up and down and Vs has been setup as well for this purpose and many times it happens if I press button to dec/ inc altitude it keeps on changing the numbers after release until I press other button

I am sure its not the hardware coz out of fsx they work absolutely fine.  

Share this post


Link to post
Share on other sites

For repeating functions like those you are using and things like trim, you are better using FSUIPC directly as even the Linda (1) developer (Artem) advises you to do this. Linda doesn't handle fast repeating functions so good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this