Sign in to follow this  
Don t moderate me this way

External drive not recognized at a different USB port

Recommended Posts

Folks,

 

this computer hardware stuff is not my strong point and probably there's just some sort of omission on my end:

 

Got myself an external Western Digital MyBook USB 3.0 HDD drive, plugged it into some USB port on my desktop PC and started installing it, configuring and backing up data (cloning the internal drive to be precise).

This has worked out well, no issues so far.

 

Just yesterday I noticed that the USB drive was plugged into a 2.0 USB port, instead of the faster 3.0 type. Thought I could just plug the drive into a different port - to my surprise this didn't work. The drive is only recognized when plugged into exactly the same port I started this backup/cloning stuff with. No other 2.0 port would work, and no 3.0 port either.

 

I tried updating the Intel chipset drivers, reinstalling the Western Digital drivers and utilities, checked the BIOS (no BIOS update, though), uninstalled the drive from the Windows device manager and tried to plug it back in - all to no avail.

 

System is a W7 64bit Professional, fully updated.

 

After checking the Western Digital manual, their knowledge base, Microsoft support database and a couple of sites via a Google search I am now at my wits' end.

 

Any hints are welcome - thanks!

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a hunch as it happens to me sometimes...

 

Right click on "My Computer" (or whatever it is in your language)

Click Manage

On the left hand side, click Disk Management

In the list of devices (main panel) see if there are any items that don't have a drive letter, i.e. no C: or D: or something like that next to it.

 

If there is one and you recognise its name, right click on it, click on "Change drive letter and paths", then click "Add" and choose a drive letter.

 

I sometimes get this when I change the USB port of my external drives.

 

Hope this helps,

 

Ian

Share this post


Link to post
Share on other sites

Hmm, found out tonight, for the Western Digital SmartWare utility there's an updated version available. Installation required a restart of my PC anyway, so I checked the BIOS again, and changed USB legacy support from 'active' to 'auto'.

 

Now the external drive is recognized on seven different ports; two them are 3.0. Letter 'I' (next free letter without the drive connected) is assigned by the OS every single time now.

 

Thanks for your suggestion, Ian; I'll keep that in case I will experience issues again.

Share this post


Link to post
Share on other sites

I had the same exact problem.   I had initially connected "My Book" hard drive to a USB 2.0 instead of 3.0.  So when I switched it to a 3.0, it would not be recognized.

The fix that worked for me is as follows:

Keep the external drive connected on the 2.0, then go to "Device Manager" and find the external drive under the "Disk Drives".  Click on "Drivers" and choose "Uninstall".  It will ask if you are sure and say "yes".

 

Do a shutdown of the computer.  Once it's shut down, unplug the external drive from the USB 2.0 drive.

 

Now start up the computer and after it finishes booting up completely, plug the external drive into the USB 3.0 drive.  Windows should now recognize it cleanly and you are good to go!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this