Sign in to follow this  
Ales-X

Not smooth and GPU usage...

Recommended Posts

Hi friends,

a few days ago I bought Scenery Fixer, great tool. But I have some problems with performance. I have compiled a new machine:

Intel Core i7-4790K (4.4Ghz)

EVGA GTX 780

16 gigabytes of RAM

GIGABYTE Z97X-Gaming 3

When I started FSX in DX9, at Heathrow, where I always had trouble with the performance, I had 45 + fps in the cockpit (A320 BlackBox sim), 100-200 + in flight level(outside camera). Well, I liked that. A lot of years I did not go to Heathrow landing performance reasons.

DX10 seemed like a good next step. But it's weird.

30fps in DX9 is not the same as 30 fps in DX10. In DX10 mode is choppy 30fps when turning the camera (panning). It's as if you're in the movie skipped frames. It does not look nice.

Everything I set according pdf file (DX10_HowTo.pdf), by the way, an excellent guide. I have tried many settings, but without much success. I even re-install the entire FSX.

This problem is mainly in large cities, but fps is still above 30 (at least it says FSX), so not only it looks.

When I look at my workload graphics card, ranging somewhere around 32%. max.

In doing so, antialiasing is in full swing, visually it looks beautiful.

 

What could be the problem?

 

(sorry for my google english)  :rolleyes:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It looks like a big performance problem caused by shadows in the cockpit. It seems that FSX is smooth at night, morning and evening, when the sun does not shadows. But I like shadows on the plane. They are shadows in the cockpit somehow disable? (only shadows in the cockpit)

Share this post


Link to post
Share on other sites

It seems that the problem also causes 1/2 vsync. If I give full vsync, sim. is much smoother...

It seems that FSX will already be tuned  B)

Share this post


Link to post
Share on other sites

 

I try to avoid tuning questions as its not a specific DX10SF issue and its not an area that I claim any great skill with.

 

When you enable aircraft casts shadow on itself then during the day the VC is drawn twice (once for shadow calculations) and the exterior once for reflections . If the aircraft is "expensive" to draw then that can be a big load on the CPU (on the GPU it is only the final pass with AA that counts). If you have 1/2 vsync and the FPS is varying around 30 then you may see stuttering I guess.

Share this post


Link to post
Share on other sites

OK, I understand and thank you. It's tuned and it's great! 

But there is another problem. Line Disablepreload = 1 causes problems with the autopilot and control aircraft(BlackBox A320). Without this line does not work properly vsync. What to do?  :huh:

Share this post


Link to post
Share on other sites

Sorry no suggestions again - I don't use vsync at all, you could ask black box

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this