Sign in to follow this  
Ken Pryor

Radio problem

Recommended Posts

Hi All,

 

I'm getting back into FS after a break and am having a small problem. In the NG-700, the radio appears to be turned on and I can change frequencies, but when I actually try to use the radio to talk with FS ATC or get the ATIS, I get nothing at all. If I push the button to select the ATIS, the frequency does change on the stack, but nothing else happens. Likewise, if I try to contact ATC, I push the button but nothing comes from my radio to contact ATC and I get no response either. Wondering if there's some little thing that needs fixed that I'm not thinking of. I'm still trying to learn all the things I forgot from before. Any advice would be appreciated.

 

Ken Pryor

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think with the 737, you change frequencies on the "inactive" reciever, then press the flip switch to select that as the active reciever. Are you doing that?

Share this post


Link to post
Share on other sites

Yep, doing things like normal. It's just weird. I'm going to try it again this afternoon and see what happens. I can change frequencies, etc and the radio appears to be on, it just doesn't do anything.

Share this post


Link to post
Share on other sites

Thanks anyway, I appreciate the replies. I'll keep working on it and if nothing else, will try a reinstall.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this