Sign in to follow this  
Wink207

Help needed with pop up window problem

Recommended Posts

Hi all:

I just completed installing FS9 on my new rig (4790k 4.4/NVidia 970/Win7 Pro). All went well. However I find in flying that the pop up windows like FMS on all my aircraft do not work. Touching the click spot or shift+ gets no response at all. Seems to be that way for all aircraft. I have UAC turned off and run FS9 as administrator. I have FS9 installed in it's own folder outside Program Files. I'd appreciate any ideas on this problem.

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try this:

 

locate your FS9.exe file, right click and select properties/compatibility. Tick the boxes for disable visual themes and disable desktop composition. Then start FS9.

 

If still no luck you could try running the sim in windowed mode, instead of full screen.

Share this post


Link to post
Share on other sites

Thanks Pschlute for answering. I forgot to mention that I had observed that the popups work fine in windowed mode. I tried your suggestion on the FS9.exe and saw no change. The popups just don't pop up. I have never run in windowed mode in the 20 years or so I've been simming and prefer not to now. I tried googling this problem with no luck. It seems that I am the only guy inflicted with this so there must be something in my system causing this.

Share this post


Link to post
Share on other sites

I bet you are not the only one so affected !  It is a video issue, and some addons in combination with some video cards present this problem to a greater or lesser degree. I certainly had the same problem when I first moved to win7.

 

I run my sim in windowed mode now and have just got used to it. Maybe someone can offer you a solution, but to be honest I doubt it.

Share this post


Link to post
Share on other sites

Interesting. May be related to the same issue that causes certain windows and menus to open up behind the running FS application. In those cases the screen goes completely black in FS and you can't see what you opened. It is open, it's just running behind FS. Running in windowed mode let's you see it.

 

From what you have said, you simply have no response at all after trying to open the window. I'm thinking it may possibly be open but behind the FS9 application depending on the type of gauge it is. Regardless, if this is what is happening there is no known fix anyone has found that I have found!

 

If you find a solution, please post it here as it may be a problem any of us could encounter in the future. I certainly don't intend to leave FS9 with my next PC upgrade.

Share this post


Link to post
Share on other sites

Yes skywatcher this is probably what is happening. Running in the full screen mode if I touch a click spot nothing happens seemingly. But if I hit the Alt key to see the task bar, the windows appear in front of the VC. But if you then move the cursor the task bar disappears and so do the 2d windows. Could well be that your hypothesis is correct and the 2d windows are running somehow behind the full screen VC. Now to your knowledge does everyone running FS9 on Win7 Pro see this issue? I'm also wondering if I try an earlier video driver? My system came with the 350.12 installed. I'm thinking about dropping back to a 347 level. What do you think?

Thanks

Share this post


Link to post
Share on other sites

This problem existed when win7 first came out. Unfortunately FS9 was created when things like "active desk top" were but a twinkle in Microsoft's eye.  I doubt earlier drivers will help, and I have experienced this with both Nvidia and AMD cards.

 

You could experiment by changing your desktop theme to a simpler one (although this will just have the same effect as the changes I suggested in my first reply), or running FS9 in winXP compatibility mode. But if there was a simple fix I am sure it would have been would have been posted in one of the FS9 forums by now.

Share this post


Link to post
Share on other sites

One interesting thing though is that the kneepad works ok. Hmmm. I wonder if I can assign 2d windows to an F key, like F10 for the kneepad I think.

Share this post


Link to post
Share on other sites

silverheels2,

 

I installed FS9 not that long ago after being away since the XP days. Now running Win 7 I haven't come across anything in my installation not already reported by users running under Win 7. The running behind FS window issue and scenery install issues are the only problems I can think of that I have from the top of my head.

The window thing isn't really a major concern for me so I haven't bothered to try and resolve it apart from some Googling for an easy/quick fix. Obviously in your case if it's hiding an aircraft gauge it's a problem. Can you list what particular gauges you are having issues with? If people are using the same ones with or without the same issue you are encountering would greatly help troubleshoot. Which makers FMS for example?

 

The black cursor in FS9 also appears to be a similar issue. If all these things are tied in, there is a reason they are giving a slightly different end affect. If something is showing inconsistency in it's behaviour in this way, it's a clue sometimes you are not dealing with a rock solid problem and there may even be a possible fix. Like I said, never tinkered with it as it's not causing any major issue for me. As mentioned by pschlute, any fix likely will require more than just messing with standard Windows settings. 

 

You could try drivers but I also doubt it will do anything. The issue appears tied to the operating system and not the graphics side.

 

Share this post


Link to post
Share on other sites

Actually, now I think about it, I have come across a couple of other issues but not related to the topic I don't think. Haven't done any research on those either but Win 7 has thrown up a few mostly minor problems. Anyone tried Win 10 with FS9 to see if Win 7 issues are unchanged?

Share this post


Link to post
Share on other sites

Well, I wasn't planning to run FSX on this machine but I installed it just to take a look at this issue. Turns out that whatever is doing this does not affect FSX as the 2d windows pop right up, at least on the default aircraft. So it looks like an FS9 issue. Guess I'll try XP compatibility mode next. This is not a real huge deal for me except for one aircraft, the Citation X. The one I like in FS9 is the ESDG Citation and the little auxiliary panel for altitude and heading will not display. The autopilot for that aircraft will not obey my yoke heading bug change button assignment.

 

Interesting NVidia note though is that I've spent so much time messing around with various driver settings with NI. I finally just went to the NVidia control panel and selected "Quality" and FS9 looks great and the frames are through the roof. I guess the hardware has caught up with FS9 and tweaking is passé.

Share this post


Link to post
Share on other sites

silverwheels,

 

Just check it is not a known issue with the Citation in FS9 and Win 7.

Share this post


Link to post
Share on other sites

Yes good thought Skywatcher. I did check it with the FeelThere Citation X and the Carenado Kingair, which I use in FS9, and the issue appears there as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this