Sign in to follow this  
avgaskoolaid

Autopilot/Trim (?) issue

Recommended Posts

I've had the B1900 since it was released, and for the most part I have been pleased with it. However, I noticed something incredibly annoying after installing it in FSX:SE. After takeoff, the autopilot works just fine until I climb above about 10,000 feet (just an approximation). From there, whenever I try to climb, the aircraft pitches upward violently and inevitably stalls. Also, it seems that for some reason if the trim is all the way down the aircraft is incredibly unstable in the pitch axis, and wants to rocket upwards if I take my hands off the controls. The CG from the FSX weight and balance page looks just fine. I am following the same procedures that I always did when using it in FSX-MS. What's going on?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm not sure I understand your situation... trim is supposed to be applied to take the force off the controls..

 

Are you saying that you cannot fly the plane by hand above 10,000 feet?

Share this post


Link to post
Share on other sites

I'm not sure I understand your situation... trim is supposed to be applied to take the force off the controls..

 

Are you saying that you cannot fly the plane by hand above 10,000 feet?

I guess I should have explained it better. I CAN fly the plane by hand above roughly 10,000 feet or so, however I need full nose-down trim in order to maintain control properly. Also, when I switch on the autopilot to, say, climb at 1500 fpm to FL180, the aircraft pitches all the way up, blowing way past 1500FPM, until it stalls. The climb setting on the autopilot works just fine when, say, I have just taken off from the airport and set it to go up to 7,000 feet. Tomorrow I will try to recreate the problem and take careful note of what happens. I may be able to explain it in much more detail then. 

Share this post


Link to post
Share on other sites

Ok, I just took the aircraft up again, and here's what happened. I filed a flight using the FSX planner from EGPH-EGHI with a cruising altitude of 17,000 ft. As the flight is quite long, I loaded up full fuel then as many passengers/bags as I could without going overweight via the FSX fuel/payload window. I was also using ActiveSkyNext. After positioning my aircraft at the gate, I hit the 'cold and dark' button via the configuration panel, then hit the 'ready to taxi' one. I got my clearance form FSX ATC, ensured that everything was set, then taxied to the runway and took off. I flew the aircraft manually up to 1000' or so, then hit the autopilot, selecting the Yaw Damper, Nav Hold and Alt Sel (setting a 2000fmp climb rate), with my nav source set to the GPS (I did not turn on the FMS during the flight). As soon as I turned the autopilot on, the aircraft started tracking towards my first GPS waypoint. The aircraft then pitched up violently, as the autopilot was still slowly lowering the trim to maintain 2000fpm. The autopilot set the trim down all the way, but even that was not enough and I stalled. What's going on? Again, the CG location was well within limits according to the load page. 

Share this post


Link to post
Share on other sites

Just as a test flight, dump the passengers and cargo and see if the behavior changes.. also try 1200 ft/min..

 

This is not a jet..

Share this post


Link to post
Share on other sites

Just as a test flight, dump the passengers and cargo and see if the behavior changes.. also try 1200 ft/min..

 

This is not a jet..

Just tried the flight again using full fuel and only the pilots, no other passengers or cargo. 1)I did not have any issues where the aircraft seemed insanely tail-heavy like before, and 2)I was able to maintain a 2000fpm climb quite easily until I got higher up. Perhaps the aircraft has a bug, where all the pax/cargo are assigned to one area in the rear of the aircraft, and this does not show up on the CG diagram for some reason? 

Share this post


Link to post
Share on other sites

In the real world, planes have crashed because of loading inaccuracies, or shifting load in flight..

 

Luckily, in FS, you get a "do-over"  B)

Share this post


Link to post
Share on other sites

In the real world, planes have crashed because of loading inaccuracies, or shifting load in flight..

 

Luckily, in FS, you get a "do-over"  B)

Very true. I'm assuming that you have the aircraft? If so, are you able to load passengers and cargo? I'm wondering if it's a bug with the aircraft or if it got corrupted when I installed it. 

Share this post


Link to post
Share on other sites

Very true. I'm assuming that you have the aircraft? If so, are you able to load passengers and cargo? I'm wondering if it's a bug with the aircraft or if it got corrupted when I installed it. 

 

I never fly at full load, but I'll give it a try.. and let you know.

Share this post


Link to post
Share on other sites

Just loaded up with full fuel, and 180 lbs passengers down to row 6 when I reached full load.

 

Flew just fine up to 18000 feet...

 

Maybe watch the bags in the back!

Share this post


Link to post
Share on other sites

I've had the same problem before -- Boxed, not Steam.  Couple of reasons.

 

Both causes can also been reported to sometimes result in altitude "porpoising," where the aircraft won't settle.

 

From what you've described, it sounds like this is cause by an issue between the FMC and the GPS directing the autopilot.  If the VNAV mode is selected on the FMC, it will take over the altitude target selector and will command a climb or descent to the altitude it intends to be at for the next waypoint.

(One way to deal with this is manually change the altitude of each waypoint in the FMS to the present/desired altitude.)

 

You'll notice this either when you select VNAV on the FMS, or when selecting NAV on the autopilot (if the FMS is commanding).

 

It would appear Carenado has treated this issue as a bug which was reportedly addressed in Service Pack 20140129.  Some persons report that installing that SP fixes this issue.

The SP is available from the Carenado website -- if you purchased the aircraft from them you can log into an account.  If purchased elsewhere, they want some proof of purchase (I don't know what form).

 

I have not yet installed the patch, because I've only just found out about it and haven't troubled to dig up my purchase information.  (And, I simply never use the VNAV mode.)

 

~ ~ ~ ~ ~

 

Second possible case, as Bert said, is the weight distribution.  This really is a very sensitive bird in that respect.  I've read that 1900 pilots litterally say this bird is "&@($*-heavy."  In the real-world, docs show the center-of-gravity allowed range is about 28 inches from fore to aft.  So the loaded cog must be somewhere within a range less than two and one half feet.

This aircraft comes with a tail stand bar to keep it from tipping backwards when bags are loaded before passengers.

 

Simple response:

 

Take extra care to balance this aircraft, especially fore-to-aft.  And, as Bert wrote, keep the weight away from the aft area.

 

Detailed comments:

 

When comparing the loading stations in the aircraft.cfg to real-world docs (with actual datum info), or even just against the approximate locations of the seats in the model -- it turns out that Carenado "compressed" all the station locations towards the center point.

Using the crew seats as an example, the loaded weight of the pilot and copilot are placed (in FSX) actual many feet behind the location where their seats are shown in the model (or in real-world docs).  Similarly the aft baggage compartments (there are two in real-world) are placed well into the passenger section of the cabin.

All the passenger seats similarly have a seat "pitch" much less than the standard 30 inches.

 

I do not know why Carenado did this, but it certainly could be because of this aircraft's high sensitivity to cog deviation.

 

Apparently, there was one 1900 crash which led the FAA to revamp some rules about standard/assumed passenger weights.  And, this also seems to be one of the aircraft for which some carriers literally weigh each passenger and each bag.

 

I've done some experimentation with the config file station locations, seeing what it's like when the load stations are in the correct locations.  It's even more touchy then (but with well-controlled loading, managable).

 

So, I've run into the same issue.  Take off tends to be fine, initial climb okay.  But, when the throttles are pulled back for cruise, the attitude goes quickly bad into a stall.  It's got to be flying fast if loaded too far to the rear.

 

Hope this info helps.

Share this post


Link to post
Share on other sites

I've been having this issue myself (FSX-SE).  Plane only had fuel, front cargo, 2 pilots.  Based on what you said here, I turned NAV off and engaged ALT by itself.  The porpoising stopped.  When I re-engaged NAV, it did not start porpoising again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this