theskyisthelimit

Windows 10 + P9x79 + CH Flight Yoke USB- No auto power off on lcds?

Recommended Posts

I run P3D v2.5, that aside.. i've begun the windows 10 adventure.. and so far, one thing is different with v10 than v8 at least for me.. it seems that usb peripherals are keeping the lcds from going to sleep.. in particular i've narrowed it down to the CH  Products yoke..

 

Unplug and all is fine.. did the test several times.. its going through a usb hub then into one of the motherboard plugs in the rear...

 

I do have the ch manager installed as well.. that didnt seem to help.. has anyone else ran into this?

 

Thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Same behavior here - P9X79 Pro motherboard, BIOS 4608. nVidia 970 card.

 

With a CH Yoke and/or Rudder Pedal set plugged in, computer will not drop the monitor into powersave mode.

 

Unplug all CH items, and boom - the system will drop the monitor into powersave mode in precicely the expected amount of time.

 

When using "powercfg -requests", there are no apparent calls to the power systems holding it up. It should be dropping, but it's not.

 

You, sir, are not losing your mind or going crazy.

 

-Greg

Share this post


Link to post

Same behavior here - P9X79 Pro motherboard, BIOS 4608. nVidia 970 card.

 

With a CH Yoke and/or Rudder Pedal set plugged in, computer will not drop the monitor into powersave mode.

 

Unplug all CH items, and boom - the system will drop the monitor into powersave mode in precicely the expected amount of time.

 

When using "powercfg -requests", there are no apparent calls to the power systems holding it up. It should be dropping, but it's not.

 

You, sir, are not losing your mind or going crazy.

 

-Greg

 

Thanks for the validation.. glad to know i'm not losing my mind on this one :)

 

I noticed if i log in via remote desktop then close the session, the screens shut off.. i cant replicate this locally by just locking the session.

 

I tried disabling the "ch flight sim yoke usb" in device manager but was greeted by a blue screen of death 0x000000d1 driver irq screen.

 

I found drivers for the lcd's, i may try that route next, though i highly doubt they will be the fix, since the culprit is the yoke.

Share this post


Link to post

Thanks for the validation.. glad to know i'm not losing my mind on this one :)

 

I noticed if i log in via remote desktop then close the session, the screens shut off.. i cant replicate this locally by just locking the session.

 

I tried disabling the "ch flight sim yoke usb" in device manager but was greeted by a blue screen of death 0x000000d1 driver irq screen.

 

I found drivers for the lcd's, i may try that route next, though i highly doubt they will be the fix, since the culprit is the yoke.

 

I might have found a solution to this issue (i may need to reboot, run a few more tests to be certain), though i'm not sure i like the solution (if it increases power consumption that is)..

 

If you goto power options in control panel.. then change settings.. there is a section usb settings.. usb selective suspend setting.. by default this is enabled.. if i turn this to disabled then we are back in business and the lcds shut off.

 

There isnt an option to turn off "allow this device to wake" the computer for the yoke.. so setting it there wont work..

Share this post


Link to post

I might have found a solution to this issue (i may need to reboot, run a few more tests to be certain), though i'm not sure i like the solution (if it increases power consumption that is)..

 

If you goto power options in control panel.. then change settings.. there is a section usb settings.. usb selective suspend setting.. by default this is enabled.. if i turn this to disabled then we are back in business and the lcds shut off.

 

There isnt an option to turn off "allow this device to wake" the computer for the yoke.. so setting it there wont work..

Update:  so far this hasnt fixed the issue.. it seemed to initially, however that was hopeful thinking.

Share this post


Link to post

Further reading has shown that it's not just P9X79 users experiencing this...

 

You wouldn't happen to have more than one monitor, would you?

Share this post


Link to post

Further reading has shown that it's not just P9X79 users experiencing this...

 

You wouldn't happen to have more than one monitor, would you?

Yep. 3 in fact. Hadn't thought of this ..latest nvidia drivers too

Share this post


Link to post

I've since bounced back temporarily to Win7 for reasons other than flight simming, so I can't properly test... but one of the common threads is in fact multiple monitors. I've got (2) monitors.

 

if you were willing to test, perhaps you could unplug two of the monitors, reboot, and see if your system falls asleep. (??) Still curious as to whether or not this is an issue with Windows itself, or perhaps the Win10 nVidia drivers....

 

-Greg

Share this post


Link to post

Had the same problem, using Saitek Pro Flight. The problem is corrected in the latest build of windows 10. (i'm set to receive preview build, fast track). So I'm guessing everyone will get it eventually. (or you can sign up for preview builds and get it first)

 

Nick

Share this post


Link to post

Great to hear, Nick - I'm going to wait for the official release of the new build and give it a shot then. Perhaps some of my other issues will also be squared away at that point. I wonder how long they'll keep this new build on the insider program... we'll see.

 

Thanks,

-Greg

Share this post


Link to post

I didnt sign up for fast track, so far the problem still persists for me, even with "normal" track updates.. I hate to go fast ring.. at least on mobile 10 its been a bit of a nightmare..

Share this post


Link to post

I did a quick test with today's update to the production release of the November update (build 10586). I can confirm that my dual displays both went to sleep after the appropriate amount of time with both my CH Yoke and Pedals plugged in!

 

The bug is squashed for me. 

 

Good stuff.

-Greg

Share this post


Link to post

I did a quick test with today's update to the production release of the November update (build 10586). I can confirm that my dual displays both went to sleep after the appropriate amount of time with both my CH Yoke and Pedals plugged in!

 

The bug is squashed for me. 

 

Good stuff.

-Greg

Yep mine too :)

 

Great that they finally fixed it.

Share this post


Link to post

Really great to hear this issue has finally been fixed by MS!

 

For anyone facing this problem I found a workaround while waiting for the official fix/next version of Windows. You can read about the basics here and then how to automate it here.

Share this post


Link to post

I know this thread was created by me awhile back.. but it seems in 1709 win 10 this issue has re-appeared.. in fact for awhile things were fine.. unsure of how to fix aside from disabling the driver in device manager.. a bit frustrating.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now