Sign in to follow this  
Peter Webber

Constant re-activation required with PMDG aircraft.

Recommended Posts

Good day.

I recently made the big mistake of upgrading to Windows 10 and had to revert back to Windows 8.1 due to many issues encountered. Everything is restored now in Windows 8.1, but I have noticed everytime I open a PMDG product in either P3D or FSX-SE, the product requires to be reactivated every time. I activate the product, but the moment I close the platform and reopen it, I need to reactivate PMDG again. This applies to 737NGX and 777. The system is not "remembering" my activation. Any ideas? I have submitted a ticket but was wondering whether any one has encountered this problem? I have tried re-install with administrator rights. Also, when the aircraft loads up, the controls initially respond to keyboard commands from my pc, then the controls will freeze, i.e. flaps stop responding mid travel, yoke stops responding, etc.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just an update...this problem only applies to the 737NGX and variants....the 777 products are ok...have reinstalled several times with no luck. Have to activate product every time and it freezes on start-up....controls unresponsive. The 777 products work ok and don't require reactivation each time. The problem is limited to the 737NGX latest version.

Share this post


Link to post
Share on other sites

 

 


I activate the product, but the moment I close the platform and reopen it, I need to reactivate PMDG again.

 

When you re-imaged back to 8.1, your SimConnect.msis got wiped. Reinstall them per the instructions in the readme files and you should be fine - both FSX:SE and P3D.

Share this post


Link to post
Share on other sites

Hi..ran the msi's as suggested. Message: "account already exists." Also tried repair option. Still asking for activation and controls freeze even though airplane loads normally. Only seems applicable to 737ngx variants..777 products work as normal....Frustrating indeed!

Share this post


Link to post
Share on other sites

Hi..ran the msi's as suggested. Message: "account already exists." Also tried repair option. Still asking for activation and controls freeze even though airplane loads normally. Only seems applicable to 737ngx variants..777 products work as normal....Frustrating indeed!

 

Submit a ticket at the link in my signature and we'll get you sorted. Note that if you have not created an account on the support site, you will need to create one.

Share this post


Link to post
Share on other sites

Hi Kyle.

Support ticket was already in progress in parallel with this post. Some feedback for those who may also experience this issue:

This was very difficult to track down, and I'm no computer boffin but it looks like I resolved it with some hints from the PMDG guys.

They suggested I delete all PMDG files within the Flexnet folder and re-install 737NGX which I did but without success. Then I decided to compare the FLEXnet folder on my affected PC with another PC which I also use for flight simulation. And there it was. The FLEXnet configuration settings were missing on my affected PC. I cut and pasted the FLEXnet configuration settings from my second PC and "Voila!", everything working and activated. Thanks for your support. Will stick to Windows 8.1. I think upgrading to Windows 10 with a clean PC would be preferable. Too many issues with complex applications.

 

Thanks again. Will report back to the PMDG team.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this